"Fossies" - the Fresh Open Source Software Archive

Member "cmake-3.6.2-win32-x86/share/cmake-3.6/Help/policy/CMP0056.rst" (7 Sep 2016, 1645 Bytes) of archive /windows/misc/cmake-3.6.2-win32-x86.zip:

As a special service "Fossies" has tried to format the requested source page into HTML format (assuming markdown format). Alternatively you can here view or download the uninterpreted source code file. A member file download can also be achieved by clicking within a package contents listing on the according byte size field.


Honor link flags in :command:try_compile source-file signature.

The :command:try_compile command source-file signature generates a CMakeLists.txt file to build the source file into an executable. In order to compile the source the same way as it might be compiled by the calling project, the generated project sets the value of the :variable:CMAKE_<LANG>_FLAGS variable to that in the calling project. The value of the :variable:CMAKE_EXE_LINKER_FLAGS variable may be needed in some cases too, but CMake 3.1 and lower did not set it in the generated project. CMake 3.2 and above prefer to set it so that linker flags are honored as well as compiler flags. This policy provides compatibility with the pre-3.2 behavior.

The OLD behavior for this policy is to not set the value of the :variable:CMAKE_EXE_LINKER_FLAGS variable in the generated test project. The NEW behavior for this policy is to set the value of the :variable:CMAKE_EXE_LINKER_FLAGS variable in the test project to the same as it is in the calling project.

If the project code does not set the policy explicitly, users may set it on the command line by defining the :variable:CMAKE_POLICY_DEFAULT_CMP0056 <CMAKE_POLICY_DEFAULT_CMP<NNNN>> variable in the cache.

This policy was introduced in CMake version 3.2. Unlike most policies, CMake version |release| does not warn by default when this policy is not set and simply uses OLD behavior. See documentation of the :variable:CMAKE_POLICY_WARNING_CMP0056 <CMAKE_POLICY_WARNING_CMP<NNNN>> variable to control the warning.

.. include:: DEPRECATED.txt