"Fossies" - the Fresh Open Source Software Archive

Member "Atom/resources/app/apm/node_modules/es5-ext/node_modules/es6-iterator/CHANGES" (7 Feb 2017, 1164 Bytes) of archive /windows/misc/atom-windows.zip:


As a special service "Fossies" has tried to format the requested text file into HTML format (style: standard) with prefixed line numbers. Alternatively you can here view or download the uninterpreted source code file.

    1 v2.0.0  --  2015.10.02
    2 * Use es6-symbol at v3
    3 
    4 v1.0.0  --  2015.06.23
    5 * Implement support for arguments object
    6 * Drop support for v0.8 node ('^' in package.json dependencies)
    7 
    8 v0.1.3  --  2015.02.02
    9 * Update dependencies
   10 * Fix spelling of LICENSE
   11 
   12 v0.1.2  --  2014.11.19
   13 * Optimise internal `_next` to not verify internal's list length at all times
   14   (#2 thanks @RReverser)
   15 * Fix documentation examples
   16 * Configure lint scripts
   17 
   18 v0.1.1  --  2014.04.29
   19 * Fix es6-symbol dependency version
   20 
   21 v0.1.0  --  2014.04.29
   22 * Assure strictly npm hosted dependencies
   23 * Remove sparse arrays dedicated handling (as per spec)
   24 * Add: isIterable, validIterable and chain (method)
   25 * Remove toArray, it's addressed by Array.from (polyfil can be found in es5-ext/array/from)
   26 * Add break possiblity to 'forOf' via 'doBreak' function argument
   27 * Provide dedicated iterator for array-likes (ArrayIterator) and for strings (StringIterator)
   28 * Provide @@toStringTag symbol
   29 * When available rely on @@iterator symbol
   30 * Remove 32bit integer maximum list length restriction
   31 * Improve Iterator internals
   32 * Update to use latest version of dependencies
   33 
   34 v0.0.0  --  2013.10.12
   35 Initial (dev version)