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Introduction 
MyQuery is a tool aimed at developing and running MySQL scripts on the Microsoft 

Windows platform. It can understand normal MySQL scripts, and it has a few tricks of its 

own to make running and patching these kinds of scripts easier. 

It is not intended to be a full blow really fast way of running MySQL scripts; the 

normal MySQL command line does this better and faster. But MyQuery has better means of 

running the scripts and developing and working with them, and it also runs scripts in a much 

more interactive fashion. 

In addition MyQuery has a few more unique features, like the ability to insert and 

retrieve blobs, and reading and writing large files as BLOBs to MySQL. MyQuery also has 

some MariaDB Specific features, such as support for Dynamic Columns. 

Running MyQuery 
Start MyQuery from the Start menu in the normal way after you have installed it. You 

will first see a logon box, allowing you to login to the server and optionally also choose a 

default database. 

After you have filled in a valid host, port username and password, you can use the 

combo box to list the available databases. For now, you can leave the checkboxes at their 

default values, click OK to log on to MySQL and start using MyQuery. 

What the checkboxes control are: 

 Automatic reconnect on server error – This will cause MyQuery to 

automatically reconnect if an error that requires this is encountered, see more 

in the Automatic reconnect section. 

 Use compression protocol – This is a feature of the MySQL Connection that 

you usually want to enable. 

 Set as interactive – This will tell MySQL that this is an interactive connection; 

this will make certain timeouts different if enabled; see the MySQL 

Documentation for more information. 

 Enable UTF-8 character set – This will set MyQuery to use UTF-8 Mode 

when logged in. 
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You may save connection parameters with a name by clicking on the Save as.. button. 

To retrieve a preconfigured connection setup, select it from the listbox to the right. Or double 

click it to connect with it. To modify a saved setting, just select it, then modify it and click 

Save. To delete a saved setting, select it and click Delete. 

The special Default connection setting is the last used setting for connection to the 

database. 

The MyQuery main window 
The MyQuery application consists on one main window where you control most 

activities. There are several other complementary windows, but they are all launched from the 

Main window. 

The Main window has 6 parts, from above: 

 A menubar 

 An optional toolbar 

 A list of tabs for exiting multiple files 

 A window for entering SQL queries and scripts, one for each tab 

 A tabbed section with Results, Output and Errors tab. 

 A status bar 

In the lower right corner there is a handle to allow resizing of the window and in 

between the SQL edit window and the 3 tabs is a narrow line that allows you to select a split 

between the editor and the tabs, just place the cursor on this divider and drag it vertically to 

change the size relationship between the editor and the tabs, 

The menu bar 
MyQuery has many functions, and they are accessible in multiple ways, but the manu 

bar is how most features are accessible. In addition there are keyboards accelerators, linked to 

menu options, and the toolbar, 

For more information regarding the menu options, see the section MyQuery menu 
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The editor window 
The editor is the top window below the toolbar. Version 2.0 of MyQuery introduces a 

colour coded editor, based on scintilla, which allows a much nicer editing and runtime 

environment, at the price of slightly slower performance. 

There may be more than one editor window at the time, in multiple tabs at the top. 

When a query is running, the tabs are looked though, and the Results tab is shared by all the 

editor tabs. There is always at least one editor tab open, and to close a tab, click on the X to 

the left of the editor tab label, or use the menu option File -> Close tab. 

You can create a copy of the content in a tab by using the File->Copy to new tab 

command. Also you can invoke the editor tab context meny by right-clicking on the tab and 

create a copy of the tab you point at by selecting Copy to new tab. 

Navigate between the tabs by clicking on them or by using the Control-Tab keyboard 

combination. To the left in the editor window is the line number display, this may optionally 

be disabled. The syntax colouring in configurable using the Settings->Editor preferences 

dialog. There are both several fixed sets of keywords that reflect common MySQL keywords, 

as well as 3 user defined set of keywords. The editor window supports the usual Windows 

editor commands, plus some that are specific to Scintilla. 

To make navigation between tabs easier, the initial content of each tab is shown in a 

tooltip window that pops up if you leave the mouse cursor shortly (hovering) over a tab, 

To the left of the editor window, there are 1, 2 or 3 margins. These shows, from the 

left: 

 The line number 

 Folding symbols 

 A Line marker 

 The Line number and Folding margins are optional and may be turned off. 

The line number margin 
This margin shows the line number of the current line. Line numbers may be hidden. 

The folding margin 
This margin shows symbols that may be used to fold / unfold the code current being 

shown. This is mostly used when working with stored procedures, and may be turned off. 

The marker margin 
This margin shows three different kinds of symbols: 

 The first line in the statement currently being executed. This is represented by 

a plain circle. 

 A line with an error. There may be more than one such marker, for example if 

he script is executed with forced execution. This marker is a red filled circle. 

 A user defined marker. This is set by the user by clicking in the margin or by 

pressing the appropriate key (Default is F9). This is used when running up to a 

certain point in the script, or when starting to run at some point in the script. 

This marker is a blue arrow. There is just one user marker, to move it, just 

place it on the new line you want it to be at. To remove it, click it again on the 

current line. There is also a keypress for setting the marker (default is F9). 

The Result tab 
Output from SQL commands that generate output, such as a SELECT command, are 

placed in the Result tab. A result tab may be locked to save the result for later reference. If a 

SQL command generated multiple results, such as a CALL statement, then the results will be 

placed in multiple Result tabs. 

http://www.scintilla.org/
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The Output tab 
This tab contains output from the running script when an error occurs. The errors are 

hyperlinked, so that you may doubleclick an error to have the cursor placed on the line in the 

script with the error. 

The Error tab 
This contains the text of any SQL statements in the recent script that caused errors. To 

edit these statement of rerun then, choose the File->Copy from errors menu command. At 

least one editor is always open. Open more concurrent editors using the File->New tab menu 

option or the appraise keyboard accelerator (Control-T). 

Tray progress indicator 
In the lower right part of the windows desktop is an area often called the “tray”, 

although Microsoft claims that this is not an appropriate name for this. Anyway, MySQL will 

display an icon in this area when active, and will animate this when a script is running. This 

icon can be turned off with the Show tray icon preference. 

The Statusbar 

 
The statusbar at the bottom of the window has four fields. The first field indicates the 

total execution time of the script, the second shows two numbers, the first is the current line in 

the script, the other is the total number of lines. 

The third field is a message field where messages on the currently executing query are 

shown. 

The fourth and last field shows a Warning icon if there we any warnings when 

executing the last script. If there were warnings, you can click this icon to show to bring up 

the User tool that has the "Run on warnings" attribute set, by default this is a tool that show 

the current warnings. See Configuring MyQuery user tools for more information. 

Using the keyboard 
From version 3.2, after having this pointed out to me by users, MyQuery now has 

much better properties for keyboard navigation. In the main editor window, Tab or Shift-Tab 

can be used to navigate between object, just like in a dialog box. The order of the items are: 

 The database selection box. 

 The search combo box. 

 The Editor tab. 

 The Editor Window. 

 The Results tab. 

 The Results / Error / Output window. 

Navigating the tabs 
In a Tab, such as when you have multiple editor tabs open or in the results tab, the 

combination Control-Tab and Shift-Control-Tab is used to change the active Tab. In MyQuery, 

this key combination is by default used to navigate the Editor tab, wherever focus is in the 

window. The exception, which is reasonable, is when you have focus on the Results tab, 

where these key combination always navigates this specific Tab. 

Beyond the standard Accelerators functions, which are extended in MyQuery 3.2, 

there are some special key combinations: 

 Select database – This key combination will navigate directly to the Select 

database list. 

 Focus editor  - This key combination will navigate directly to the editor 
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Displaying accelerator help 
The accelerators are user configurable, and in Default keys the default key settings are 

listed. In MyQuery there is now also dynamic accelerator help, accessible from the 

Help->Keyboard shortcuts menu option. This will show a non-modal dialog with the current 

accelerator key assignments. You may also print this by clicking on the Print button in the 

dialog. 

Default keys 
The following table lists all accelerators and the default key assignments. 

Function Default key Comments 

Open file Control-O Shows dialog for opening a file 

Save file Control-S Saves the current file 

Print Control-P Print the current script 

Print result Control-R Print the current result and, optionally, include 

the current script 

Undo Control-Z Undo current operation in the editor 

Redo Control-Y Redo the recent operation in the editor 

Cut Control-X Cut selected text in the editor 

Copy Control-C Copy selected text in the editor 

Paste Control-V Paste text from the clipboard to the editor 

Select all Control-A Select all text in the editor 

Copy result Alt-R Copy result to clipboard 

Search next F3 Search next occurrence of the search string 

Search Alt-F3 Show the search dialog 

Search and replace Control-H Show the search and replace dialog 

Set / Clear marker F9 Set or clear the user marker on the current line. 

New tab Control-T Create a new editor tab 

Copy to new tab Alt-V Create a new tab and copy the contents of the 

current tab to it 

Close tab Control-W Close the current tab 

Execute script Alt-X Execute the current script 

Force execute script Alt-F Execute current script, ignoring errors 

Execute script forward Alt-C Execute script, starting on the marker 

Execute selected text Alt-S Execute the currently selected text in the editor 

Execute to current position Alt-T Execute script up to the marker 

Dictionary F10 Show dictionary viewer 

Default delimiter ; Alt-D Set the delimiter to the default semicolon 

UTF-8 Support Alt-8 Enable UTF-8 Mode 

MySQL Help Alt-H Show MySQL Help Viewer 

Keyboard shortcuts Alt-K Show keyboard shortcuts dialog 

Next tab Control-Tab Switch to next editor tab 

Select database F5 Navigate to the database selection list 

Focus editor Alt-E Navigate to the editor 

Show keyword help F1 Show help for current keyword 

Show autocomplete list F12 Show list of database object names that match 

the current word. See Autocomplete 

Beyond these assignments, any user defined tools may also be assigned to keyboard 

accelerators. 
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Autocomplete 
MyQuery 3.5.0 and up supports Auto Complete of database object names. This means 

that you can easily access a list of matching words for a table name, column name, database 

name or routine name. There are different ways to pop up this list, and as this is a new feature, 

there is some fine tuning to do here, and in order to make this possible, this feature, as most 

other features in MyQuery, is highly configurable. 

The list will find only relevant matching names, and it also knows about dot notation, 

for example if you type a.b then we know that b cannot be the leading part of a database 

name. The different ways to pop up a list are: 

 Manually - This is used when you really need to show matching names for 

example when you only know very few characters at the start of say a table 

name. The key to press is the Show autocomplete list and the default key for 

this is F12. 

 After a certain number of leading characters - The number of characters is 

configurable, and the default is 5. This means that if you type 5 characters and 

there is one or more matching names found, the list is shown. 

 On . (period) - This means that the list is shown when a . is pressed and the 

word before the . is a known entity or aliases are enabled, then a list of 

matching words are shown. 

If you do not like the autocomplete list functionality, is can be disabled, although you 

may still use if by pressing the Show autocomplete list hotkey. When the autocomplete list is 

shown, you can do one of three things: 

 Continue to type as usual, in which case the list will remain but will be filtered 

according to what is typed. 

 Cancel the list by pressing escape (but when you type again, and a match is 

found, the list will reappear). 

 Select a name in the list using the arrow keys and inserting it in the text by 

pressing return. 

Printing 
MyQuery supports printing of both script and result from version 3.2 and up. Printing 

of the script is implemented mostly by Scintilla, whereas printing of the query results is 

implemented inside MyQuery itself. Three menu options are associated with printing. 

Page setup 
This menu option will bring up a dialog that allows you to set up the basic format of a 

printed page. 

The most important setting here is the page margins, except for this, this dialog works 

as it does in most other Windows programs. 

Print 
This command will bring up a standard print dialog that allows you to print the current 

script. This printing is handled by Scintilla and supports colour coding, so if you use a colour 

printer, the printout will be colour highlighted, just like on the screen. 

Print result 
This command will bring up a dialog that allows you to print the result in the current 

result tab. Optionally, you may also print the current script, but note that result and script isn’t 

inherently linked, so to print the script that produced the output, the appropriate script tab 

must be selected for this to work. 
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Printing may cover multiple pages, both horizontally and vertically. If a large column 

will not fit on a page, a new page, horizontally, will be created. The maximum size of any 

printed field is a full page, if there is more data than this it will be truncated. 

If a script is printed with the result, this is printed first. If 2 rows or more will fit on the 

same page as the script, then these will be printed on the same page as the script. 

Online Help 
MyQuery 3.4 introduces OnLine help. The help content is based on the help that 

comes with the MySQL Server in the help_xx tables in the mysql schema. The help is 

available in 3 shapes: 

 Help viewer – Allows you to read and browse for online help. 

 Hoovering popups – Hoover with the mouse over a keyword, and help is 

displayed in a Tooltip style window. 

 F1-help – Mark a keyword and press F1, and help for that keyword is 

displayed in the Help viewer. 

Using the Help Viewer 

 

The OnLine help in MyQuery is data that is picked up from the database that 

MyQuery is connected to, and which is stored in tables prefixed with help_ in the mysql 

schema. For this reason, OnLine help looks different than in many other Windows 

applications, but this also means that the OnLine help is always up-to-date with the database 

server that MyQuery is connected to. 

To browse for help, you use the Help Viewer accessible from the Help->MySQL Help 

menu option. Selecting this will bring up the Help Viewer, which is a non-modal Window 

The Help information can be browsed either by keyword, by selecting the Keywords 

tab or by Category by selecting the Categories tab. Which even way you chose to browse 
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help, when selected a number of topics is displayed in the Topic list to the right. Now you 

may selected a topic to see the description, and sample and possibly a clickable URL below 

the Topics list that corresponds to the selected topic. 

Help may be loaded automatically when connecting to the server, or it may be fetched 

when opening Help for the first time, and this is configurable. 

Hovering for help 
This is online help, determined from the same help source as when using the Help 

Viewer. When the mouse is over the editor Window and is not moving for a predefined time, 

help for the topic represented by the keyword the mouse is over, is displayed. This may be 

turned off, as is the time the mouse should hoover (or dwell) before showing the help. 

Help when pressing the Help key 
This help is OnLine, like when Hovering, but the difference is that this help is shown 

on Demand only (usually when pressing F1, but this is configurable), and that the help is 

shown in the Help Viewer. 

The Help is also based on the Keyword help, which in turn may be linked to more than 

one Topic, which is why this help is more complete than the Hovering help. 

Information and dictionary functions 
MyQuery has several functions for showing information on the running script, the 

database server environment, sessions and other things, and also allows a level of control over 

these. In addition, the dictionary functions are a good help when writing SQL. 

 Most of these dialogs are new from MyQuery 3.0, and most of these dialogs are non-

modal, which means they can remain open even when you are editing or running statements 

in the main window, see more in the section Non-modal resizable transparent dialogs. 

InnoDB Status 
This dialog in accessed from the Status->InnoDB status menu option and show the 

output of the InnoDB Status command as a block of text. In a future release, it is planned to 

have MyQuery group and interpret some of this information, for easier access. 

Clicking the Refresh button will cause the status to be refreshed (surprise!). 



MyQuery 3.5.6 Beta  Page 15 of  69 

 

 

Global and Session Status 

This is accessed from the menu options Status->Global status and Status->Session 

status menu options respectively and show the output from the commands SHOW GLOBAL 

STATUS and SHOW SESSION STATUS respectively. 

These dialogs have several means of organizing the status information you are 

inspecting, to make it easier and more effective to work with the information: 

 Show only checked – This will only show the status output that you have 

checked. To check status values, uncheck this box to see also non-checked 

status values (other filers are still active), check the values you want to see, and 

the select Show only checked again. 

 Show only change since previous – The status list keep three lists of values, 

current, previous and first, which allows you to get both total and “lap time” 

values. With this option enabled, only values that have changed since the 

previous sample are shown. 

 Show only changed since first – This is will only cause values that have 

changed the first round / reset to be shown. 

 Filter- Setting this (case insensitive) will cause only status variable names that 

begin with the specified string to be shown. Starting the filter with a * will 

match the filter inside the variables name. 

 Auto refresh – Click this to autorefresh the content for the number of seconds 

specified. 

Note that all these types of filters are applied “ANDed” together, so that if the filter is 

set to the string “q” only will case the values beginning with “q” to be displayed, but if only 

of these, “Questions” is checked, and Show only checked is selected, then only the 

“Questions” value will be shown, even of more values, that do not begin with q, are checked. 

Clicking the Refresh button will get another “lap time”, clicking Reset will set the 

“First” value. 

You can choose what values to see, including deltas from the first and previous run, by 

right-clicking in the header of the listbox, and choose the values you want to view in the 

dialog that pops up. 
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Another way of organizing what is viewed is to create groups of variables. A group is 

created by clicking the New group button and giving the group a name. The variables you 

want to be part of the group are then "dragged" from the list of variables. The All group 

contains all variables, but variables can be moved by dragging between all groups. To remove 

a variable from a group, drag it to the All group. 

Server variables 

 

MySQL Server variables can be viewed by selecting the Status->Server variables 

menu option. Server variables are grouped in categories, to ease access to the many settings. 

Just like with the Global and Session Status dialog, you may select the variables you want to 

view, and then hide all othe rs. The variables that are marked with a blue name have a link to 

the appropriate online documentation, just double-click on the name, and you are taken 

directly to the correct webpage. 

The Filter is used to show only variables whose name begins with the specified filter, 

or if the filter begins with a *, all variables whose name contains the filter string. 

Processlist 
This dialog will show the result of a SHOW PROCESSLIST command in a dialog 

box. The list can be refreshed by clicking the Refresh button. To see a FULL processlist, 

check the Show full processlist checkbox. 

If you right-click on a process, you will get a menu with three options: 

 Show query – This will display a dialog box with the query in question, 

including Kill query and Kill connection buttons. 

 Kill query – This will issue a KILL QUERY command on the session in 

question. 

 Kill connection – This will kill the connection. 
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You can sort the processes by clicking on the list headers, the sorting is changed 

between ascending and descending each time you click on a header. 

SQL Statements 

This dialog shows the same information as the Processlist dialog, but it is organized in 

a different way. To begin with, the statements that are displayed in this dialog have any 

embedded literals, such as numbers and strings, removed, and are replaced with question 

marks. Secondly, in this dialog, unique statements are counted only once, and this is after the 

literals have been removed, so a statement that is executed from two sessions, with different 

literal values but with the same statement, will be counted as being executed twice. 

Another difference is that this dialog shows the history, so even statements that are not 

currently executing are displayed. The history can be cleared by clicking the Reset button. 

The dialog keeps track of how many times a statement has been executed, how long it 

takes to execute in total and the maximum execution. Also, the latest “full” statement, i.e. the 

one which still includes the literals, is also saved, as well as the last session that executed the 

statement. As in the Processlist dialog, the statements displayed can be sorted by clicking on 

the headers. 

The contents of the list can be refreshed in two ways, either by clicking the Refresh 

button of course, or by enabling automatic refresh, by choosing an appropriate interval in 

seconds and checking the Automatic refresh checkbox. 

As for the data in the dialog, it is important to understand that the information comes 

from executing SHOW PROCESSLIST, which means that fast running statements may well 

be missed. In an upcoming release of MyQuery, I will optionally include the ability to use the 

general log for this, but current, this is not implemented. 
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SQL Profile 

This dialog, accessible from the Status->Profile menu option, allows you to see the 

query profile, as reported by the SHOW PROFILE SQL command. This dialog has a few 

useful features. To begin with, is shows all profiles that are available with just one click. 

Secondly, it allows you to sort the different values, just click on a column and it will 

be sorted. In the example dialog shown, a MySQL server on Windows is displayed, and there 

is limited amount of information on Windows specifically. Of all the columns that are 

returned, if all values are NULL in a column, that column is not shown at all. You may also 

select which columns you want to display by right-clicking on the column header, and a 

dialog with all available columns will be displayed. 

If you check the Group by Status checkbox, the left list will only show the summary 

by each status. In many cases, there is just one row per status, but in some cases, this is not so, 

and you may then want to see all status values in summary. 

Comparing statement profiles 
Finally, one thing that this dialog allows you to do is to compare the profile of two 

queries. Just select one of the queries in question in the list to the left, and the select the other 

one with the Control key down, the usual means of selecting more than one entry in a list that 

is. Doing this will show the difference in total, as well as per Status. When comparing 

statement profiles, Group by Status is always enabled. 

Dictionary 
Accessible from the Tools->Dictionary menu, this dialog allows you to browse the 

MySQL data dictionary. The dialog use the INFORMATION_SCHEMA tables, so this means 

that this dictionary viewer will not work with versions of MySQL that doesn't support this 

(i.e. before version 5.0). 

The supported objects that appear in this viewer are Database, Tables and Views with 

Columns and Triggers, Stored Procedures and Events. Tablespaces are not yet supported. 
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Open the Database to see the objects in each database and use the dialog to dive into 

the dictionary with Tables, Views, Columns etc. If you hover with the mouse over the objects, 

you see some more data in the information tooltip. If a script is running, certain actions (such 

as pasting to the editor) are disabled. 

More information on each object is show in the right of this dialog. In the CREATE 

tab for every object, a CREATE statement for the object is shown. In the tree view you may 

drag an object to the editor, which will paste the fully qualified name of the object where it is 

dropped. You may also right-click on an object in the tree view to bring up a menu where you 

can copy the name or the CREATE of the object to the editor. 

Finally, you may double-click on an object, and the action here is determined by 

settings in the Dictionary preferences dialog. 

Creating and running scripts 

Basic running of scripts 
To create a script, just start writing it in the top SQL Edit window. By default the 

command delimiter is a “;”, a semicolon, just like in the case of the MySQL commandline. 

You can change this with the delimiter command, again just like the MySQL commandline, or 

by changing Preferences 

When you have written the SQL statement or statements, you can run it in one of four 

ways. 

 Press Alt-X (The default key combination) 

 Choose the Menu option File->Execute 

 Click the icon in the toolbar 

 Click the down arrow to the right of the toolbar icon and select Execute 

If your statement executed without errors, you will see the result from the latest query 

that returned any data in the results window. You can select the Tools->Script information 

menu to show information on your script. 

Script markers 
There are markers in the script, to the left of the editor area, and these are used to 

show error statements (a red circle), the currently executed statement (a circle) and a user 

marker. 

The user marker is used when starting from, running up to a particular point in the 

script or running the current statement. The error marker shows the first line of statements 

with errors, and the current marker indicates the first line of the statement currently being 

executed. 

Markers may be cleared with the View->Clear all markers menu option. 

Script indicators 
A script indicator is an aid when there are errors in the script. MyQuery will try to 

identify the position and length of that fails part of the statement, and will mark this with an 

indicator. The default indicator is a squiqqly line under the error, but this is configurable. 

The current indicator may be cleared using the View->Clear indicators menu option. 

Other ways to run scripts 
You have other choices of running scripts with MyQuery than running the whole 

script, in addition to an option of “forced” execution, which will continue to run even if there 

are errors, you can also run selected commands and start running from a specific statement. 

Forced execution 
Normal execution of a script will stop if there is an error, unless you have set the 

preference to ignore errors, in which case normal execution and forced execution is the same 
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thing. Forced execution will continue to run, even if there are errors. In difference to running 

a script from the commandline, you can still work with this. Errors will appear in the Errors 

tab, and you can click on an error to get to the offending statement. 

Also, any failed statements are written to the window in the Errors tab. If you want to 

run the offending statements, after having corrected them, then just click the File->Copy from 

errors menu option, and all the statements that executed with errors will be placed in the SQL 

Edit window. 

Forced execution is initiated by: 

 Pressing Alt-F (default) 

 The File->Execute force menu option 

 Click the down arrow to the right of the toolbar icon and select Execute 

force 

Run selected statements 
If you want to run just a portion of a script, the just select that using the normal 

Windows keyboard or mouse actions for selecting text, and then either: 

 Press Alt-S (default) 

 Select the File-Execute selected menu option 

 Click the down arrow to the right of the toolbar icon and select Execute 

selected 

When running a selected part of a script, the three tabs, Result, Output and Errors 

works just like before. The errors in the Output tab are still clickable. 

Run current statement 
This command will run the statement that currently has the user marker. If the user 

marker isn't set, then it is set at the first statement in the script and after executing the 

statement the user marker is moved to the statement following this. After the last statement 

has been executed, the marker is removed. Using this command you can single step through 

the statements in a script. This command is executed by: 

 Press F-10 (default) 

 Select the File-Execute current menu option 

 Click the down arrow to the right of the toolbar icon and select Execute 

current 

Run forward from the marker or current line 
This is a particularly useful feature when developing scripts. It allows you to start or 

restart running a script from a point in the script. Just place the user marker in the margin or 

the cursor in the statement where you want to continue to run and start forward execution as 

described below. When there is an error in a running script, MyQuery will automatically place 

the cursor on that statement, so this makes managing large scripts easy, just run it, and when 

you have an error, the cursor is just where you need to make you adjustments and when done, 

you can continue to run from where you left off. 

Start forward execution of a script by: 

 Press Alt-C (default) 

 Select the File-Execute from current statement menu option 

 Click the down arrow to the right of the toolbar icon and select Execute from 

current statement 

Run to the marker or current line 
This is another useful feature when developing scripts. It allows you to start running a 

script from the beginning, up to, but not including, the line with the user marker or the current 

statement. Just place the user marker on the line or the cursor in the statement after the last 

statement you want executed. 

Start running to the current statement in a script by: 

 Press Alt-C 
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 Select the File-Execute from current statement menu option 

 Click the down arrow to the right of the toolbar icon and select Execute from 

current statement 

Error handling 
When an error occurs in a script, and unless you are running forced execution or have 

turned this on by default in the preferences, an error dialog will show up. This will show 

information about the statement that was in error, which line it appear on in the script and 

some more information. 

If you are using InnoDB and you get an InnoDB error, for example a Foreign Key 

error, you will want to have a look at InnoDB status. With MyQuery you don’t need to issue a 

separate command for this, just click the InnoDb Status button on the error dialog. 

You can always look at InnoDB status by selecting the Tools->Innodb status menu 

option. 

Other options in the error dialog are: 

 Stop, which will halt execution at the current statement 

 Ignore, which will ignore the current error and continue to process the script 

until it ready or another error occurs 

 Ignore all, which will continue to run the script and ignore any errors, just like 

with Forced execution 

 Retry, which will Retry the current statement 

 
If execution is stopped, the cursor will be placed on the last failed statement in the 

SQL Edit window. Execution of a script may also be stopped by clicking the icon on the 

toolbar or selecting the File->Cancel menu option. Note that this will only stop the script in 

between statements if you are running in single connection mode, when in Dual Connection 

mode, the currently executed statement will be stopped. 

When there is an error, whether you choose to skip past them as in Forced execution 

or you stop at them, they are listed in the Output window. The blue underlined link can be 

clicked and the cursor will be placed on the first line of the statement with the error. 

Statements with errors will also always be show in the Errors tab, and this can be copied to 

the SQL Edit window with the File->Copy from errors menu option. 

Working with script files 
Scripts are typically saved in and loaded from files. Use the File->Open, File->Save 

and File->Save as.. menu options appropriately, or use the appropriate toolbar icons,   for 

opening and for saving files. To start a new clean script, use the File-New or click the 

toolbar icon. 
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If you want to save the result from a SELECT to a file, use the File->Save Result 

menu option. This will save all the retrieved data in a coma separated files, data vales 

enclosed in double quotes. The first row will contain the column names in the same format. 

Dos and Unix format files 
MyQuery can handle files using both DOS / Windows format files (where a linebreak 

consists of a carriage return, ASCII 13 followed by a line feed, ASCII 10) and Unix format 

files (where a linebreak is represented by a linefeed, ASCII 10, only). Internally, the format is 

always DOS / Windows format, as this is what is the default with the Rich Edit control. 

You can see in the code that I in most places check for a carriage return only, 

optionally followed by a linefeed. There are two reasons for this. One reason is to prepare for 

Mac format files (where a linebreak is represented by a carriage return, ASCII 13, only). The 

other reason is that when copying from the Rich Edit control, for some reason, this is the 

format in the contents are being copied. Don’t ask me why. 

The default format is by default set to DOS format files in the preferences. This 

doesn’t mean all files have to be in DOS / Windows format. MyQuery will detect the format 

when a file is opened, and it will always be converted to DOS / Windows format 

automatically it necessary. When saving a file, by default, if this was a file that was originally 

read in, then it will be saved in the original format by default. Again, this can be turned off in 

the preferences, this is the “Retain file format” setting. 

And you have yet another option to control the file format. This is when you use the 

“Save as..” dialog. This will allow you to select the file format, DOS / Windows or Unix, you 

want to save the file in, the default being controlled by the preferences as mentioned above, 

but the “Save as type” combobox has one “SQL file” and one “Unix SQL file” setting, to 

allow you to override this default. 

Search and replace 

There is a search function built into MyQuery, as well as a Search and Replace 

function. The search function is available both from the Edit->Search menu option, and from 

the leftmost toolbar combobox. The latter is a convenience search that uses the same options 

as was last set for searching from the separate search dialog. 

The Regular expression checkbox uses the normal Unix regular expressions for 

searching. 

Search and replace is available from the Edit->Search and replace menu option. This 

supports the same search options as the search dialog, but you may replace the search text in 

the same dialog, and also replace all occurrences of a the searched text on one go. 

File associations 
The MyQuery installer can optionally associate .SQL files with MyQuery so that when 

you double-click on a .SQL file in Windows explorer, MyQuery will start and load this file. If 
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you want to add this association after having installed MyQuery, this is available by using the 

Settings->Associate SQL Files menu option. 

Bookmarks 
MyQuery 2.2 and up supports Bookmarks. A SQL file bookmark works much like the 

bookmarks in a Web browser, but references local files instead of Website of course. You 

access the bookmarks feature from the “Bookmarks menu”. This menu has two parts, the 

upper three menu items are always present and are used to manage your Bookmarks. 

Under the divider, and Bookmarks you create will be accessed. Selecting a saved 

Bookmark will read the corresponding bookmark file into the editor. 

Organize bookmarks 
This dialog, accessed from Bookmarks->Organize menu, is the most powerful means 

of organizing your bookmarks, but it is also the most complex one. Use the Add folder button 

to create a bookmark folder in the current folder, this will show up as a Submenu in the 

Bookmarks menu. The Add bookmark button will allow you to add a new Bookmark to the 

currently selected Folder in the tree-view to the left. 

When adding a bookmark, the default name is derived from the filename that the 

bookmark references, it is the filename minus the path and extension, but it can be changed to 

anything you desire. 

The Delete button will delete a Bookmark or folder and the Edit button will allow you 

to edit it. Double-clicking on a Bookmark (but not a folder) will also bring up the 

corresponding edit dialog. You can edit the name of any item by clicking the name and the 

“hovering” (stay with the mouse over the name), just like in Window explorer. 

You can reorganize bookmarks and folders by dragging them. If you drag a bookmark 

onto another, the dragged bookmark will be placed after the one it is dragged to. 

The Validate all button will check that the files in all bookmarks are valid. Any 

bookmarks with invalid files, i.e. that don’t exist, will be marked with bold text and are 

displayed. 

Add bookmark to folder 
The Bookmarks-Add bookmark to folder option will bring up a simplified dialog that 

will allow you to add a bookmark to a folder only. New folders may also be created, but in 

other aspects this dialog works much like the Add bookmark dialog in the Organize dialog. 

Add to folder Bookmarks 
This menu option, which is just under the Bookmarks->Add bookmark to folder one, 

is dynamic, i.e. the name of it changes. This is used to add a bookmark to the most recently 

used folder in the Add bookmark to folder dialog. 

When this option is selected, no dialog is shown, the Bookmark will be automatically 

added to the Recently used bookmark folder (or the main “Bookmarks” folder) and the name 

will be the filename of the current file, excluding the Path and the extension. 

Working with results 
Result output can be saved to files in CSV or JSON format, individual fields can be 

view in detail and there is also support for multiple results and for locking results. 

Multiple results 
When you issue a query that returns multiple resultsets, typically this is the result of a 

CALL of a stored procedure, you will see added tabs in between the Result and the Output, 

labeled Result2, Result3 etc, one for each returned resultset. If the following query will return 

fewer resultsets, then the extra tabs will be removed, but there will always be at least one 

Result tab. 
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The Max resultsets preference is a setting to limit the number of resultsets that are 

displayed, but note that all Resultsets are always retrieved, this is a requirement by the 

MySQL API. 

Locking results 
Sometimes you want to save a resultset for reference, not save it to a file, but to look 

at it later in the same session, without rerunning the SQL statement that produced it. You do 

this by clicking on the grayed “Lock” icon on tab of the corresponding Result tab. If there are 

multiple result tabs, such as after a MySQL Procedure CALL, you can lock any or all of the 

results. When a new SQL statement is run, the locked result-tabs will remain. To remove a 

locked Result tab, just click the “Lock” icon again. 

A current, but locked, Result tab will not be removed by clicking the “Lock” icon, it 

will just be unlocked. 

If you do not have the Overwrite results preference setting on, then every new result 

set will be placed in a new Result tab, and existing tables will be locked automatically. You 

have lock / unlock several tabs by right clicking on the Tab heading and select the appropriate 

action from the popup menu. 

Viewing column data 

To view data in some more detail, and to enable you to save data from a column in a 

file, double click, or right click and select the Show data option in the menu, on the field you 

want to view and a dialog with the column data will be displayed: 

This dialog shows information on the data, and the title contains the column name. To 

view the data, click on any of the three Show buttons at the bottom of the dialog. Clicking 

Save Data will bring up a dialog where you can save the column data to a file. If the column 

contains Dynamic Column data, then clicking Save JSON will save the dynamic column as a 

JSON file. The Show buttons shows the column data in an expanded version of the dialog, and 

works like this: 

 Show data – This will show the actual textual data as returned from MySQL. 

 Show UTF8 – This will convert UTF8 data to a format acceptable by Windows 

and display this properly. This button is only enabled when running in UTF8 

mode. 

 Show Hex – This button will show the hexadecimal representation of the 

textual data in the column. Note that for numeric data, this will not show the 
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hexadecimal data itself, but a hexadecimal version of the corresponding text, 

which is not the same thing. 

 Show Dyncol - If the column contains dynamic column data, clicking this 

button show dynamic column data as a tree. 

 Show JSON - If the column contains dynamic column data, this button show 

the dynamic column data as JSON. 

To the upper right there are four buttons that you can use to navigate data, so for 

example you can view data in the next row, but the same column, by clicking the v (down) 

button. 

Saving results to file 
To save the current result to a file use the File->Save result as CSV or the File->Save 

result as JSON to the save to a file in CSV or JSON format respectively. The settings for 

saving to file are determined by the settings in Settings->General preferences->File in the 

Output file settings section. 

In some cases you might want to test a specific file format setting or save a single file 

with some specific options, and then you can use the File->Advanced Save result menu option 

that shows a dialog with all the individual save file options that you can change, without 

affecting the default output file settings. 

The settings in this dialog are the same as the ones in the Settings->General 

preferences->File settings for output files, with the exception of the JSON format checkbox, 

which control the format of the output file, the default being CSV. The “Save result” button 

saves the result to the specified file, the “Save options” button saves the settings as the futire 

defaults. 

Copy result to the clipboard 
You can copy result to the clipboards and paste it as text into any other application. 

For this, use the Edit->Copy result command, or right click in the result and select Copy 

result, to copy the current result using the current parameters to the clipboard, or the 

Edit->Copy result as command, or right click on the result and select Copy result as, to copy 

after setting the parameters to copy with. 
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You also have the option of copying a single column to the clipboard. To do this, right 

click anywhere on the column you want to copy in the result, and in the popup menu select 

Copy column. When copying a single column, the data is copied as it is without using any 

enclosing character or column name headings. 

Script history 
Every time a script is executed, it is placed in the history, unless this has been 

disabled. A certain number of statements are placed in the history, which is configurable. To 

navigate the statements in the history, use: 

 To move backward, use the View->Back or the toolbar icon. 

 To move forward, use the View->Forward or the toolbar icon 

In some cases, you might want to push an unfinished statement temporarily to the 

history to execute another command, so you can bring it back later. Use the View->Push to 

history or the toolbar icon for this. 

Working with BLOBs 
With MySQL working with BLOB data is not that easy. To insert binary data, this 

needs to be properly escaped, and if the file is large, this binary data will be a very long string. 

Getting BLOB data out of MySQL and into a file using the MySQL commandline is also not 

that easy. With MyQuery, this has changed, using two nifty features. 

Inserting BLOB data 
To insert binary BLOB data from a file into MySQL, you just have to drag the file to 

the SQL Edit window. MyQuery will encode the binary data appropriately, slit it up in chunks 

concatenated by the CONCAT command and will also handle one character which is not a 

problem for MySQL, but which is a problem for the Rich Edit control used as the SQL Editor 

in the current version of MyQuery. 

To insert a binary datafile into MySQL, actually, the file doesn’t HAVE to be binary, it 

will work fine with any file, text as well as binary, the first write the basics of the command 

you want to execute. Let’s assume that we want to insert a new row into the table tb that has 

two columns, c1 which is an auto-increment integer and c2 which is a BLOB column, then the 

statement would be something like this, excluding the blob: 
INSERT INTO tb(c1, c2) VALUES(NULL, ) 

What is missing here is the escaped binary string between the last coma and the last 

parenthesis. Now, Open Window explorer, or some other program that allows you to drag files 

from it, select the file you want to insert, and pull the cursor, while holding down the left 

mouse button, over the MyQuery SQL Edit window. When the cursor reaches the SQL Edit 

window, you see that the shape of it changes. Place it the appropriate place in the SQL 

Statement above and release the mouse button. You will see some binary data, representing 

the file you just dragged, being inserted. 

You can now execute the statement and the binary data will be inserted into the table. 

It will not look nice in SQL Edit window, but this is because the Rich Edit control doesn’t 

format binary data appropriately, the SQL statement will still work. 

Selecting BLOB data 
Getting BLOB data out from MySQL is even easier with MyQuery. Just issue a select 

statement that will return some BLOB data. You will not see the full binary data in the Result 

tab, and that is just as well, and this is not reasonable information anyway, and the grid 

control is not good for reading large amounts of data. 



MyQuery 3.5.6 Beta  Page 27 of  69 

 

 

Data in database columns is limited to 50 characters wide by defaults, but this may be 

changed. But this is only the displayed width. To extract binary data to a file, using the 

example tables above, issue the following command: 
SELECT c1, c2 FROM tb 

 

 

I assume you don’t have too many rows in this table. Now, in the result grid control, 

assume that we get the following data: 

Now, to get the binary data for column c2 from the row where c1 has the value, 1, 

doubleclick on this row on c2 column, and you will see the Show column data dialog. Use the 

Save data button in this dialog to save the BLOB to a file. 

MyQuery script commands 
In a script, you can use three types of commands. 

SQL Commands 
These are the standard SQL commands that are available from any SQL Client. These 

are passed as is from MyQuery to the MySQL server, with one exception. 

Versioned segments in SQL commands 
SQL commands may contain versioned segments. These are segments that are valid 

parts of an SQL statement from a specific version. Usually, these segments are passed as is to 

the server, and the server determines if it should run this segment or not. You have seen this is 

files produced by the mysqldump tool for example: 
/*!40000 ALTER TABLE `mytable` DISABLE KEYS */; 

This also how MyQuery handles these segments by default, they are just passed on as 

is to the server. But MyQuery can also process these segments itself, in three different ways: 

 Ignore these segments completely, they are never passed to the server. 

 Always pass them to the server, in this case the comments are removed and the 

commented command is passed as it. 



MyQuery 3.5.6 Beta  Page 28 of  69 

 

 

 Assume a specific MySQL version. In this case, MyQuery will process the 

version identifier and compare it to a version set by the user, and if the 

commented version matches or is lower than this set version, the segment will 

be passed, without comments, else it will be ignored. 

Internal MyQuery commands 
These are commands that are executed by MyQuery itself. Currently there are only 

two such commands, and they correspond to MySQL commandline commands: 

The USE command 
The USE command is used to set the current active database, just like with the 

MySQL command utility. If not set when running a script, the currently selected database will 

be used. 

The DELIMITER command 
This will set the delimiter in the script. The default is a semicolon. 

The SOURCE command 
This command will execute the SQL script commands embedded within a given SQL 

file. The SOURCE command is followed by the name of this file, which might be a full path 

or related to the current path. 

Command executed in the sourced file will be displayed as executed in the edit 

window, and then the script ends or an error occurs, and execution is passed back to the 

original script, the original script will be redisplayed. The called script is placed in the script 

history though. 

Any errors in a called script are logged to the Output tab, together with the filename. 

When clicking on an error in a SOURCE script, the script will be loaded into the editor and 

the cursor is placed on the offending statement, just as usual. 

The SOURCE command is particularly useful when using SQL to generate SQL. 

Internal MyQuery commented commands 
These are commands that are specific to MyQuery. To allow these commands to 

appear in a script that may also be executed by the MySQL commandline program, these 

commands are commented, and the comment contains a prefix that flags these commands as 

being MyQuery specific commands. The prefix is /*MYQUERY, and an example of such a 

command in a script could is: 
/*MYQUERY HIDE_OUTPUT */ 

The available commands are: 

HIDE_OUTPUT and SHOW_OUTPUT 
These commands will turn off and on output of a command to the Output tab. 

RETAIN_DELIMITER and DONT_RETAIN_DELIMITER 
These commands will turn the Retain delimiter flag on and off, respectively, in a 

script. 

RETAIN_DATABASE and DONT_RETAIN_DATABASE 
These commands will turn the Retain database flag on and off, respectively, in a script. 

OUTPUT_FILE and CLOSE_OUTPUT 
The OUTPUT_FILE command will start writing SQL output to the specified file, and 

this commence until the CLOSE_OUTPUT command is encountered or the script finished 

processing. The output of these commands follows the File result preferences. 

SPARSE_OUTPUT_FILE and CLOSE_SPARSE_OUTPUT 
These commands are similar to the OUTPUT_FILE and CLOSE_OUTPUT 

commands, but whereas the former produces result in a more human readable, columnar 

format, these corresponding SPARSE commands only output to file the exact results of the 
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SQL statements, i.e. no fillers, no column headers etc. This is particularly useful when using 

SQL to generate SQL. 

User defined tools 
MyQuery Version 3.3 introduces the ability for the user to define their own tools. A 

tool appears in the Tools menu. Tools may be of several types, some a really easy to set up, 

where other types of tools require development. 

For defining and configuring user defined tools, see 

SQL SELECT tool 
This type of tool will run a predefined SELECT statement and show the results in a 

dialog. 

SQL Script tool 
This tool will run a script defined by the tool. 

SQL File tool 
This tool will run a predefined SQL file, much like the SQL Script tool, but using a 

file instead of specifying a script. 

Web link tool 
This tool will open a webpage with a specified URL when selected. 

Plugin tool 
This tool will run a plugin, which is a Windows DLL that is written to support 

MyQuery using the MyQuery Plugin API. 

External program tool 
This is a tool that is really a program external to MyQuery, and may be passed 

arguments defined by the tool itself that are either constants or are values that reflect the 

current environment, such as the database name. 

Tool group 
This is not a tool per se, but a way to organize other tools in. 

Builtin user tools 
If MyQuery was installed with plugins enabled, then a set of user defined tools are 

defined by MyQuery. In addition, there are some tool samples, but those are not described 

here. 

Break Long Lines 
This is a simple tool that was available as a built-in before Version 3.3. It will split a 

SQL script with long lines into shorter lines, keeping string, comments etc intact. 

Memory Info 
This tool in mainly for debugging, but may be an aide in some other cases also. It will 

show the current memory usage by MyQuery in a non-modal dialog. 
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InnoDB Locktree 

This tool will show a dialog that shows the Lock tree of the InnoDB Row locking 

system. This tool requires the INNODB_LOCK plugin. Two types of objects are shown, locks 

and transactions waiting for them. Note that only transactions that are waiting are shown, as 

well as only locks with waiters. This is due more to how these information schema tables 

work in InnoDB than anything else. 

Also note that for the top level transactions, i.e. the ones that hold one or more locks 

but isn't waiting on something, the statement shown is not necessarily the one that caused the 

lock, but rather the current statement in that transaction. 

Miscellaneous features 

Tabbed editing 
You can edit multiple scripts at the same time, by opening multiple Tabs. You can 

switch between tabs using the Control-Tab keyboard combination or click on the appropriate 

tab above the editor window. The different tabs are completely independent. 

When a script is running, most attributes of the tabs are disabled. You may switch beet 

and view the different editor tabs, but all other actions are disabled. 

The tabs share a single connection, which is the reason for this. Also, all scripts share 

one result output. If you run a script in one tab, and want to persist that result for later 

reference, then you must lock that result tab, see Locking results. 

Tabs may be opened and closed by using the File-> menu commands, by using the 

accelerator keys or by using the quick menu that pops up when you right-click on the editor 

tab itself. 

Dual connections 
The way this works is that when you have 2 connections, one is used for running 

queries in the query window, and only that. Everything else, like Status dialogs and the 

Dictionary viewer, use the other connection, so even if you have long running queries, you 

can still look at the dictionary and view database status. 

The #1 feature that this enables though, is the ability to interrupt a long running query, 

without breaking the connection to the database. 

Automatic reconnect 
Certain errors from MySQL will require you to reconnect to MySQL. This is true for 

example if the server goes down. In those cases, in Automatic Reconnects are enabled, this 

reconnection will happen automatically in the background, you just run a query as usual, and 

if such an error occurs, a reconnection will be attempted, and the query will be executed 

normally. 
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Non-modal resizable transparent dialogs 
MyQuery 3.0 adds several new information and dictionary dialogs, and most of these 

are modal. Also, most dialogs in MyQuery, where appropriate, are resizable, indicated by a 

“resizable” indicator in the bottom right corner. 

 To resize a resizable dialog, just drag the indicator in the lower right corner, or 

any of the sides of the dialog. This is true even for the few resizable modal 

dialogs. 

 Non-modal dialogs may be parented either by the editor itself, in which case 

these dialogs are always on top of the editor. As these dialogs are intended to 

remain open even while continuing to edit, this may be annoying, to these 

dialogs may optionally be parented by the desktop. See also Floating modeless 

dialogs. 

 To have the non-modal dialogs not completely cover the editor window, you 

optionally set these are being transparent, and you may also set the 

transparency level. See Use transparent dialogs and Transparency level. 

 When you have the desktop parenting the nonmodal dialogs, these may 

“disappear” behind the editor. Just use the menu option or accelerator key to 

open them “again”, and they will appear in the same position as before, but on 

top of any other window that is hiding them. Also, you may “Alt-Tab” to them. 

Script search function 
There is a simple search function in the current version of MyQuery. This is available 

in from the Toolbar and work in the obvious way. Type in the text to search for and press 

return. Press return again to search for next occurrence. If you have Focus in the Edit window, 

you can search for the string in the Search combobox by pressing the F3 function key, just as 

usual in Windows applications. 

Using the Edit->Search or the Edit->Search and replace command give you more 

control. The search menu bar follows the settings last set in these dialogs. 

The toolbar 

 
The MyQuery toolbar can optionally be turned off, by the View->Toolbar setting. The 

toolbar has 8 buttons and 2 comboboxes. All the buttons represents shorts cuts to commands 

available also as menu options. The two combo boxes, for setting the default database and 

searching in the Script editor, are features only available on the toolbar. 

From left to right, the function in the toolbar are: 

 Select default database combobox. 

 New file- The same as the File->New menu option. 

 Open file – The same as the File->Open menu option. 

 Save file - The same as the File->Save menu option. 

 Print script – Bring up the Print dialog for printing the current script. 

 Execute – Execute script. This is complemented by a dropdown menu to the 

right with the following additional options: 

o Execute – Same as clicking the button itself. 

o Execute selected – See Run selected statements 

o Execute from current statement – See Run forward 

o Execute to the current statement – See Run to the current statement 

o Execute force – See Forced execution 

 Stop – This is the same as the File->Cancel menu option and will stop 

execution of the current script. 
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 Back – This is the same as the View->Back menu option. See the Script history 

section. 

 Forward – This is the same as the View->Forward menu option. See the Script 

history section. 

 Push to history – This is the same as the View->Push to history menu option. 

See the Script history section. 

 Search combobox – See Script search function 

Accelerator keys 
MyQuery 3.0 introduces many more accelerator keys, and also the ability for the user 

to configure the accelerators, see Keyboard preferences. Some accelerators are still fixed in 

their function, this is the case with certain editor functions, as well as some Windows 

functions that you always want to keep as standard. 

UTF-8 Mode 
MyQuery 3.1 introduces support for UTF8. This support is implemented in three 

places: 

 The Scintilla editor. This is supported by Scintilla by default, and the only 

thing that MyQuery does is to enable it. 

 Query results display. This is implemented as part of displaying data in the 

result grid at the bottom on the MyQuery window, as well as in the Column 

data dialog. 

 The database layer. In this case, it is only implemented to apply the appropriate 

SET NAMES SQL command to set the character set used. As Windows doesn’t 

in and of itself work with UTF-(, MyQuery does the conversion, but happens 

in the Query results, not as part of the database layer. 

The way UTF-8 support is implemented than has a few advantages, such as I can 

always get at the UTF-8 data, as well as ANSI data, and this is well controlled. The 

disadvantage is that UTF-8 then needs to be implemented by all consumers of database data, 

but so far, this has only been done for the results, not for any metadata or dictionary data. 

There is a technical reason why the implementation works the way it does now, and UTF-8 

support will be enhanced in future versions of MyQuery. 

To enable / disable UTF-8 support, you can set the UTF-8 flag when you connect, or 

you can set it while connected by using the Settings->UTF-8 support menu option. 

Drag-and-drop support 
Drag-and-drop is supported in several places. MyQuery supported Drag-and-drop of 

text and files. 

Text drag and drop in the editor 
The editor windows supports text being dragged to and from it, just select text and 

drag it, or drag text to the editor. The text will be inserted into the appropriate place in the 

editor. 

If you drag text to the Editor tab, see Tabbed editing, the text will open in a new editor 

tab, unless the current editor window is empty. 

File drag to MyQuery 
Files can be dragged from, say, Explorer, to MyQuery. If you drop them on the editor 

window, a menu will pop up that allows you to paste one of three things: 

 The name of the dropped file. 

 The contents of the dropped file. 

 The contents of the dropped file, but encoded in such a way so that is can be 

inserted as a BLOB. Also see Inserting BLOB data. 
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A file may also be dropped on the Editor tabs, see also Tabbed editing, in which case 

the file will be read in and opened in a new tab. 

Dictionary drag operations 
From the dictionary window objects may be dragged. This is done as text, so it can be 

dropped anywhere where text is accepted, but typically this is would be to the MyQuery 

editor window. 

As the drag format here is plain text, you may also drag a dictionary object to the 

Editor tab, in which case a new tab will be created for the object, as necessary. 

Reconnection to the database 
Sometimes you want to abandon a connection and reconnect again. This is what the 

Files->Reconnect menu option does. If will just disconnect the current connection and 

reconnect using the same parameters as you connected with before. 

Load Data Local Infile support 
MyQuery version 3.5.2 introduces support for the SQL command LOAD DATA 

LOCAL INFILE. This support means that the command will run as expected (this command 

requires support in the MySQL Client that was missing in previous versions). While a load is 

running, a progress dialog is shown. 

Dynamic columns and JSON support 
Dynamic Columns is a unique feature to MariaDB and is not available in MySQL. 

Basic support for Dynamic Column so that this data can be viewed is introduced in MyQuery 

3.5.4. 

Dynamic Columns is a way to store structured, nested, data in a single column in a 

specific binary format. To access dynamic column data special function must be used, either 

on the server or the client. MyQuery can unpack this data and display it in a human readable 

format. 

MyQuery has several options related to working with JSON and dynamic columns. To 

begin with, if  

Hints and tricks 

Using SQL to generate SQL 
Two features in version 2.3 and up allow you to use SQL to generate SQL. This is 

useful in particular for DBAs and when working with database schema statistics, but also in 

many other cases. 

The way this is used is to write SQL that in turn will generate SQL, write the output of 

this SQL statement or statements to a file, and then use the SOURCE command on this file. 

The SPARSE_OUTPUT_FILE command is targeted at this exact purpose. 

For example, assume that you want to optimize all tables in the current database, then 

this script will do the trick (MySQL 5.0 or higher is required for this to work): 
/*MYQUERY sparse_output_file tmp.sql */ 

SELECT CONCAT(‘OPTIMIZE TABLE ‘, table_name, ‘;’) 

FROM information_schema.tables 

WHERE table_schema = DATABASE(); 

source tmp.sql 

Using and editing keyword files 
MyQuery 3.0 introduces the ability for the user to control the keywords used by the 

editor. The keywords are stored in simple text files, with a simple format: 
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 Keywords can be separated by any separator you choose, except the ones that 

are used to make up a keyword, which is the letters a-z (keywords are always 

case insensitive), the numbers 0-9 and the underscore sign (_). 

 You may separate the keywords on as many lines as you want. 

 Multiple separators, blank lines etc. are ignored and considered just one 

separator. 

 The hash-mark (#) introduces a comment line, which means that anything from 

the hash mark and up to end of the line is ignored. 

An example keyword file can looks like this: 
# MySQL Objects 

character collation column columns database engine 

function index logfile partition procedure server schema 

storage table tables tablespace trigger user view 

 

# MySQL Engines. 

myisam innodb ndb ndbcluster heap memory federated blackhole 

archive 

There is one keyword file per keyword type, at the most (certain keyword types may 

well lack a keyword file, in which case there is no highlighting in effect for those keywords), 

and the types of keywords are: 

 Major keywords – Such as SELECT, INSERT, CREATE etc. 

 Keywords – Such as FROM, WHERE, ORDER, GROUP, BY etc. 

 Object and type keywords – Such as TABLE, COLUMN, INTEGER etc. 

 Function keywords – Such as MD5. SLEEP, ADDDATE etc. 

 Procedure keywords – Such as If, ELSE; ELSEIF, WHILE 

 Three sets of user defined keywords. 

The user defined keywords may also contain column, table and routine names from 

the current database, the complete list of user keywords in the list in question is the sum of all 

these keywords, including the user defined keywords, if those are enabled. 

Caching database object names as keywords 
Sometimes you want to have the tables and column and other objects in the database 

colourcoded, but using the feature in the editor of allowing these to automatically included 

among the user keywords, see User defined keywords set 1, 2 and 3, makes starting MyQuery 

slow, and also makes changing databases slow, then there is a remedy. 

The reason for the slowness is that the list of object names much be gotten from 

MySQL every time you connect and every time you change database. The objects that are 

automatically included are also only the objects in the current database, so if you are writing 

cross database SQL, the colour coding will not work. 

The way fix this is to place the tables, columns etc that you want colourcoded in a 

keyword file, and use that instead of selecting Tables, Columns etc, you just specify this file. 

The problem is how to create this file, but help is near! MyQuery contains a tool for just this 

purpose, accessed from the Settings->Generate keyword file menu option, see also Generate 

keyword file. 

Once a file has been generated, select the Settings->Editor preferences menu option, 

select the Editor keywords tab, and select the generated file as described in User defined 

keywords set 1, 2 and 3. 

Application crash dump 
Version 3.0 of MyQuery includes the ability to dump a useful crash dump, should a 

serious problem occur. If this happens, and the feature is enabled (you have to build MyQuery 

with the MYQUERY_DUMP macro defined for this to work), a dialog box will open when a 

crash occurs, with an optional email compose dialog opening up. 
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In the email dialog that pops up, sometimes the dumpfile is attached to the email 

automatically (if you use Outlook, this might be the case for example), whereas in some other 

cases, this will not be the case. In any case, the email text asks the user to attach the file, 

including the full pathname of it, to the email. 

The reason that automatic attach doesn’t always work is twofold: 

 The attributes for attached files to mailto: is not standardized 

 Many emails do not support  automatic attaching for security reasons. 

And before I close this discussion, if you think that instead of using the mailto: syntax, 

I should use MAPI to get automatic attaching to work, you are wrong. This does not help, and 

is not supported, again, for example by Thunderbird for security reasons. 

Non-interactive user defined tools and standard output 
If you want to pass standard output from a user defined command, such if you want to 

pass the output from mysqldump to a file, you usually use the > operation on the 

commandline, like this: 
mysqldump --no-data test > testdmp.sql 

Using a user defined external program, tool like this, with mysqldump as the 

executable name and –no-data test > testdmp.sql will not work though, as this way of 

handling standard output is a feature of the Windows cmd program ,which processes 

commandlines. For the above to work then, you pass cmd as the name of the executable 

program and  /C mysqldump --no-data test > testdmp.sql as the argument. The /C leading 

parameter tells CMD to execute the program and then exit. If you want to open the generated 

file after running the command, such as if you use the %TMPFILEOPEN% parameter, then be 

sure to uncheck the Interactive checkbox for the tool. 
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Configuring MyQuery user tools 

The menu option Settings->Configure user tools will bring up a dialog where you 

manage the user defined tools. A tool which has been configured and is available for use will 

show as an option in the Tools main menu. 

A tool is one of several available types, see 12.16.User defined tools for more 

information on the types. Once a tool is defined with a specific type, the type of the tool 

cannot be changed. The Configure user tools dialog will show all the defined tools in the tree 

to the left in that dialog. 

Creating a new tool 
First, click the New button, which will bring up a dialog where the tool type and name 

is determined. You must at this stage select the type, which cannot be changed later, and a 

reasonable name, which may be changed at a later time. 

Click OK in this dialog, and a new tool is defined. For most tools though, there are 

some more things to do, as they require additional information to work, such as a DLL name 

for a plugin or a SELECT statement for a SQL SELECT tool. 

Enabling tools 
Only tools that are enabled will be shown in the Tools menu. A tool may be enabled, 

disabled or may be automatically enabled, based on a condition: 
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 Enabled when connected – These tools will only be available when you are 

connected to the database. This is the default for SQL based tools. 

 Enabled when connected to a database – A tool with this property will only be 

enabled when you are connected to a database and there is a current database 

selected. 

 Enabled by variable – These tools are enabled when a MySQL Server variable 

has a value equal to, not equal to, less than or greater than a given value. 

 Enabled for engine – These tools are only enabled if the specified storage 

engine is installed. 

 Enabled for plugin – These tools are only available if the specified plugin is 

installed. 

Also, in addition you may enable a tool only when a specified string is found inside 

the server version string using the Enabled when version string contains setting.. 

If a tool-group is disabled or not available because of one of the conditions above isn’t 

met, then all tools in that group are also disabled. 

Renaming, reordering and grouping tools 
Tools may be grouped for convenience, and to achieve this, first create an appropriate 

Group by clicking the “New” button and then naming the group. After a tool Group has been 

created, add tools to the group by dragging them to the group in the tree to the left in the left. 

In the same way, the order of the tools may be changed by dragging the, in the tree. 

The order they appear in the tree is the same as the order they appear in the Tools menu. 

To rename a tool, select it in the tree view and click it again and edit the text in the tree 

itself. 

Exporting and importing tools 
Tools may be exported and subsequently imported. To export a tool or set of tools, 

select one or more tools in the checkboxes in the tree to the left, and then click export. The 

file format is a simple uncompressed tag format. 

When exporting a plugin, the path to the executable file is ignored and is assumed to 

be the default plugin directory, and the plugin DLL is exported also. When imported, the DLL 

is unpacked to the default plugin directory again. 

Common tool attributes 
A few a attributes are common to all tools: 

Help text 
Help information for the tool in question 

Enabled when version string contains 
Setting this value will cause the tool to be enabled only when the server version string 

contains the given value. This is combined with the other tool enable features. 

The only attribute common to all tools is the Help text attribute. One attribute is 

common to all tools except Group Tool: 

Grayed when not enabled 
Checking this flag will cause the tool to appear in the Tools menu, but grayed out, 

when not enabled. Usually tools that are not enabled are not shown in the Tools menu at all. 

This attribute is now available for Group Tools. 

SQL Tool attributes 
The SQL Tools (SQL SELECT, SQL File and SQL Script) have most attributes in 

common. These tools may not have the Enabled attribute, it can have any other enabling 

attribute than this, with Enabled when connected being the default. 
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SQL Text 
This attribute is available for SQL SELECT and Script tools only. This defines the 

actual SQL statement to execute when the tool is running. 

To copy the text to or from the editor or clipboard, click the Copy button, which will 

bring up a menu of options. 

File name 
This attribute defined the filename when running a SQL File tool. 

Use main, execute or separate connection 
This defines which MySQL Connection to use when running the tools. Mostly, you 

want to use the Monitor connection, which is used for most background tasks in MyQuery, 

but note that this connection does not have a database selected, so any references to tables in 

scripts has to include the database name. If you want to run the tool in the currently selected 

database, then instead select Use monitor connection. 

In some cases, in particular if you run a large SQL File based tool, you may want this 

to run in the background. In this case, select Use separate connection, to have MyQuery create 

a separate connection for the script in question. 

Modal dialog 
If this is set, then the tool will run in a modal dialog, blocking MyQuery until it has 

finished running. 

Close window when finished 
This setting is only available for SQL File and Script tools. When this setting is 

enabled, whenever a tool is running it will show a modal dialog, in essence blocking 

MyQuery until the tool has finished running. 

Single row vertical 
This option is only available for SQL SELECT tools. It will turn the result “around”, 

so that the column names are shown in the first column and the first row is shown in the 

second column. Only one row is retrieved. This is useful for creating tools around things like 

SHOW SLAVE STATUS where MySQL, in all its wisdom, shows the data as multiple 

columns in one row, instead of multiple rows, like in SHOW VARIABLES and SHOW 

STATUS. 

Allow refresh 
This option allows the user to automatically or manually refresh the content in the 

dialog by rerunning the SQL query. The default is that this option is enabled. 

Run on warning 
There can be only one tool with this attribute set in each toolset. The tool with this flag 

is special as this is the tool that is run when the Warning icon is clicked in the statusbar after a 

statement that produces one or more warnings has been run. 

Group tool attributes 
A Group only has one unique attribute, which is applied to any tools in the group in 

question. 

Show group as submenu 
Usually, tools appear as one long menu under the Tools main menu. With this setting 

on for a group though, only the tool group will be in the Tools menu, with the items in the 

group appearing as a submenu. 

Web link tool attributes 
Again, a Web link has only one attribute. 
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Link 
This attribute is the link itself that will be displayed in the web browser when the tool 

is selected. 

External program tool attributes 
File name 

This is the name of the program to run, either just the name of the program, or a full 

path. You may browse for the full path by clicking the button to the right of the file name box. 

Arguments 
These are the arguments for the program to run. You may put in any arguments 

relevant for the program in question here and in addition, you can use special escape 

sequences that will be replaced by relevant information from the current MyQuery 

environment. 

A help screen for the available escape sequences is available by clicking on the button 

to the left of the arguments edit box. An example argument setting, for use with a mysql 

commandline would be: 
-h %host% -P %port% -u %user% %mysqlpass% %database% 

Interactive application 
This checkbox flags if this is an interactive tool or not. If this checkbox is not set, then 

MyQuery will wait for the tool to exit before continuing. Usually, you do not want to have 

this setting on if the tool you run uses one of 

the %outfileopen%, %OUTFILEOPEN%, %tmpfileopen% or %TMPFILEOPEN% 

arguments. 

Plugin tool attributes 
Most of the functionality of a plugin tool is determined by the plugin DLL itself, more 

than the settings set by MyQuery. All that MyQuery needs to know is how to call the plugin, 

and if it should be enabled or not. 

File name 
This is the name of the plugin DLL to execute when this tool is run. You may browse 

for the DLL by clicking on the button to the right of the file name edit box. 

Entry point 
This is the entry point in the Plugin DLL that will be called when the plugin executes. 

Building MyQuery plugins 
Plugins are DLLs that are called from the tools menu. A Plugin has access to the editor 

text, the connections and many other aspects of MyQuery. DLL’s are written in C / C++, are 

combined with a special .h include file and are linked with the MyQuery export library. The 

latter isn’t strictly necessary, unless you want access to the MyQuery environment, but most 

plugins will need that anyway. 

The easiest way to get started is to look at the source for the supplied plugins, which 

are reasonable well documented and structured. Some functions that was previously part of 

MyQuery itself are now included as plugins, such as Break Long Lines and Memory 

Information. 

MyQuery Plugin API 
These are functions that a Plugin DLL can use to access MyQuery itself. In some 

cases, precaution is needed, in particular when running plugins as separate threads. Plugins 

are written in C, or possibly C++, and will probably use parts of the MyQuery Plugin API. I 

recommend anyone developing a plugin to have a look at the sample plugins that are part of 

the distribution. 
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Every plugin DLL (which may well have multiple entrypoints) must do a couple of 

things: 

 Include MyQueryPluginCallback.h 

 Provide all the necessary stuff for a Win32 DLL. 

 Implement one or more functions to be called 

 Optionally, provide an initialization function, using C bindings, called 

MyQueryPluginInit taking a hWnd argument (the application main window 

handle), that is called when the plugin library is loaded. 

 Optionally, a Deinitialization function called MyQueryPluginDeInit may also 

be provided, to be called whenever the library is unloaded. 

Note that a plugin may be unloaded by MyQuery itself at times, such as when 

exporting an existing plugin or importing a new plugin. 

More plugins will probably link to MySQL, but for those that don't and if you want to 

avoid dependency on MySQL includefiles, define MYQUERYPLUGIN_NOMYSQL before 

including MyQueryPluginCallback.h, like this: 
#define MYQUERYPLUGIN_NOMYSQL 

#include “MyQueryPluginCallback.h” 

MyQuery plugin function entry points 
For every plugin library, one or more entry points, i.e. functions to be called, are 

defined. When defining a Tool plugin, both the DLL and the entry point must be defined. 

The entry point has the prototype: 
MYQUERY_PLUGIN_API EntryPoint(HWND hWnd, PMYQUERYPLUGINCTX 

pCtx) 

Where MYQUERY_PLUGIN_API is defined as an exported function returning a 

BOOL. The hWnd is the window handle of the application main windows, and pCtx is a 

pointer to the content for the function. If the function continues to execute after returning, 

such as a new thread is created or a non-Modal dialog box is opened, then set the 

PLUGIN_FLAG_KEEPCTX flag in the dwFlags member of the pCtx struct: 
pCtx->dwFlags |= PLUGIN_FLAG_KEEPCTX; 

This is strictly necessary only if the context is to be used after returning from the 

called function, for example if the plugin opens a non-modal dialog box. In this case, when a 

non-modal dialog box is open, the plugin should call MyQueryPlugin_SetHwnd() in the entry 

point function to make sure that the Window is handled properly. In addition, when the plugin 

exists, MyQueryPlugin_ExitPlugin() should be called. 

MyQuery plugin contexts 
Every plugin gets passed a pointer to a context, a PMYQUERYPLUGINCTX, which 

is used when doing callbacks from the plugin through the API to MyQuery itself. If the plugin 

keeps running after having been called, say by keeping a non-Modal dialog box open, and it is 

required to call back to MyQuery even after returning from the call, then the called plugin 

must: 

 Set the PLUGIN_FLAG_KEEPCTX flag in the dwFlags member of the passed 

context. 

 Release the context by calling MyQueryPlugin_ReleaseCtx when the context 

is no longer needed. 

 When the plugin entrypoint is called, you MUST call MyQueryPlugin_SetHwnd() to 

associate the plugin with a unique HWND for the plugin. 

Building MyQuery from source 
MyQuery contains three sets of Sourcecode, one set for MyQuery itself one which is 

the MySQL Lexer for Scintilla and one which is used by InnoSetup for the MyQuery installer. 
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MyQuery Sourcecode 
MyQuery right now comes with Projectfiles for Microsoft Visual C++ Express 2008. 

To build the project, download and extract the sourcecode files in some directory. Then start 

Visual C++ and open the solution file MyQuery.sln. 

Before you can build MyQuery, you must also have MySQL or MariaDB installed. 

Also, Scintilla is needed, download this from http://www.scintilla.org. Now, in Visual C++, 

you need to adjust the paths for MySQL includefiles and libraries. Note that MySQL and 

MariaDB comes with both debug and release libraries, which are placed in separate 

directories. 

The MyQuery project has three build configurations: 

 Debug – This is debug build that will links dynamically with the debug client 

library. 

 Release – This is a release build, without debug information, that is 

dynamically linked with the MySQL / MariaDB client library. From Version 

3.3 and up, this is the configuration of the pre-built binaries. 

 Release static – This is a statically linked version of MyQuery, which has some 

benefits, but when using the plugins introduced in in Version 3.3, using a static 

build was no longer possible. This used to be the configuration used for the 

pre-built binaries before Version 3.3. 

To adjust the paths, select Project->MyQuery_3_5_5 Properties... menu option. Select 

the configuration you are working with the combobox in the upper left. Then set the 

appropriate include directories to Scintilla and the MySQL include directory in the 

“Additional Include Directories” field under the C/C++ General property. Secondly, select 

Linker in the tree to the left and adjust the MySQL library defined in the “Additional Library 

Directories”. 

If you want to include the crash-dump feature of MyQuery 3.0 and up, you have to 

define MYQUERY_DUMP when you compile MyQuery. 

Having adjusted the paths as appropriate, you should now be able to build MyQuery. 

LexMySQL Scintilla lexer 
Here you need to download the Scintilla Sourcecode and copy the LexMySQL.cxx file 

supplied with the MyQuery sourcecode to the Scintilla src directory and the SciLexer.h needs 

to replace the file with the same name in the Scintilla include directory. 

For more information on how to build scintilla, see the scintilla documentation: 

http://scintilla.sourceforge.net/ScintillaDoc.html. 

Building the installer 
To build the MyQuery installer, you first need to download and install InnoSetup from 

http://www.jrsoftware.org/isdl.php. Having done that, open the MyQuery.iss MyQuery 

installation project file that is part of the MyQuery sourcecode. You need to adjust the file 

paths and other setting as appropriate in this file, but it should be fairly obvious. Note also 

that you need to have the documentation PDF, as this is part of the install, alternatively, you 

can comment out the documentation part of the install. 

Limitations 
There are still some limitations in the current version of MyQuery. One limitation is 

that to run a script, it need to be pulled into memory and possibly be edited, before it is run. 

This means that there is a limit to how large scripts on can work with. 

Despite these limitations, the added features beyond the MySQL commandline should 

make MyQuery a useful addition to the MySQL Windows toolkit. 

http://www.scintilla.org/
http://scintilla.sourceforge.net/ScintillaDoc.html
http://www.jrsoftware.org/isdl.php
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Software dependencies 
Beyond the sourcecode contained within MyQuery itself, there are three sources for 

code contained within the project, as of this version: 

 MySQL or MariaBD Client libraries. 

 Windows standard API and libraries 

 InnoSetup ingenious Windows installer is used for the windows installation. 

See more on http://www.jrsoftware.org 

 Scintilla editor, see http://www.scintilla.org. 

 

Appendixes 

MyQuery menu reference 
The MyQuery menu makes most features accessible from one place. In addition, most 

menu option may be linked to a keyboard accelerator, if you so wish. See the section Using 

the keyboard for more details. 

File menu 
Except the obvious options in the File menu, there are some special commands here: 

Open / Open in new tab 
MyQuery allows you to have multiple files open in different tabs. If you use the 

File->Open command to open a file, then the contents of the opened file will replace the 

contents of the current tab. If you instead use the File->Open in new tab command, then the 

file will open in a new tab, unless the current tab is empty. 

Recent files 
Here is a list of the most recent files opened. 

Save / Save as 
Save the current script. 

Save result as CSV / Save result as JSON 
These commands will save the contents of the result to a file in CSV or JSON format 

respectively. Use the File settings to set up file format specific for these formats respectively. 

Advanced Save result 
Save result to a file with all the available file format option in one place. 

Copy from errors 
This special command will copy the contents of the Error tab to the editor. 

Set output file / Close output file 
This is the menu based version of the script commands OUTPUT_FILE and 

CLOSE_OUTPUT. 

Set sparse output file / Close sparse output file 
This is the menu commands that do the same as the script commands 

SPARSE_OUTPUT_FILE and CLOSE_SPARSE_OUTPUT. 

Page setup / Print / Print result 
These commands control printing of script and results. See more in Printing. 

Connect / Disconnect / Reconnect 
Sometimes you want to connect to a different server or reconnect to the current server, 

for some reason, these commands allow you to do just that. 

Exit 
Exit MyQuery. 

http://www.jrsoftware.org/
http://www.scintilla.org/
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Edit menu 
This menu works like the Edit menu in any Windows program, and most options 

require no further explanation. There are some Commands that are non-standard here though. 

Copy result / Copy result as 
These commands allow you to copy the current result to the clipboard. The 

Edit->Copy result command just copies the result, whereas the second allows you to set some 

option on how the copied text should look like. 

Search / Search next / Search and replace 
These commands works as expected, but with a few extra features. See more in the 

section: Search and replace. 

View menu 
This menu contains Commands related to what is shown and how in MyQuery. 

Toolbar 
This option switched the toolbar on and off. 

Back  / Forward / Push to history 
These menu option are alternatives to using the Toolbar for navigating the statement 

history. 

Set / Clear marker / Clear all markers 
These options manage the user defined line marker and error line marker. See more in 

The marker margin. 

Clear indicators 
This clear the indicator, a red squiggly line under the text, that indicates the position of 

an error in the specific SQL statement. 

New tab / Close tab 
These commands create a new empty editor tab and closes the current one 

respectively. 

Copy to new tab 
This command will create a new tab and copy the contents of the current tab to it. 

Run menu 
Execute 

Execute the current script. 

Execute selected 
Execute the select text as SQL 

Execute current 
Execute the current statement only. If no statement is current, the first statement is 

executed. After the statement is executed the marker moves to the next statement. 

Execute from marker 
Start executing from the current position of the marker. If the marker is not set, then 

the marker is first set at the first statement. 

Execute to marker 
Execute to the current position of the marker. If no marker is set the whole script will 

be executes.. 

Execute force 
Execute the whole script and ignore errors. 
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Status menu 
InnoDB status 

Show the InnoDB Status dialog. See InnoDB Status. 

Server variables 
This shows the MySQL Server variables. See Server variables 

Global status / Session status 
Shows the Global and Session dialogs respectively. See Global and Session Status. 

Processlist 
Show the result of SHOW PROCESSLIST in a dialog. See Processlist. 

SQL Statements 
Shows the collected SQL statements running in the server. See SQL Statements. 

Profile 
Manage the MySQL Profile in a single simple dialog. See SQL Profile. 

Tools menu 
The tools menu contains a number of tools for different uses, followed by the user 

defined tools. 

Connection information 
This will bring up a dialog with information on the current database connection. 

Script information 
Show information on the current script. For a script that has been run, this dialog 

shows statistical information on the run, such as the time took, the number of rows fetched 

etc. 

Dictionary 
This menu option will show the Dictionary viewer. 

Bookmarks menu 
This menu contains commands for dealing with Bookmarks. 

Organize 
Show the dialog to organize bookmarks. 

Add bookmark to folder 
Show the dialog that allows you to add the current file to a bookmark folder. 

Add to folder '<folder name>' 
This is a shortcut to add the current SQL file to the most recently used bookmark 

folder. 

Settings menu 
Default delimiter 

Sets the delimiter to the default ";" (semicolon). 

Retain delimiter 
When enabled, this option will reset the delimiter to the current one after each script 

run. 

Retain database 
When enabled, the current default database will be reset after each script run. This is 

useful when you run scripts that contain use statements. 

Hide output 
Enabling / disable display of SQL results in the Result output area. This is similar to 

using the HIDE_OUTPUT and SHOW_OUTPUT internal commands. 
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UTF-8 Support 
Enable / disable UTF-8 support. See UTF-8 Mode. 

Associate SQL files 
Enable SQL files to be associated with MyQuery. See File associations. 

General preferences 
Show the dialog where all the General preferences are accessible. See MyQuery 

preferences reference. 

Editor preferences 
Show the dialog with the SQL editor specific preferences. 

Configure user tools 
This brings up the dialog where User defined tools are created. 

Refresh editor 
This menu option will instruct the editor to refresh the syntax colour highlighting and 

autocomplete keyword list. This is a rarely used tool, but may be used if the 

highlighting/autocomplete get out of sync and must be refreshed, for example when a new 

table is created or dropped or when a table is altered. 

Generate keyword file 

 

This will bring up a dialog that allows you to generate a file that is valid as a keyword 

for the editor, based on the objects in the database. 

To create a file, select which databases you want to use as source, or click the Use all 

databases checkbox. The select the types of objects you want to place in the file, finally, 

choose a file, either by tying in a filename or clicking on the Browse button to the right and 

click the Write to file button to generate the file. 



MyQuery 3.5.6 Beta  Page 46 of  69 

 

 

Save settings 
This menu option allows you to export the current settings to a file. This is useful, for 

example, when you want to use MyQuery on a different machine, but using the same settings 

as on the current installation. 

Restore settings 
This option allows you to restore settings previously exported using the Save settings 

menu option mentioned above. 

Help menu 
This menu contains some commands related to online help. MyQuery currently lacks a 

full-blown, context sensitive help system, but some help is supplied using these commands. 

MySQL Help 
This shows the MySQL Help viewer. 

Documentation 
This menu option shows this documentation. 

Keyboard shortcuts 
This option show a dialog with the defined Accelerator keys. Note that this shows 

what is currently defined, bit the defaults, so this dialog is dynamic. Also, note that you can 

print the shortcuts using the Print button. 

Check for updates 
This will open a web-browser on the page for software updates for MyQuery. 

About 
This shows the about box with credits to supporting programs such as InnoSetup and 

Scintilla. 

MyQuery preferences reference 
MyQuery has a lot of preferences that you can set. To do this, bring up the Preferences 

dialog using the Settings->General preferences menu option. Most options here should be 

pretty self-explanatory, but a summary follows. Also, there is a separate set of preferences for 

the editor, available through the Settings->Editor preferences dialog. 

The setting for MyQuery may also be saved and restored using the Settings->Save 

Settings and Settings->Restore settings menu commands. 

General tab 
Logon at startup 

Flag if the Logon to MySQL dialog should be displayed when the program starts, 

Save password 
If this option is set, the password used to log on will be put in the registry. This is 

often not a good idea for security reasons, but might come in handy during development. Note 

that the password is obfuscated when stored in the registry. It’s not really hard to figure it out, 

but at least it in not in plain text. Do NOT trust this obfuscation to be secure in any kind of 

production environment! 

Use KILL QUERY 
Enabling this option will send a KILL QUERY command to the running query. There 

is usually no reason not to enable this option. 

History size 
This is the number of entries in the Script history. 

Max script size in history 
This is the maximum size of a script to be placed in the history. Very large scripts are 

typically best not being placed in the history, as history entries are stored in memory. Scripts 
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larger than this will silently not be placed in the history, there will not be any warnings for 

this. 

Plugin directory 
This sets the default directory for MyQuery plugin tools. 

Interface tab 
Use transparent dialogs 

This works on Windows XP and up, and will make the non-modal dialogs transparent, 

so that anything that goes on in, say, the query window, can be seen through the dialog. This 

slows updating of the screen up a fair bit though. 

Transparency level 
The level of transparency when transparent dialogs are enabled. 

Show tray icon 
This setting controls if MyQuery will display and animate an icon in the Windows 

tray. 

Floating modeless dialogs 
Without this option enabled, the Main window of the application is the parent of any 

non-modal dialogs, so these will always be in front of the main window. With this option 

enabled, the dialogs will be parented by the desktop, and will hence float independently of the 

main window. 

Wrap long texts in dialogs 
This concerns mostly error dialogs, and makes sure that multiline texts in these dialogs 

will  always wrap around of they will not fit the width of the window. If this is disabled, text 

will be displayed “as is”. 

Recent files open in new tab 
Enabling this open causes opening of files using the File -> Recent files to open in a 

new editor tab. Without this enabled, existing content on the current tab will be replaced by 

the opened file. 

Activate first result after running a query 
If this is set, the first result tab shown after running a query, if it is not, the currently 

selected result tab is shown. Not having this turned is sometimes confusing when you have 

tabs locked, as the result isn't shown if a locked tab is selected. 

Ask before closing an editor tab with changes 
If an editor tab is closed and the tab has changes, for example by clicking the close 

icon on the tab itself, it is silently closed, unless this setting is on, in which case a dialog to 

confirm the close is popped up. 

Only ask before closing a table with a file 
If Ask before closing a tab with changes is set, then checking this setting will cause 

the confirmation only to show in the case the tab is associated with a file. 

Use single click to close a tab 
To close a table, unless this setting is on, you have to double-click on the tab close 

icon. If this is on, only a single click is required. 

Result preferences 
Max rows to fetch 

This is the maximum number of rows to fetch and place in the Output tab. This is only 

the limit of how many rows will be in this window, not how many rows will be fetched from 

the MySQL server to the database. As MyQuery use the mysql_store_result() function to fetch 

data, this means that the SQL_SELECT_LIMIT MySQL variable is not set. This feature will 

be available in a future release. 
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Max column width 
This sets the maximum width of a column value in the Output tab. The default is 50, 

which is a reasonable conservative limit. For longer data item, such as BLOBs, see the 

Selecting BLOB data section. Data that is very large will typically be difficult to read in the 

output control anyway. 

Max resultsets 
This controls how many resultsets will be display, at the most. MySQL require all 

resultsets to be retrieved, but this setting will limit how many will be displayed. 

Overwrite results 
When this is checked, when a new query is issued that returns a result, the current 

result data tab is cleared and reused. If this flag is not set, any current tabs with data will be 

locked, and the new data tabs will be added before the existing data tabs. 

File result settings 
These are the same as the corresponding result settings, except that these relate to file 

results, i.e. when the OUTPUT_FILE and/or the SPARSE_OUTPUT_FILE commands has 

been used. 

Smart conversion of Dynamic Columns to JSON 
Setting this option will investigate each resulting binary column and check if the 

content is a binary column, and if it is the result will be converted to JSON. 

File preferences 
Use UNIX file format 

Setting this means that the default format for new files will be Unix. See the section 

Dos and Unix format files for more details. 

Retain original file format 
For files read from disk, if this setting is enabled, the default format will be that of the 

file read, independent of the Use UNIX file format preference setting. See the section Dos and 

Unix format files for more details. 

Filesize warning 
Size of file where a warning will be issued when the file is read from disk. This is to 

prevent very large files mistakenly being read into and filling up memory, making the 

computer unresponsive. This is just a warning. Note that there is also an absolute limit of 1Gb 

file size which cannot ever be read into the program. 

Max dragged filesize 
This is the maximum size of a file that can be dragged to the edit window when 

working with large binary objects. See the Inserting BLOB data section for more details. 

Number of recent files 
This is how many recent files opened / saved will be placed in the File->Recent Files 

menu option. 

The Output file settings are settings that define how files are written when using the 

File->Save as CSV or File->Save as JSON menu options. These settings are also available in 

the dialog displayed by File->Advanced Save as menu option. 

Use unix file format 
Use UNIX style CR/LF instead of DOS. 

Treat NULL as an empty string 
Output NULL values as empty strings. 

Handle empty column as NULL 
Handle empty strings and binary column values as NULL. 

Quote numeric values 
Put quotes around numeric values. 
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Smart dynamic column to JSON handling 
This option will cause saved data to auto detect if a binary column contains valid 

dynamic column data, and if it does output it as JSON. 

Include column names in CSV files 
When saving to a CSV file, the first row will contain the column names. 

Use SQL NULL (“NULL”) in CSV files, else use “\N” 
When outputting a NULL value in a CSV file, the default is to use the MariaDB 

NULL marker, \N, but by enabling this option the usual SQL NULL is used instead. 

Quote character in CSV files 
This sets the character used for quoting values in CSV files. This may be empty to 

disable quoting altogether. 

Separator character in CSV files 
This sets the character used to separate different columns in a CSV files. 

Skip NULL values in JSON files 
When this option is set, column values that are NULL will be ignored for JSON files. 

Keyboard preferences 
Accelerator function 

This is a list of the available accelerator functions to define. Select of them to change 

the key. Note that some key combinations are locked, in which case all fields but this is 

disabled when such an Accelerator key function is chosen. 

Explanation 
This is an explanation of the actions performed by the Accelerator key in question. 

In use 
This controls whether key combination is question is in use or not. 

Key 
This defines the keyboard combination for this accelerator function. To change it, 

place the cursor in the field and press the key combination you want to set it to. 

Set default 
This will reset the keyboard combination for the currently selected function to the 

default. 

Apply all defaults 
This will restore the defaults for all keys. 

Script preferences 
Delimiter 

This is the default delimiter in use. This can be set here or by using the DELIMITER 

command in a script. It can also be recent to the default semicolon by the menu option 

Settings->Default delimiter. 

Retain delimiter in script 
If this option is set, and the default delimiter is changed when running a script, using 

the DELIMITER command , the default delimiter will be reset after the script has run. 

Retain database in script 
If this option is set, and a default database is set using the USE command in a script, 

then the default database is reset to what it was before the script was run, except when no 

default database was set at all before the script began running, in which case whatever it was 

set to at the end of the script will be the new default database. 
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Run all internal command on continue 
If this option is set, which is the sensible default, then when running a script not from 

the start, but from some arbitrary line in the script, using the Execute forward command, then 

any internal commands, such as USE, DELIMITER and any commented internal commands, 

the proceeds the line to run from, will still be run. This allows you, for example, to have the 

Retain database in script preference set, and still be able to continue running in a script. 

Versioned commands 
These options control how versioned commands are handled. 

Run always 
In this mode, versioned segments are always “uncommented” and passed as is to the 

MySQL server. 

Run never 
In this mode, all versioned segments are removed from the SQL statement before 

passing the statement to the MySQL server. 

Pass to server 
This is the default option, and in this case, the versioned segments are passed as is, as 

comments, to the MySQL server. This is how the MySQL commandline handles these 

statements. 

Assume version 
In this mode, a specific MySQL Server version is assumed, as defined by the user. The 

MyQuery program will then remove or include versioned segments based on the given 

version. Note that when a segment is passed to the server in this mode, it is “uncommented” 

first, just in the case of the Run always option, and not like the Pass to server option. 

Max levels of source 
This setting controls how many levels you may execute SOURCE commands, i.e. 

having script A SOURCE script B which in turn will SOURCE script C requires 3 levels of 

SOURCE commands. 

Note that the source command system relies in the script history to work, so you 

would normally don’t want to have the levels of source commands higher than the levels of 

History commands. 

Dictionary preferences 
Scroll current database into view when changed 

When this option is enable, if the current database is changed, the current database is 

scrolled into view in the dictionary browser. 

Include DROP when pasting a CREATE statement 
Enabling this will include a DROP .. IF EXISTS statement before the actual CREATE 

statement. This option is valid for all types of dictionary objects that can be pasted with a 

CREATE statement (which is true for all objects except columns). This option is also in effect 

independently of how the paste is done, i.e. by double-clicking or by choosing from a right-

click (context) menu. 

Include table name when pasting 
Include the table name when pasting relevant object. 

Include database name when pasting 
Include the database name when pasting relevant object. 

Include non-default database name when pasting 
Include the database name when pasting relevant object and the database is not the 

current default one. 

Include quotes when pasting 
Include relevant backticks when pasting. 
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Doubleclick action 
These options control when an object is double-clicked in the tree view of the 

dictionary browser: 

 Set default database - If this is set, when a database name is clicked in the 

dictionary browser, this is set as the default database. 

 Fold / Unfold tree - This is the same as clicking on the fold / unfold button in 

the tree. 

 Paste name - Paste the name of the object to the editor. 

 Paste qualified name - Paste the fully qualified name of the object (i.e. 

<table>.<column>) to the editor. 

 Repeat previous action - When this is selected, then the last action performed 

from the right-click menu is repeated. 

Routine and trigger paste delimiter 
When pasting a Routine or a trigger, a DELIMITER statement is also pasted, using the 

delimiter specified here. 

Create paste prefix / Create paste suffix 
Each time a CREATE OBJECT is pasted, if may be prefixed and / or suffixed with the 

text specified here. These are multi-line text strings, and inside the strings, you make also use 

the following escapes: 

 %n, %N – Substitute with the name of the current object, in the latter case in 

uppercase. 

 %t, %T – The type of the object, use %T for upper case. 

 %d, %D – The current database name, %D for upper case. 

Printing preferences 
Max pages to print 

The maximum number of pages to print. If a printjob exceeds this number of pages, 

the user is asked which action to take: 

 Cancel the print job 

 Print max pages – This will print the maximum number of allowed pages, and 

skip the last pages. 

 Print all pages in the printjob. 

Page setup font, font size and font attributes 
Set up the font to use for general page properties, currently the header and footer. 

Print frame 
Print a frame around the printed script and result. 

Header 
Print page header. This is a string that is printed at the top of each printed page. The 

string has some special format escapes: 

 \t – This will advance to the next position in the header of 3, leftmost, centered 

and rightmost. I.e. to print the string Printout horizontally centered on the page as a header, 

use the string \tPrintout. 

 %d – Replace with current date. 

 %t – Replace with current time. 

 %n – Replace with current name of script. 

 %% - Replace with a single % sign. 

 %p – The current page #. 

 %P – The total number of pages. 

Footer 
The page footer. Has the same format as the header. 
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Column and data font, font size and font attributes 
This is the font to use when printing column names and data values respectively. 

Vertical lines 
Print lines vertically, separating the columns in the result. 

Horizontal lines 
Print horizontal lines, separating the rows in the result. 

Line below column names 
Print a horizontal line below the column name only. 

Wrap results 
Wrap result values so that they may cover multiple lines per row. 

Print column names 
Print the column names for the result. 

Max column length to print 
The max length of a column, in characters, to print. 

Errors preferences 
Stop on error, Ask on error, Continue on error 

This allows you to set the error processing for the normal Execute command when 

running a script. In normal cases, the Ask on error default is good enough. If you set 

“Continue on error”, then the Execute command will behave like the Execute force command. 

Stop on error isn’t much different than Ask on error, except that processing will stop 

immediately if an error occurs, without a dialog box asking for action. 

Always ask on USE error 
The USE command is a bit different. If this command fails, there is usually something 

very wrong, and you really do not want to continue usually. If this option is set, which is the 

default, processing of a script will always stop and ask for an action if a USE command fails, 

even if the script is run as forced execution or the error processing option is set to Continue on 

error. 

Help preferences 
Load help when connecting 

If this setting is on, then the Help tables are loaded at each connection. 

Load help on first connection 
If this setting is on, then Help is loaded when the first connection is made to the 

database, and then this is kept loaded. 

Show help tips in editor 
If this is enabled, then help tips, which is the description of the relevant keyword, is 

shown when the mouse is dwelled or is hovering over a keyword for a time specified by 

Mouse dwell time. 

Mouse dwell time 
The time in milliseconds that the mouse should be hovering over a keyword before the 

help tip is displayed. 

MyQuery editor preferences reference 
These preferences control the look and feel of the editor, based on Scintilla. There are 

three tabs of preferences in this dialog, general, highlighting and user keywords. Set them in 

the Settings->Editor preferences dialog. 
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General editor preferences 
Show linenumbers 

This controls if the linenumbers displays at the left in the editor window is displayed. 

Show folding 
This controls if the folding margin, between the linenumbers and the edited test, is 

displayed. Support for folding is experimental in the current version. 

Place user marker on line when script is stopped 
The default for this is to be on, which means that if a script is stopped, for example if 

the users presses the Stop toolbar button or if there is an error in the script, then the User 

marker is placed on the line where processing was stooped. 

Even if this is turned off, the caret is placed on the first line of the statement in 

question. 

Use Tab / Shift-Tab to navigate 
When this option is enabled, the Tab key is used to navigate the Main window of 

MyQuery, instead of inserting a Tab character in the text you are editing. This is to ensure that 

it is possible to navigate the editor without resorting to special key presses, instead just using 

Tab / Shift-Tab no navigate to the next or previous item in the window. 

For more information see Using the keyboard. 

Font settings 
These preferences controls the default font used by the SQL Edit control. Note that 

this control is really not a program editor control, but a text editor control, which means that 

is has built-in font handling of its own. There are specific operations that change the 

appearance of the text in this control, and these operations has not been overridden in 

MyQuery. Eventually, the Rich Text control used for this will be substituted with a control 

better suited for program editing, but for now, this is something you have to live with. It is not 

usually a problem though. 

Fixed pitch fonts only 
Setting this option will list only fixed pitch fonts, which is what you usually want for 

programming and script work. 

Font name 
The name of the font used for script editing. 

Font size 
The size of the font used for text editing 

Sample 
Sample text formatted using the currently selected font. 

Error indicator settings 
Show indicator 

Controls if indicators are shown or not. 

Indicator style 
This controls the style of the indicator. Experiment with different settings to set it to 

your liking. The default is a Squiggly line under the error statement. 

Color 
This sets the colour of the indicator. The default is bright red. 

Editor highlighting preferences 
This section controls how the different known syntax sections are highlighted. For 

each setting in the left listbox, you can choose between a wide set of display options. 
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Text and Background colour 
This controls the foreground and background colour of the syntax element in question. 

Upper, lower and mixed case 
This controls how the case of the text is displayed. Note that this is only the display of 

the text, the stored text is always mixed, i.e. the displayed case is the same as the case in the 

text. 

Underline, bold and italic 
These control the font attributes of the text. Note that you may use none, some or all 

of these for any particular style. 

Editor keywords preferences 
This is a change from version 2.x of MyQuery. Keywords are now much more 

flexible, and you can define your own keywords by just creating a file. MyQuery comes with 

files that contain the usual MySQL keywords. 

In addition, you may have different sets of keyword files. The way this works is that 

each set comprises all the keyword files for some task, and you can choose which set you 

want to activate. See Using and editing keyword files for more information. 

Keyword sets 
This is where you edit, create and delete the current keyword sets. 

Current keyword set 
This is where you select the keyword set you want to edit. 

New / Copy / Delete 
Use these buttons to administer the keyword sets, to create a new blank set, copy an 

existing set, or to delete a set. 

Major keywords file / Keywords file / Objects / types keywords file / Function keywords file / 
Procedure keywords file 

This is the full path of the different keyword files. You may click on the Browse 

button to the right to browse for the appropriate file. 

User defined keywords set 1, 2 and 3 
These are the user defined sets that you can use for any purpose. 

Tables / Columns / Routines 
Check this to include the appropriate object names from the current database in the list 

of keywords. More than one may be selected. 

User keywords 
Check this to include the keywords from the specified user keywords file. 

Keyword file 
This is the file that is optionally included in the list of user keywords, use the Browse 

button to the right to browse for a file. 

Autocomplete preferences 
Autocomplete was introduced in MyQuery 3.5.0 and is a really useful feature. These 

settings control when the autocomplete list is shown, what it contains and what it looks like. 

Autocomplete after characters 
This setting controls if the autocomplete list is automatically shown after a specified 

number of characters has been typed and there is at least 1 matching entry in the list. 

Autocomplete on period 
This setting controls if the autocomplete list is shown when a period is typed and there 

is a matching list of entries. 

Include databases 
If this flag is enabled, then names of databases are included in the autocomplete list. 
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Include routines 
When this is enabled, names of routines are also included in the autocomplete list 

where appropriate. 

Assume tables aliases 
This option makes the list assume that when the string <part 1>. is matched, and part1 

is neither a table name, nor a database name (and database names are included), the it is 

assumed that part1 is an alias for a table. We do not know what table this is an alias for, that 

part of the statement might not have been entered yet, so the autocomplete list contains all 

column names in all tables in the current database. You may keep typing to shorten this, often 

very long, list or you may as usual select from the list. 

Rows in autocomplete list 
This option controls how long the displayed list is, it is not a limit of how many names 

there are in the list in total, just how many are displayed at the most. The list may be scrolled 

of there are more names than this in the list. 

MyQuery Plugin API reference 

MyQuery Plugin API  data type reference 
MYQUERYPLUGINCTX, *PMYQUERYPLUGINCTX 

Members: 

DWORD dwApiVersion API version of the caller 

DWORD dwPluginApiVersion API version of the plugin itself. Set by the plugin when 

MyQueryPluginInit is called. 

DWORD dwFlags Flags for the plugin. Some are set by the plugin itself, 

some by the calling application. 

MyQuery Plugin API  constants reference 
PLUGIN_FLAG_KEEPCTX 

Set in the context by the called plugin, to flag that the context is to be retained 

between calls. 

MyQueryPlugin API messages 
WM_CONTENT_REFRESH 

This message is defined by MyQueryUtils, so if this message is used, MyQueryUtils.h 

must be included. This message is sent in the case that the plugin called 

MyQueryPlugin_SetHwnd() in the entry point function, and an event that would require 

refreshing of the contents of the window occurs, such as a reconnected or a disconnect. 

MyQuery Plugin API  general function reference 
MYQUERY_PLUGIN_API MyQueryPlugin_Init() 

Arguments: 

HWND hWnd Window handle of application main window 

PMYQUERYPLUGINCTX pCtx Plugin context 

Returns: 

BOOL TRUE if initialization is successful, else FALSE. 

This function may be implemented by a Plugin library to perform any Plugin 

initialization needed when the plugin is loaded. 
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MYQUERY_PLUGIN_API MyQueryPlugin_DeInit() 

Arguments: 

HWND hWnd Window handle of application main window 

Returns: 

BOOL TRUE if deinitialization is successful, else FALSE. This is 

currently ignored. 

This function is optionally implemented by a Plugin library to perform tasks when the 

library is unloaded. Note that a library may be unloaded by MyQuery itself, which means that 

this function is implemented for example if the plugin implements a non-modal dialog, to 

close this. 

BOOL MYQUERY_PLUGIN_CALLBACK MyQueryPlugin_ReleaseCtx() 

Arguments: 

PMYQUERYPLUGINCTX pCtx Plugin context to release 

Returns: 

BOOL TRUE if successful, else FALSE. 

Call this function to release a context which is managed by the plugin itself. See 

MyQuery plugin contexts for more details. 

BOOL MYQUERY_PLUGIN_CALLBACK MyQueryPlugin_ExitPlugin() 

Arguments: 

PMYQUERYPLUGINCTX pCtx Plugin context to the exiting plugin 

Returns: 

BOOL TRUE if successful, else FALSE. 

This function will ensure that any information allocated by MyQuery for the plugin is 

made free when the plugin exists. This function MUST be called when the plug exits if the 

MyQueryPlugin_SetHwnd() function has been called when executing the plugin entry point.. 

LPTSTR MYQUERY_PLUGIN_CALLBACK MyQueryPlugin_GetFilename() 

Arguments: 

PMYQUERYPLUGINCTX pCtx The plugin context 

Returns: 

LPTSTR The filename, NULL if the filename isn't specified. 

Get the filename for the current script in the editor. 

LPTSTR MYQUERY_PLUGIN_CALLBACK MyQueryPlugin_GetScriptText() 

Arguments: 

PMYQUERYPLUGINCTX pCtx The plugin context 

Returns: 

LPTSTR The script text. 

Get the script text in the editor. After using the text, the memory must be freed by 

calling  MyQueryPlugin_MemFree(). 

BOOL MYQUERY_PLUGIN_CALLBACK MyQueryPlugin_SetScriptText() 

Arguments: 

PMYQUERYPLUGINCTX pCtx Plugin context 

LPTSTR pText 



MyQuery 3.5.6 Beta  Page 57 of  69 

 

 

Returns: 

BOOL FALSE if the setting of text was successful, else .TRUE. 

Set the script text in the editor. This is currently not supported using contexts that are 

managed by the plugin after the initial call has returned. 

BOOL MYQUERY_PLUGIN_CALLBACK MyQueryPlugin_SetHwnd() 

Arguments: 

PMYQUERYPLUGINCTX pCtx Plugin context 

HWND hWnd The main hWnd in the plugin 

Returns: 

BOOL TRUE if there was an error, else FALSE. 

Set a HWND that is managed by the MyQuery plugin context. The hWnd may be 

retrieved by calling MyQueryPlugin_GetHwnd. 

HWND MYQUERY_PLUGIN_CALLBACK MyQueryPlugin_GetHwnd() 

Arguments: 

PMYQUERYPLUGINCTX pCtx Plugin context 

Returns: 

HWND The hWnd set by a call to MyQueryPlugin_SetHwnd 

previously. 

Get the HWND that is managed by the MyQuery plugin context. 

BOOL MYQUERY_PLUGIN_CALLBACK MyQueryPlugin_SetUserData() 

Arguments: 

PMYQUERYPLUGINCTX pCtx Plugin context 

LPVOID pData The user defined data pointer. 

Returns: 

BOOL TRUE if there was an error, else FALSE. 

Set a void pointer that is managed by the MyQuery plugin context. The pointer may be 

retrieved by calling MyQueryPlugin_GetUserData. 

LPVOID MYQUERY_PLUGIN_CALLBACK MyQueryPlugin_GetUserData() 

Arguments: 

PMYQUERYPLUGINCTX pCtx Plugin context 

Returns: 

HWND The pointer set by a call to 

MyQueryPlugin_SetUserData previously. 

Get the data pointer that is managed by the MyQuery plugin context. 

BOOL MYQUERY_PLUGIN_CALLBACK MyQueryPlugin_SaveString() 

Arguments: 

PMYQUERYPLUGINCTX pCtx Plugin context 

LPTSTR pSection Section to set key  in. This may be NULL. 

LPTSTR pName String key value name. 

LPTSTR pValue String value to save. 

Returns: 
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BOOL TRUE if there was an error, else FALSE. 

Set a string value in the registry for this plugin. The exact location for storing the 

string is determined by MyQuery itself. Only 2 levels of storage are allowed, either in a 

specific section by setting pSection, or by setting pSection to NULL. 

BOOL MYQUERY_PLUGIN_CALLBACK MyQueryPlugin_SaveInt() 

Arguments: 

PMYQUERYPLUGINCTX pCtx Plugin context 

LPTSTR pSection Section to set key in. This may be NULL. 

LPTSTR pName String key value name. 

unsigned int nValue Integer value to save. 

Returns: 

BOOL TRUE if there was an error, else FALSE. 

Set an integer value in the registry for this plugin. The exact location for storing the 

value is determined by MyQuery itself. Only 2 levels of storage are allowed, either in a 

specific section by setting pSection, or by setting pSection to NULL. 

LPTSTR MYQUERY_PLUGIN_CALLBACK MyQueryPlugin_LoadAllocString() 

Arguments: 

PMYQUERYPLUGINCTX pCtx Plugin context 

LPTSTR pSection Section to load string value from. This may be NULL. 

LPTSTR pName String key value name. 

LPTSTR pDefault Default value if the key isn't found. 

Returns: 

LPTSTR The string value or the default, or NULL if there was an 

error. 

Get a string value from the registry for this plugin. The caller must free the returned 

value using the memory handle gotten with MyQueryPlugin_GetMemoryHandle 

BOOL MYQUERY_PLUGIN_CALLBACK MyQueryPlugin_LoadString() 

Arguments: 

PMYQUERYPLUGINCTX pCtx Plugin context 

LPTSTR pSection Section to load string value from. This may be NULL. 

LPTSTR pValue A pointer to the buffer where the string will be placed. 

LPTSTR pName String key value name. 

LPTSTR pDefault Default value if the key isn't found. 

DWORD dwValueSize Size of the buffer pointed to be pValue 

Returns: 

BOOL TRUE is the value wasn't found and pDefault is NULL, 

else FALSE. 

Get a string value from the registry for this plugin and copy it to the buffer pValue 

supplied by the caller. 
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MyQuery Plugin API Memory management function reference 
A plugin is free to handle memory anyway it wants to, but using the MyQuery 

functions has many advantages. For example can MyQuery be built with memory tracing, 

which allows easy access to where memory is allocated and deallocated and aids in tracking 

down memory leaks. 

void MYQUERY_PLUGIN_CALLBACK *MyQueryPlugin_MemAlloc() 

Arguments: 

PMYQUERYPLUGINCTX pCtx Plugin context to allocate memory in. 

unsigned int nSize Size of memory to allocate. 

Returns: 

void * A pointer to the allocated memory block, NULL if there 

was an error. 

Use this function to allocate memory from the MyQuery heap. 

void MYQUERY_PLUGIN_CALLBACK MyQueryPlugin_MemFree() 

Arguments: 

PMYQUERYPLUGINCTX pCtx Plugin context to free memory from. 

void * Pointer to memory to free. 

Returns: 

void * A pointer to the allocated memory block, NULL if there 

was an error. 

Pointer to a memory block allocated with MyQueryPlugin_MemAlloc() or any other 

MyQueryPlugin function that allocates memory. 

HANDLE MYQUERY_PLUGIN_CALLBACK MyQueryPlugin_GetMemoryHandle() 

Arguments: 

PMYQUERYPLUGINCTX pCtx Plugin context 

Returns: 

HANDLE Handle to the heap used by MyQuery itself. 

It is recommended that memory in the plugin is allocated from the Heap, and not from 

a heap local to the plugin or the process heap. 

MyQuery Plugin API MySQL function reference 
If the plugin is to connect to MySQL, this can be done in several ways. Either, the 

plugin can implement all this by itself or course. The easiest way is to let MyQuery handle 

this though, and there are four types of connections in that case: 

 The execute connection. This is the connection that MyQuery use to execute 

statements. 

 The monitor connection. This is the connection that is used for monitoring 

MySQL while a script is running, if MyQuery is in Dual Connection mode. 

 A connection unique for the plugin. 

 A connection shared with other plugins. 

In all these cases, except when using a plugin unique connection, the connection is 

protected by a mutex, which means that the plugin must return the connection after use. A 

plugin must NOT store the connection itself, this will cause all sort of trouble, instead, use the 

supplied functions to get a connection and return it after each use, and in the same state as 

when gotten. 
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MYSQL MYQUERY_PLUGIN_CALLBACK *MyQueryPlugin_GetMonitorConnection() 

Arguments: 

PMYQUERYPLUGINCTX pCtx Plugin context 

DWORD dwWait Time in ms to wait for the connection. 

Returns: 

MYSQL * A MySQL connection handle, NULL if there was an 

error or the timeout expired. 

Get the MySQL connection used by the MyQuery background operations. 

MYSQL MYQUERY_PLUGIN_CALLBACK *MyQueryPlugin_GetExecConnection() 

Arguments: 

PMYQUERYPLUGINCTX pCtx Plugin context 

DWORD dwWait Time in ms to wait for the connection. 

Returns: 

MYSQL * A MySQL connection handle, NULL if there was an 

error or the timeout expired. 

Get the MySQL connection used by the MyQuery to execute SQL scripts. 

MYSQL MYQUERY_PLUGIN_CALLBACK *MyQueryPlugin_GetConnection() 

Arguments: 

PMYQUERYPLUGINCTX pCtx Plugin context 

BOOL bShared Flag if this connection is shared with other plugins. 

DWORD dwWait Time in ms to wait for the connection. 

Returns: 

MYSQL * A MySQL connection handle, NULL if there was an 

error or the timeout expired. 

Get a MySQL Connection handle. If bShared is set, then this is shared with other 

plugins, else a new unique connection is returned. 

BOOL MYQUERY_PLUGIN_CALLBACK MyQueryPlugin_ReleaseConnection() 

Arguments: 

PMYQUERYPLUGINCTX pCtx Plugin context 

MYSQL *pMySQL The connection handle to release. 

BOOL bError Flag if errors were encountered during plugin execution. 

Returns: 

BOOL TRUE is there was an error, else FALSE. 

Release a connection handle acquired by any of the MySQL Connection functions 

above. 

LPTSTR MYQUERY_PLUGIN_CALLBACK MyQueryPlugin_GetMySQLVarValue() 

Arguments: 

PMYQUERYPLUGINCTX pCtx Plugin context 

LPTSTR pVarName Name of variable to get.. 

Returns: 
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LPTSTR The value of the MySQL variable. 

Get the value of a MySQL variable in the current MyQuery connection. 

Change log 

Version 3.5.6 
Features added. 

 Added optional “smart JSON” handling. 

 Added copy object name to clipboard to dictionary tool. 

 Fixed so that the apply button is enabled in the configuration dialogs when the 

user makes a change. 

 Added optional number formatting to status dialogs and tools. 

 Moved settings from HKEY_LOCAL_MACHINE to 

HKEY_CURRENT_USER. 

 NDB Monitor plugin is now removed completely and is no longer supported. 

 Added JSON format for saving results. 

 Added many new features for saving results in a more flexible way. 

 Added auto refresh for global and session status dialogs. 

 Added some defaults groups to global and session dialogs on installation. 

Bugs fixed: 

 Fixed a bug that caused a crash when running a user defined tool with a script. 

 Removed row tracking in the result listview that was obviously incorrect. 

 Fixed issues when running with a client library not supporting dynamic 

columns. 

 Fixed so that the installation and the program itself runs OK with UAC in 

Windows 10. 

Version 3.5.5 
This is a version which adds a few minor features. 

 Added filter for server variables. 

 Added feature to match non-leading part of status and server variable names by 

using a leading *. 

 Added the ability to enable / disable a tool based on the server version string. 

 Added column sort ability to SELECT user defined tools. 

 Added some MariaDB specific user tools. 

 Added an Advanced Processlist tool based on data from Performance Schema. 

 Changed the application icon and made sure it was used in all appropriate 

places. 

 Made the Organize Bookmarks dialog resizable. 

There is also one minor bug fixed: 

 Made sure that the Help->Documentation menu option works as expected. 

Version 3.5.4 
This version mainly adds support for MariaDB Dynamic Columns and supporting 

features and some minor features: 

 Dynamic column data is automatically detected. 

 Added dynamic column and JSON display in ShowData dialog. 

 Added Copy to new tab for editor. 

 Added single statement execution (Default key F-10). 

 Upgraded the documentation. 
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 Added MariaDB 10 syntax. 

 Removed Infobright extensions. 

 Added MySQL 5.6 and MariaDB 10 variables and status help links and text. 

 Added right-click menu to result to copy result to clipboard and show data. 

 Added the ability to copy a single column to the clipboard. 

Version 3.5.3 
This version adds some minor features: 

 Tooltip with the first characters in each editor tab to ease tab navigation. 

 Added the Run on warning feature for user defined tools 

 Added the Help->Documentation menu option to show the PDF documentation for 

the program. 

Bug fixed: 

 Fixed that when setting marker when a script covers more than one page the editor 

would to jump the marked line out of focus. 

 Fixed so the a user defined tool for Warnings is shown when the Warning icon in 

the statusbar is clicked. This feature was missing for a while, since the built-in 

warning dialog was removed. 

Version 3.5.2 
This version adds one new feature only, support for LOAD DATA LOCAL INFILE. 

Version 3.5.1 
Bugs fixed: 

 Fixed bug that caused auto reconnect to not work for all relevant errors. 

 Fixed bug that caused auto reconnect to hang in getting a mutex. 

 Fixed bug that caused connection to seem to work in some cases, when it actually 

didn't connect at all. 

Features removed: 

 Dual connections are no longer optional. This caused just too many issues and 

made the code overly complex, for no good reason. Also, having this feature 

optional made very little sense. 

 The Event editor is removed. This was very little used it seems, and it is somewhat 

substituted by the new dictionary viewer. 

 The Tables and Routines dictionary viewers and now substituted with the new 

dictionary viewer. 

Features added: 

 Added new dictionary viewer. 

Version 3.5.0 
Bugs fixed: 

 Fixed crashing bug when selecting a database in the connection dialog and then 

connecting. 

 Fixed several minor memory allocation bugs. 

 Fixed only help popup which sometimes didn't show. This is related to how 

Scintilla works, and this fixs makes it work better, but not perfect. This is not to 

say that there is a bug in Scintilla, rather that MyQuery uses a Scintilla feature for 

help pops which weren't really intended for this use. As it stands though, it works 

well enough. 

Features added: 

 Changed the Database Status dialogs to look more like the Variables dialog. 
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 Added Database Status groups. 

 Added support for Autocomplete. 

 Added memory allocation check functions. 

 Changed to use a much more recent version of Scintilla (3.2.2). 

Version 3.4.4 
Bugs fixed: 

 In the connection dialog, if the databases combobox was dropped down for an 

invalid connection, the connection got in a weird state and the application would 

crash on a subsequent connect. 

 Fixed some sizes for static strings that weren’t always properly shown. 

Features added: 

 Added seconds since first and previous columns to the Global and Session Status 

dialogs. 

 Added flag for only non-zero values to the Global and Session Status dialogs. 

 Added the ability to not allow refresh of User defined SQL tools. 

Version 3.4.3 
Bugfixes 

 Added support for large numbers in status dialog by using 64-bit integers. 

 Fixed a bug that caused non-default connections to not have the password de-

obfuscated when read from the registry. 

Version 3.4.2 
This releases fixes a few minor issues in the Break long Lines plugin and a adds a few 

Plugin callback functions. 

 Added a feature to optionally compress repeating spaces in the Break Long 

Lines plugin. 

 Fixed a bug that caused lines not to break at the right place and to garble the 

contents in some cases. 

 Added MyQuery callback functions MyQueryPlugin_MemAlloc() and  

MyQueryPlugin_MemFree(). 

Version 3.4.1 
This is a minor release with a few small bugfixes and one new feature: 

 Fixed a small bug that caused UAC in Windows 7 to freak out. In this case, it 

wasn’t UAC in itself, but rather UAC exposing a small bug (the registry was 

opened for write where only read was needed). 

 Fixed a bug in the SQL Statements dialog, which caused normalization not to 

work and eventually a crash. 

 Added the Single row vertical option for SQL SELECT User defined tools. 

 

Version 3.4.0 
This is mostly a bugfix and minor feature release, including a few larger features. 

 Changed again from using Semaphores to using Mutexes. Some releases back, 

there was a change for Semaphores instead of Mutexes. Fact is, mutexes are 

more appropriate here, but at that time, Semaphores has some advantages. 

Now I have cleanup up some stuff and Mutexes work as expected. 

 Fixed a bug that caused columns to have incorrect contents in the GLOBAL 

and SESSION STATUS dialogs, when columns were added dynamically. 
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 Fixed a bug that caused certain passwords to not be properly deobfuscated, 

causing the “Save Password” feature not to work in all cases. 

 Fixed a bug that caused only odd columns (i.e. only columns 1, 3, 5 etc) to be 

copied from the result to the clipboard. 

 Fixed a bug that caused crashing after a number of reconnects, caused by 

improper handling of Keyboard accelerators for user defined tools. 

 Checked and fixed built-in tools so that reconnects was handled properly and 

in a consistent way. 

 Fixed a bug that caused the Window title not to be set appropriately when a 

connect / disconnect was made from the File->Connect menu. 

 Editor Undo / Redo accelerators didn't work as expected, but that is fixed now. 

Menu options for this was enable / disabled when the edit menu was opened, 

but if this changed, then the accelerators didn't follow this. 

 Added OnLine help based on the help in the MySQL database itself. 

 Added a feature not to refresh a SQL User tool when using the execute 

connection and no database was selected for this. 

 Added a feature to ask the user before closing of modified editor tabs. 

 Added the Interactive setting for User defined external program tools. 

 Added the ability to open output files from User defined external program 

tools in an editor tab. 

 Added a feature to copy results to the clipboard using specific parameters for 

enclosing and separator strings and if to include column names or not. 

 Added a feature to only show processes with activity in the Show process list 

dialog. 

 Added some simple user defined tools, like a MySQL Commandline and a 

Schema tool. 

 INCOMPATIBLE CHANGE: MyQueryPlugin_SetUserHwnd() and 

MyQueryPlugin_GetUserHwnd() have been renamed to 

MyQueryPlugin_SetHwnd() and MyQueryPlugin_GetHwnd(). 

 Added margin markers for current, error and user marked lines. 

 Added an error indicator feature. Not very advanced, but it works. 

Version 3.3.4 
 Fixed a bug in handling of delimiter commands, where the current delimiter 

wasn't properly reset, causing a script that had a different delimiter set at the 

end, would assume that delimiter at the start of the script also. 

Version 3.3.3 
 NOTE: Incompatible change! Version 3.3.3 extends the Plugin API with a 

revised version of the function MyQueryPlugin_LoadString() with different 

arguments. The old version which allocated string space is now called 

MyQueryPlugin_LoadAllocString(). 

 Some subtle changes in how the NdbMonitor plugin handles the data columns 

in the node list. 

Version 3.3.2 
This is again a bugfix release, which fixes three issues: 

 Changing the path and/or Entry Point for a plugin tool required a restart to 

have the desired effect. 

 A memory access bug in NdbMonitor caused all sort of trouble. 

 Minidump wasn't included in the release build. This was a result of the project 

structure changes, where I just forgot this feature. 
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Version 3.3.1 
This is a fix for some problems with 3.3.0 on some platforms, dealing with how 

manifests are handled. Also, to avoid these problems, I now link statically with the Microsoft 

runtime library. 

In the process of fixing these errors, the structure of the project was cleaned up and 

updated, and is now best built with Visual Studio 2008. 

Also, a little nasty bug when getting properties from a plugin was fixed. 

Version 3.3.0 
This version add user defined extensions to MyQuery and several fixes and additions. 

 Added the ability to add user defined scripts to run. 

 Added user defined SQL SELECT statements to run as separate windows, 

modal or non-modal. 

 Added the ability to run external programs and plugins. 

 Added the ability to open user defined Internet Links from the tools menu. 

 Changed the startup behavior, so that the editor is shown before the initial 

logon screen is shown. 

 Added the ability to use several different user defined logon parameter sets. 

 Added the ability to export and import MyQuery settings. 

 Updated the MySQL Lexer in Scintilla to support code folding much better. 

 Changed from static to dynamic linking, this was more of less required when 

working with Plugins in MyQuery. 

 Added a whole bunch of plugins and user defined tools. 

 Fixed a crashing bug when using the Dictionary views when being connected 

but not having a default current database. 

Version 3.2.1 
This version fixes a bug in Version 3.2 where printing of UTF8 data wasn’t handled 

properly. 

Version 3.2 
The major theme for this release follows the other 3.x releases, usability and features. 

This release adds, in terms of usability, much better keyboard navigation facilities, that allows 

navigation of the main window using the Tab key, as well as several new accelerators for 

direct access to items in the main menu. Also, a new non-modal window with help for the 

current accelerators, and the ability to print a reference for these, has been added. 

In terms of features, the main one by far is printing support. By means of Scintilla, 

printing of the SQL script was easy to implement, and supports printing in highlighted format. 

Also, printing of Query results is implemented, and this turned out to be much more 

complicated than initially envisioned. This release should be a GA release really, and most of 

it is, but as printing support turned out so complex and is completely new, although well 

isolated from the rest of the code. 

 Added script printing support. 

 Added result printing support. 

 Added keyboard navigation facilities. 

 Added tooltips to editor preferences dialogs. 

 Added several new accelerators. 

 Added a feature to show a dialog with the assigned accelerator keys. 

 Added a feature to print the assigned accelerator keys. 

 Fixed a bug that caused the general editor preferences not be to saved or 

loaded properly. 
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 Fixed a bug that caused the Accelerators to override the usual Ctrl-Tab 

navigation for the result tabs. 

 Fixed a crashing bug when clicking on an error link in the output window. This 

was caused by the error message being incorrectly formatted and including an 

empty filename. 

 Fixed a bug that caused a crash when reexecuting a query after a reconnect. 

Version 3.1.1 
Fixed a slight, but crashing, bug in the Group by status checkbox in the SQL Profile 

dialog. 

Version 3.1 
This releases fixes a few bugs from MyQuery 3.0, but also adds many new features. In 

addition, some areas in terms of usability of old features have been fixed, this relates mostly 

to drag and drop support, which is now greatly enhanced. Also, another minor, but important 

and more complex fix that you think, is limited UTF-8 Support, as suggested by a user. 

Also, the Events dictionary dialog was added, as well as a Server variables dialog. 

Support for viewing statement profiles, as the result of the MySQL SQL PROFILE 

command was added. This is pretty extensive, and includes features allowing you to compare 

the profile of two statements, among other cool things. 

Support for affected and matched rows for updating statements was added, both on the 

status messages and in the Script information dialog. 

A warning indicator was added to the Status bar. 

Version 3.0 
In general, this is a feature release with many small features being  added (see below) 

and refactoring of the code was done, as well as some rewrites. One feature, which was part 

of version 2.3.2, but which never worked well, Automatic reconnection, was fixed and fully 

implemented. 

 Dual connection was implemented, to allow the user to stop a running query. 

 Multiple editor tabs, to allow you to have multiple editors open at the same 

time. All editors share the same connection though, the other connection, of 

using the optional dual connection feature, is used for control purposes. 

 Automatic reconnection was implemented. 

 Many new status monitor dialogs were implemented, most as non-modal 

dialogs, so they can remain open while running and editing SQL scripts. 

 Some Dictionary dialogs were also implemented, again as non-modal dialogs. 

 Keyboard accelerators were implemented in many more places, and were made 

configurable by the user. 

 Editor syntax highlighting was also made much flexible, so that the keywords 

that make of the different kinds of colour coded words are now placed in files 

that can be configured and edited by the user. 

 A large amount of (manual) refactoring of the code was done. Manual as I 

wanted to force myself to re-read large parts of the code. 

 Many bugs were fixed, but as many new features were also added, version 3.0 

is still considered Alpha, and in addition to requiring more testing, a few 

features are still missing, which makes this Alpha and not Beta. 

 Version 2.3.2 

 Fixed a minor bug that would cause a crash when reading a non-existing 

registry entry for editor settings. 

Version 2.3.1 
 Allow installations as non-Administrator. 
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Version 2.3 
 Added OUTPUT_FILE, SPARSE_OUTPUT_FILE, CLOSE_OUTPUT and 

CLOSE_SPARSE_OUTPUT commented internal commands. 

 Added the SOURCE internal command. 

 Made the databases combobox dynamic, so that the current list of databases is 

updated each time the combobox is opened, which in turn means that the menu 

option Tools->Refresh database list is redundant and has been removed. 

 Restructured the Preferences dialog to use a tabbed dialog, and made the 

different tabs more independent. 

 Made default syntax highlighting better than the previous black on white for all 

styles. 

 Made the tray icon active in the sense that clicking it will bring the active 

MyQuery instance to the foreground. 

 Restructured pieces of the code to work better with the new SOURCE 

command and related file commands. 

 Version 2.2.1 

 Fixed a minor bug which caused the Output and Error panes to have no 

scrollbars. 

 Fixed a bug that computed the size of a script wrong, making it not be present 

in the History, although it should be there. 

 Fixed a NULL pointer issue with a script being retrieved from the History onto 

a NULL script. 

Version 2.2 
 Fixed an installer bug that caused the installer to hand around if the “Run 

MyQuery” button was checked. 

 Fixed an issue with “SHOW INNODB STATUS”, that works slightly different 

in 5.1 compared to 5.0 of MySQL. 

 Added Bookmarks support. 

 Added lockable resultsets support. 

 Fixed a few minor bugs. 

 Updated documentation. 

Version 2.1.1 
 Fixed a bug with saving result data. 

 Added the ability to save all the datasets or the currently active one only. 

Version 2.1 
 Added handling of multiple resultsets as returned from Stored Procedures. 

 Added a wait cursor while statements are being executed. 

 Added up/down spin-controls to a few configuration settings. 

 Added an optional tray icon to show processing status. 

 Added a file association menu item. 

 Added file association and a few other fixes to the installation program. 

 For file associations to work, added the optional file name argument, which 

will open MyQuery with the specified file in the editor. 

 Fixed a few memory leaks. 

 Cleaned up handling of results in general, and moved this code to a separate 

file. 

 Preparations for Unicode support. 
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Version 2.0.1 
 Changed from using named to unnamed mutexes, as this caused, expected, 

problems when using multiple instances of the application. 

 Version 2.0 

 Syntax highlighting through Scintilla and a custom MySQL Lexer. 

 MySQL syntax folding through Scintilla. 

 Windows application implemented, no longer Dialog based. 

 Fixed history to work better. 

 Code restructuring. 

 Search and replace, including Regular expressions. 

 Fixed a few minor bugs, among them quoted identifiers for the USE command, 

and a few other minor fixes. 

 Added editor coloring dialogs. 

 Added custom keywords with optional dictionary lookup. 

 Fixed some memory leaks. 

Version 1.1.1 
 Fix a bug related to a delimiter command that was set to a string that included 

part of the current delimiter, i.e. setting it to ;; when it is already at ; 

 Fixed a potential memory leak related to the file drop functionality. 

Version 1.1 
 Added “Execute to current statement” feature 

 Added Minimize and Maximize buttons 

 Added Scroll feedback in editor for use with large scripts 

 Updates relevant segments in documentation 

 Begun some code cleanup and restructuring 

To do 
Among the features to be added in future releases are, in no particular order and 

excluding the obvious memory checking and stability tests: 

 Ability to run scripts without loading them in their entirety in the editor. This is 

a rather big, but hardly impossible task, depending on how much functionality 

this feature should have. I have a plan for this, and it will appear in some 

version in a not too distant future. 

 The ability to put commands and possibly results in a file as they are executed. 

There are some optional ideas here, like using this for a log, or running a script 

and only put the successfully executed in the log and so in. This should be 

controlled by both preferences and commented internal commands. 

 Update the documentation (this document). Although most that should be there 

is in place, it has become a fair bit unstructured after several edits. 

 Implement the ability to continue editing in one tab, while running a script in 

another. This really should mostly work today, but it does require some small 

changes, and quite some testing, so I haven’t dared implementing it yet. 

 More dictionary views, like triggers, indexes and above, all users and user 

privileges. In particular the latter is hard to determine without some 

programming, because of the way MySQL does this (i.e. GRANTs can be 

made both to (user X may access object Y) as from (database X may be access 

by users Y), which may not sound of much of a problem, unless wildcards 

were involved, which they are. 
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 Remodeling the way the SOURCE command is handled, current this relies on 

the history feature for keeping track of multiple level of script processing, but I 

would rather use the multiple editor tabs introduced with MyQuery 3.0 for this. 

 Add Wizards. I want to add Wizards for a whole bunch of things. Although we 

know how to create a table and things like that, some more uncommon tasks 

often require us to look it up in the manual. I want to add Wizards for this 

instead, not only for tables, but also for procedures, tablespaces, events and 

such things. 

 Online documentation. This is way overdue, but I have still to find a good 

authoring tool for this. Microsoft seems to be changing their minds about this 

all the time, i.e. formats and stuff like that. 

 Export data in JSON format is also something I want to add. 


