"Fossies" - the Fresh Open Source Software Archive

Member "xterm-379/package/pkgsrc/options.mk" (11 Jul 2013, 1448 Bytes) of package /linux/misc/xterm-379.tgz:


As a special service "Fossies" has tried to format the requested source page into HTML format using (guessed) Make source code syntax highlighting (style: standard) with prefixed line numbers. Alternatively you can here view or download the uninterpreted source code file.

    1 # $NetBSD: options.mk,v 1.14 2013/07/11 11:44:07 wiz Exp $
    2 
    3 PKG_OPTIONS_VAR=        PKG_OPTIONS.xterm
    4 PKG_SUPPORTED_OPTIONS=      debug pcre freetype luit xpm xterm-toolbar
    5 PKG_SUGGESTED_OPTIONS=      freetype luit xpm
    6 
    7 .include "../../mk/bsd.options.mk"
    8 
    9 .if !empty(PKG_OPTIONS:Mdebug)
   10 CONFIGURE_ARGS+=    --enable-trace
   11 CONFIGURE_ARGS+=    --enable-warnings
   12 .elif defined(PKG_DEVELOPER) && !empty(PKG_DEVELOPER:M[Yy][Ee][Ss])
   13 CONFIGURE_ARGS+=    --enable-warnings
   14 .endif
   15 
   16 .if !empty(PKG_OPTIONS:Mfreetype)
   17 CONFIGURE_ARGS+=    --enable-freetype
   18 .  include "../../x11/libXft/buildlink3.mk"
   19 .else
   20 CONFIGURE_ARGS+= --disable-freetype
   21 .endif
   22 ###
   23 ### XXX The configure test checks for pcreposix_regcomp in libpcreposix.
   24 ### However, there is no such function [insofar as I can tell].
   25 ### Moreover, libc's regex(3) functions are weak-aliased to those
   26 ###     within libc's namespace, so we should have no problems.
   27 ###
   28 .if !empty(PKG_OPTIONS:Mpcre)
   29 CONFIGURE_ARGS+=    --with-pcre
   30 CONFIGURE_ENV+=     ac_cv_lib_pcreposix_pcreposix_regcomp=yes
   31 .  include "../../devel/pcre/buildlink3.mk"
   32 .endif
   33 
   34 .if !empty(PKG_OPTIONS:Mluit)
   35 DEPENDS+=   luit-[0-9]*:../../x11/luit
   36 CONFIGURE_ARGS+=    --enable-luit --enable-mini-luit
   37 .else
   38 CONFIGURE_ARGS+=    --disable-luit --disable-mini-luit
   39 .endif
   40 
   41 .if !empty(PKG_OPTIONS:Mxpm)
   42 ### nothing
   43 .else
   44 CONFIGURE_ARGS+=    --without-xpm
   45 .endif
   46 
   47 .if !empty(PKG_OPTIONS:Mxterm-toolbar)
   48 CONFIGURE_ARGS+=    --enable-toolbar
   49 .else
   50 CONFIGURE_ARGS+=    --disable-toolbar
   51 .endif