"Fossies" - the Fresh Open Source Software Archive

Member "phpMyAdmin-5.1.0-english/doc/html/_sources/require.rst.txt" (24 Feb 2021, 1683 Bytes) of package /linux/www/phpMyAdmin-5.1.0-english.zip:


As a special service "Fossies" has tried to format the requested text file into HTML format (style: standard) with prefixed line numbers. Alternatively you can here view or download the uninterpreted source code file. See also the last Fossies "Diffs" side-by-side code changes report for "require.rst.txt": 5.0.2-english_vs_5.0.3-english.

    1 .. _require:
    2 
    3 Requirements
    4 ============
    5 
    6 Web server
    7 ----------
    8 
    9 Since phpMyAdmin's interface is based entirely in your browser, you'll need a
   10 web server (such as Apache, nginx, :term:`IIS`) to install phpMyAdmin's files into.
   11 
   12 PHP
   13 ---
   14 
   15 * You need PHP 7.1.3 or newer, with ``session`` support, the Standard PHP Library
   16   (SPL) extension, hash, ctype, and JSON support.
   17 
   18 * The ``mbstring`` extension (see :term:`mbstring`) is strongly recommended
   19   for performance reasons.
   20 
   21 * To support uploading of ZIP files, you need the PHP ``zip`` extension.
   22 
   23 * You need GD2 support in PHP to display inline thumbnails of JPEGs
   24   ("image/jpeg: inline") with their original aspect ratio.
   25 
   26 * When using the cookie authentication (the default), the `openssl
   27   <https://www.php.net/openssl>`_ extension is strongly suggested.
   28 
   29 * To support upload progress bars, see :ref:`faq2_9`.
   30 
   31 * To support XML and Open Document Spreadsheet importing, you need the
   32   `libxml <https://www.php.net/libxml>`_ extension.
   33 
   34 * To support reCAPTCHA on the login page, you need the
   35   `openssl <https://www.php.net/openssl>`_ extension.
   36 
   37 * To support displaying phpMyAdmin's latest version, you need to enable
   38   ``allow_url_open`` in your :file:`php.ini` or to have the
   39   `curl <https://www.php.net/curl>`_ extension.
   40 
   41 .. seealso:: :ref:`faq1_31`, :ref:`authentication_modes`
   42 
   43 Database
   44 --------
   45 
   46 phpMyAdmin supports MySQL-compatible databases.
   47 
   48 * MySQL 5.5 or newer
   49 * MariaDB 5.5 or newer
   50 
   51 .. seealso:: :ref:`faq1_17`
   52 
   53 Web browser
   54 -----------
   55 
   56 To access phpMyAdmin you need a web browser with cookies and JavaScript
   57 enabled.
   58 
   59 You need a browser which is supported by jQuery 2.0, see
   60 <https://jquery.com/browser-support/>.