"Fossies" - the Fresh Open Source Software Archive

Member "elasticsearch-6.8.23/modules/x-pack-upgrade/plugin-descriptor.properties" (6 Jan 2022, 1467 Bytes) of package /linux/www/elasticsearch-6.8.23.tar.gz:


As a special service "Fossies" has tried to format the requested text file into HTML format (style: standard) with prefixed line numbers. Alternatively you can here view or download the uninterpreted source code file.

    1 # Elasticsearch plugin descriptor file
    2 # This file must exist as 'plugin-descriptor.properties' inside a plugin.
    3 #
    4 ### example plugin for "foo"
    5 #
    6 # foo.zip <-- zip file for the plugin, with this structure:
    7 # |____   <arbitrary name1>.jar <-- classes, resources, dependencies
    8 # |____   <arbitrary nameN>.jar <-- any number of jars
    9 # |____   plugin-descriptor.properties <-- example contents below:
   10 #
   11 # classname=foo.bar.BazPlugin
   12 # description=My cool plugin
   13 # version=6.0
   14 # elasticsearch.version=6.0
   15 # java.version=1.8
   16 #
   17 ### mandatory elements for all plugins:
   18 #
   19 # 'description': simple summary of the plugin
   20 description=Elasticsearch Expanded Pack Plugin - Upgrade
   21 #
   22 # 'version': plugin's version
   23 version=6.8.23
   24 #
   25 # 'name': the plugin name
   26 name=x-pack-upgrade
   27 #
   28 # 'classname': the name of the class to load, fully-qualified.
   29 classname=org.elasticsearch.xpack.upgrade.Upgrade
   30 #
   31 # 'java.version': version of java the code is built against
   32 # use the system property java.specification.version
   33 # version string must be a sequence of nonnegative decimal integers
   34 # separated by "."'s and may have leading zeros
   35 java.version=1.8
   36 #
   37 # 'elasticsearch.version': version of elasticsearch compiled against
   38 elasticsearch.version=6.8.23
   39 ### optional elements for plugins:
   40 #
   41 #  'extended.plugins': other plugins this plugin extends through SPI
   42 extended.plugins=x-pack-core
   43 #
   44 # 'has.native.controller': whether or not the plugin has a native controller
   45 has.native.controller=false
   46