"Fossies" - the Fresh Open Source Software Archive

Member "mod_fastcgi-2.4.7-0910052141/debian/libapache2-mod-fastcgi.postinst" (10 Apr 2012, 1422 Bytes) of package /linux/www/apache_httpd_modules/old/mod_fastcgi-2.4.7-0910052141.tar.gz:


As a special service "Fossies" has tried to format the requested source page into HTML format using (guessed) Bash source code syntax highlighting (style: standard) with prefixed line numbers and code folding option. Alternatively you can here view or download the uninterpreted source code file.

    1 #! /bin/sh
    2 # postinst script for libapache-mod-fastcgi
    3 #
    4 # see: dh_installdeb(1)
    5 
    6 set -e
    7 
    8 # summary of how this script can be called:
    9 #        * <postinst> `configure' <most-recently-configured-version>
   10 #        * <old-postinst> `abort-upgrade' <new version>
   11 #        * <conflictor's-postinst> `abort-remove' `in-favour' <package>
   12 #          <new-version>
   13 #        * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
   14 #          <failed-install-package> <version> `removing'
   15 #          <conflicting-package> <version>
   16 # for details, see http://www.debian.org/doc/debian-policy/ or
   17 # the debian-policy package
   18 #
   19 # quoting from the policy:
   20 #     Any necessary prompting should almost always be confined to the
   21 #     post-installation script, and should be protected with a conditional
   22 #     so that unnecessary prompting doesn't happen if a package's
   23 #     installation fails and the `postinst' is called with `abort-upgrade',
   24 #     `abort-remove' or `abort-deconfigure'.
   25 
   26 case "$1" in
   27     configure)
   28     test ! -e /etc/apache2/mods-enabled/fcgid.load \
   29       -a ! -e /etc/apache2/mods-enabled/fastcgi.load \
   30       && a2enmod fastcgi
   31     ;;
   32 
   33     abort-upgrade|abort-remove|abort-deconfigure)
   34 
   35     ;;
   36 
   37     *)
   38         echo "postinst called with unknown argument \`$1'" >&2
   39         exit 1
   40     ;;
   41 esac
   42 
   43 # dh_installdeb will replace this with shell code automatically
   44 # generated by other debhelper scripts.
   45 
   46 #DEBHELPER#
   47 
   48 exit 0
   49 
   50