"Fossies" - the Fresh Open Source Software Archive

Member "swig-4.1.1/CCache/debian/patches/11_utimes.diff" (30 Nov 2022, 2434 Bytes) of package /linux/misc/swig-4.1.1.tar.gz:


As a special service "Fossies" has tried to format the requested source page into HTML format using (guessed) Diff source code syntax highlighting (style: standard) with prefixed line numbers. Alternatively you can here view or download the uninterpreted source code file.

    1 --- ccache.c    2004-09-13 03:38:30.000000000 -0700
    2 +++ ccache.c    2006-06-09 16:29:16.695117780 -0700
    3 @@ -481,8 +481,13 @@
    4  
    5     /* update timestamps for LRU cleanup
    6        also gives output_file a sensible mtime when hard-linking (for make) */
    7 +#ifdef HAVE_UTIMES
    8 +       utimes(hashname, NULL);
    9 +   utimes(stderr_file, NULL);
   10 +#else
   11     utime(hashname, NULL);
   12     utime(stderr_file, NULL);
   13 +#endif
   14  
   15     if (strcmp(output_file, "/dev/null") == 0) {
   16         ret = 0;
   17 --- ccache.h    2004-09-13 03:38:30.000000000 -0700
   18 +++ ccache.h    2006-06-09 16:28:16.601658626 -0700
   19 @@ -22,6 +22,9 @@
   20  #ifdef HAVE_PWD_H
   21  #include <pwd.h>
   22  #endif
   23 +#ifdef HAVE_SYS_TIME_H
   24 +#include <sys/time.h>
   25 +#endif
   26  
   27  #define STATUS_NOTFOUND 3
   28  #define STATUS_FATAL 4
   29 --- config.h.in 2003-09-27 21:48:17.000000000 -0700
   30 +++ config.h.in 2006-06-09 16:25:43.000000000 -0700
   31 @@ -19,6 +19,9 @@
   32  /* Define to 1 if you have the `gethostname' function. */
   33  #undef HAVE_GETHOSTNAME
   34  
   35 +/* Define to 1 if you have the `getpwuid' function. */
   36 +#undef HAVE_GETPWUID
   37 +
   38  /* Define to 1 if you have the <inttypes.h> header file. */
   39  #undef HAVE_INTTYPES_H
   40  
   41 @@ -31,6 +34,9 @@
   42  /* Define to 1 if you have the <ndir.h> header file, and it defines `DIR'. */
   43  #undef HAVE_NDIR_H
   44  
   45 +/* Define to 1 if you have the <pwd.h> header file. */
   46 +#undef HAVE_PWD_H
   47 +
   48  /* Define to 1 if you have the `realpath' function. */
   49  #undef HAVE_REALPATH
   50  
   51 @@ -60,6 +66,9 @@
   52  /* Define to 1 if you have the <sys/stat.h> header file. */
   53  #undef HAVE_SYS_STAT_H
   54  
   55 +/* Define to 1 if you have the <sys/time.h> header file. */
   56 +#undef HAVE_SYS_TIME_H
   57 +
   58  /* Define to 1 if you have the <sys/types.h> header file. */
   59  #undef HAVE_SYS_TYPES_H
   60  
   61 @@ -69,6 +78,9 @@
   62  /* Define to 1 if you have the <unistd.h> header file. */
   63  #undef HAVE_UNISTD_H
   64  
   65 +/* Define to 1 if you have the `utimes' function. */
   66 +#undef HAVE_UTIMES
   67 +
   68  /* Define to 1 if you have the `vasprintf' function. */
   69  #undef HAVE_VASPRINTF
   70  
   71 --- configure.in    2004-09-13 03:38:30.000000000 -0700
   72 +++ configure.in    2006-06-09 16:25:15.541288184 -0700
   73 @@ -27,10 +27,11 @@
   74  AC_HEADER_TIME
   75  AC_HEADER_SYS_WAIT
   76  
   77 -AC_CHECK_HEADERS(ctype.h strings.h stdlib.h string.h pwd.h)
   78 +AC_CHECK_HEADERS(ctype.h strings.h stdlib.h string.h pwd.h sys/time.h)
   79  
   80  AC_CHECK_FUNCS(realpath snprintf vsnprintf vasprintf asprintf mkstemp)
   81  AC_CHECK_FUNCS(gethostname getpwuid)
   82 +AC_CHECK_FUNCS(utimes)
   83  
   84  AC_CACHE_CHECK([for compar_fn_t in stdlib.h],ccache_cv_COMPAR_FN_T, [
   85      AC_TRY_COMPILE(