"Fossies" - the Fresh Open Source Software Archive 
Member "swig-4.1.1/CCache/debian/patches/10_lru_cleanup.diff" (30 Nov 2022, 559 Bytes) of package /linux/misc/swig-4.1.1.tar.gz:
As a special service "Fossies" has tried to format the requested source page into HTML format using (guessed) Diff source code syntax highlighting (style:
standard) with prefixed line numbers.
Alternatively you can here
view or
download the uninterpreted source code file.
1 --- ccache.c (révision 8804)
2 +++ ccache.c (copie de travail)
3 @@ -481,6 +481,9 @@
4 return;
5 }
6
7 + /* update timestamps for LRU cleanup
8 + also gives output_file a sensible mtime when hard-linking (for make) */
9 + utime(hashname, NULL);
10 utime(stderr_file, NULL);
11
12 if (strcmp(output_file, "/dev/null") == 0) {
13 @@ -513,10 +516,6 @@
14 failed();
15 }
16 }
17 - if (ret == 0) {
18 - /* update the mtime on the file so that make doesn't get confused */
19 - utime(output_file, NULL);
20 - }
21
22 /* get rid of the intermediate preprocessor file */
23 if (i_tmpfile) {