"Fossies" - the Fresh Open Source Software Archive

Member "sleuthkit-4.6.6/framework/INSTALL_unix.txt" (25 Apr 2019, 2951 Bytes) of package /linux/privat/sleuthkit-4.6.6.tar.gz:


As a special service "Fossies" has tried to format the requested text file into HTML format (style: standard) with prefixed line numbers. Alternatively you can here view or download the uninterpreted source code file.

    1                     The Sleuth Kit Framework
    2                 http://www.sleuthkit.org/sleuthkit
    3 
    4               Installation Instructions for Linux / OS X
    5 
    6                    Last Modified: Apr 8, 2013
    7 
    8 
    9 REQUIREMENTS
   10 =============================================================================
   11 Tested Platform:
   12 - Linux 2.*
   13 - Mac OS X
   14 
   15 Build System:
   16 - C/C++ compiler
   17 - GNU Make
   18 - GNU autoconf, automake, and libtool
   19 
   20 
   21 Required Libraries:
   22 The following libraries must be installed before building and install
   23 the framework.
   24 
   25 - POCO: POCO is a set of open source C++ classes for building
   26 portable applications.  The Sleuth Kit framework uses POCO to handle
   27 some basic internal tasks.  Testing has been performed with version
   28 1.4.4 of the POCO libraries.
   29     Available at http://www.pocoproject.org
   30 
   31 The modules may also have library dependencies.  For example, the
   32 file type module requires libmagic.  The documents in each module
   33 will list them .
   34 
   35 
   36 INSTALLATION
   37 =============================================================================
   38 
   39 Refer to the INSTALL_win.txt file for details on building using
   40 Microsoft Visual Studio 2010.
   41 
   42 The Sleuth Kit framework uses the GNU autotools for building and
   43 installation.  There are a few steps to this process.  First, run
   44 the 'configure' script in the framework directory.  This will also
   45 run configure in all of the modules.  The modules have been designed
   46 to not fatally fail if a dependency exists so that you can continue
   47 to build all of them.  Refer to the end of the output for messages
   48 about missing dependencies.
   49 
   50     $ ./configure
   51 
   52 If there were no errors, then run 'make'.  This will also run make
   53 in all of the modules.
   54 
   55     $ make
   56 
   57 The 'make' process will take a while and will build the framework
   58 library, tools that use the framework, and modules that load into
   59 the framework.  
   60 
   61 The tools are in the "tools" directory and the modules were copied
   62 into the "runtime" directory. You can run the tools from this layout.
   63 For quick reference, tsk_analyzeimg is a tool that can drive the
   64 entire framework.
   65 
   66 To install the tools, moduless, and framework, type 'make install'.
   67 
   68     $ make install
   69 
   70 By default, this will copy everything in to the /usr/local/ structure.
   71 
   72 If you get an error like:
   73 
   74   libtool: Version mismatch error.  This is libtool 2.2.10, but the
   75   libtool: definition of this LT_INIT comes from libtool 2.2.4.
   76   libtool: You should recreate aclocal.m4 with macros from libtool 2.2.10
   77   libtool: and run autoconf again.
   78 
   79 Run:
   80     ./bootstrap 
   81 
   82 and then go back to running configure and make.  To run 'bootstrap',
   83 you'll need to have the autotools installed (see the list at the
   84 top of this page).
   85 
   86 
   87 CONFIGURE OPTIONS
   88 -----------------------------------------------------------------------------
   89 The framework doesn't support extra arguments to 'configure'
   90 
   91 
   92 -----------------------------------------------------------------------------
   93 
   94 Brian Carrier
   95 carrier <at> sleuthkit <dot> org