"Fossies" - the Fresh Open Source Software Archive

Member "roundcubemail-1.4.2/UPGRADING" (1 Jan 2020, 4148 Bytes) of package /linux/www/roundcubemail-1.4.2.tar.gz:


As a special service "Fossies" has tried to format the requested text file into HTML format (style: standard) with prefixed line numbers. Alternatively you can here view or download the uninterpreted source code file. See also the latest Fossies "Diffs" side-by-side code changes report for "UPGRADING": 1.4.1_vs_1.4.2.

    1 UPGRADING instructions
    2 ======================
    3 
    4 Follow these instructions if upgrading from a previous version
    5 of Roundcube Webmail. We recommend to carefully backup the existing
    6 installation as well as the database before going through the following steps.
    7 
    8 Using the update script
    9 -----------------------
   10 There is a shell script (for unix based systems) that does the job for you.
   11 To use it, unpack the archive of the new Roundcube version to a temporary location
   12 (don't replace the Roundcube installation you want to update)
   13 and cd into that directory. From there, run the following command in a shell:
   14 
   15   ./bin/installto.sh <TARGET-FOLDER>
   16 
   17 For <TARGET-FOLDER> you specify the path to the Roundcube installation
   18 which should be updated. The update script will then copy all new files to the
   19 target location and check and update the configuration and database schema.
   20 After all is done, the temporary folder with the new Roundcube files can be
   21 removed again.
   22 
   23 WARNING: Make sure files have proper owner/group for your setup. If you use
   24          tar to extract the package, `--no-same-owner` option might be helpful.
   25 WARNING: See Post-Upgrade Activities section below.
   26 
   27 
   28 Updating manually
   29 -----------------
   30 If you don't have shell access to the Roundcube installation or if not running
   31 it on a unix system, you need to do the following operations by hand:
   32 
   33 1. Replace index.php and all files in
   34    - ./bin/
   35    - ./SQL/
   36    - ./program/
   37    - ./installer/
   38 2. Replace the configuration defaults files:
   39    - config/defaults.inc.php
   40    - config/mimetypes.php
   41 3. rsync the contents of the following folders from your installation
   42    directory into the target folder:
   43    ./skins/
   44    ./plugins/
   45    ./vendor/
   46 4. Update dependencies:
   47 4a. If you previously installed plugins through composer, update dependencies
   48    by running `php composer.phar update --no-dev`.
   49 4b. Install/update dependencies using composer:
   50    - get composer from https://getcomposer.org/download/
   51    - rename the composer.json-dist file into composer.json
   52    - if you want to use LDAP address books, enable the LDAP libraries in your
   53      composer.json file by moving the items from "suggest" to the "require"
   54      section (remove the explanation texts after the version!).
   55    - run `php composer.phar install --no-dev`.
   56 4c. If you use git sources or the release package without dependencies
   57    update javascript dependencies by executing `bin/install-jsdeps.sh` script.
   58 4d. If you use git sources compile css files for the Elastic skin (required
   59    lessc >= 1.5.0):
   60    $ cd skins/elastic
   61    $ lessc -x styles/styles.less > styles/styles.css
   62    $ lessc -x styles/print.less > styles/print.css
   63    $ lessc -x styles/embed.less > styles/embed.css
   64 5. Run `./bin/update.sh` from the commandline OR
   65    open http://url-to-roundcube/installer/ in a browser and choose "3 Test config".
   66    To enable the latter one, you have to temporary set 'enable_installer'
   67    to true in your local config/config.inc.php file.
   68    WARNING: See SQLite database upgrade below.
   69 6. Let the update script/installer check your configuration and
   70    update your config files and database schema as suggested by the updater.
   71 7. Make sure 'enable_installer' is set to false again.
   72 8. See Post-Upgrade Activities section.
   73 
   74 
   75 Post-Upgrade Activities
   76 -----------------------
   77 1. Check system requirements in INSTALL file.
   78 2. If you're using build-in addressbook, run indexing script /bin/indexcontacts.sh.
   79 3. When upgrading from version older than 0.6-beta you should make sure
   80    your folder settings contain namespace prefix. For example Courier users
   81    should add INBOX. prefix to folder names in main configuration file.
   82 4. When upgrading from version older than 1.4.0 make sure old files
   83    in configured temp_dir are removed. Since this version we use constant filename
   84    prefix and do not remove files not starting with "RCMTEMP".
   85 
   86 SQLite database upgrade
   87 -----------------------
   88 Versions older than 0.9 were supporting SQLite v2 only. Newer versions require
   89 database in v3 format. The best what you can do is to convert database file
   90 to the new format using command line tools:
   91 
   92 sqlite OLD.DB .dump | sqlite3 NEW.DB