"Fossies" - the Fresh Open Source Software Archive

Member "netbiff-0.9.18/debian/rules" (7 Feb 2005, 726 Bytes) of package /linux/privat/old/netbiff-0.9.18.tar.gz:


As a special service "Fossies" has tried to format the requested source page into HTML format using (guessed) Make source code syntax highlighting (style: standard) with prefixed line numbers. Alternatively you can here view or download the uninterpreted source code file.

    1 #!/usr/bin/make -f
    2 
    3 configure: configure-stamp
    4 configure-stamp:
    5     dh_testdir
    6     echo /usr >conf-home
    7     touch configure-stamp
    8 
    9 build: build-stamp
   10 build-stamp: configure-stamp
   11     dh_testdir
   12     $(MAKE)
   13     touch build-stamp
   14 
   15 clean:
   16     dh_testdir
   17     dh_testroot
   18     rm -f build-stamp configure-stamp
   19     -$(MAKE) clean
   20     dh_clean 
   21 
   22 install: build
   23     dh_testdir
   24     dh_testroot
   25     dh_clean -k 
   26     dh_installdirs
   27     $(MAKE) install DESTDIR=$(CURDIR)/debian/netbiff
   28 
   29 binary-indep:
   30 binary-arch: build install
   31     dh_testdir
   32     dh_testroot
   33     dh_installchangelogs 
   34     dh_installdocs
   35     dh_strip
   36     dh_compress
   37     dh_fixperms
   38     dh_shlibdeps
   39     dh_gencontrol
   40     dh_md5sums
   41     dh_builddeb
   42 
   43 binary: binary-indep binary-arch
   44 .PHONY: build clean binary-indep binary-arch binary install configure