"Fossies" - the Fresh Open Source Software Archive

Member "mp3info-0.8.5a/mp3info.spec" (13 Nov 2006, 2600 Bytes) of package /linux/misc/old/mp3info-0.8.5a.tgz:


As a special service "Fossies" has tried to format the requested source page into HTML format using (guessed) RPM Spec source code syntax highlighting (style: standard) with prefixed line numbers. Alternatively you can here view or download the uninterpreted source code file.

    1 %define name mp3info
    2 %define version 0.8.5a
    3 %define release 1
    4 
    5 Summary: An MP3 technical info viewer and ID3 v1.x tag editor
    6 Name: %{name}
    7 Version: %{version}
    8 Release: %{release}
    9 Packager: %{packager}
   10 Vendor: %{vendor}
   11 License: GPL
   12 Group: Utilities/file
   13 Source: ftp://ftp.ibiblio.org/pub/linux/apps/sound/mp3-utils/mp3info/%{name}-%{version}.tgz
   14 BuildRoot: /tmp/%{name}
   15 
   16 %description
   17 MP3Info is an MP3 technical info viewer and ID3 1.x tag editor.
   18 MP3Info has an interactive mode (using curses) and a command line mode.
   19 A separate executable includes a GTK-based GUI version.  MP3Info can
   20 display ID3 tag information as well as various techincal aspects of
   21 an MP3 file including playing time, bit-rate, sampling frequency
   22 and other attributes in a pre-defined or user-specifiable output format.
   23 
   24 %prep
   25 
   26 %setup -q 
   27 mkdir -p $RPM_BUILD_ROOT/usr/share/doc/%{name}-%{version}
   28 mkdir -p $RPM_BUILD_ROOT/usr/bin
   29 mkdir -p $RPM_BUILD_ROOT/usr/X11R6/bin
   30 mkdir -p $RPM_BUILD_ROOT/usr/man/man1
   31 
   32 %build
   33 make
   34 strip mp3info
   35 strip gmp3info
   36 
   37 %install
   38 mv mp3info $RPM_BUILD_ROOT/usr/bin/mp3info
   39 mv gmp3info $RPM_BUILD_ROOT/usr/X11R6/bin/gmp3info
   40 mv ChangeLog README INSTALL LICENSE mp3info.txt mp3info.html $RPM_BUILD_ROOT/usr/share/doc/%{name}-%{version}
   41 mv mp3info.1 $RPM_BUILD_ROOT/usr/man/man1
   42 
   43 %post
   44 
   45 %postun
   46 
   47 %clean
   48 rm -rf ${RPM_BUILD_ROOT}
   49 
   50 %files
   51 %defattr(-,root,root)
   52 /usr/bin/mp3info
   53 /usr/X11R6/bin/gmp3info
   54 /usr/man/man1/mp3info.1.gz
   55 %doc /usr/share/doc/%{name}-%{version}
   56 
   57 %changelog
   58 * Mon Nov 6 2006 Cedric Tefft <cedric@phreaker.net>
   59 - Added 'make install-mp3info' and 'make install-gmp3info' options to
   60   Makefile (Felix Kronlage)
   61 - Fixed a bug in the windows version that caused it to blow up or give
   62   erroneous output on certain MP3 files
   63 - Added handling of 'free form' bitrate frames, the lack of which was
   64   causing segfaults on AMD 64-bit sytems
   65 - Tweaked code to eliminate various gcc warnings and errors
   66 - Improved detection of invalid MP3 frames (Ben Bennett)
   67 - Updated gmp3info for GTK 2 (Eric Lassauge)
   68 - Miscellaneous documentation updates and corrections
   69 
   70 * Mon Jul 16 2001 Cedric Tefft <cedric@phreaker.net>
   71 - Added %k format specifier to allow printing of the file size
   72   in formatted text output (-p option)
   73 - Rearranged some items in the man page and quick help (-h)
   74   to make them more readable.
   75 - Fixed minor logic bug in mp3tech
   76 - Now compiles under CYGWIN32
   77 - Manual page typos fixed
   78 - Now correctly recognizes and reports MPEG version 2.5 files
   79 - Clearing individual ID3 fields can now be accomplished
   80   by passing a blank argument ("") to any tag setting
   81   switch (-t, -a, etc.)