"Fossies" - the Fresh Open Source Software Archive

Member "opensaf-5.21.09/NEWS" (14 Sep 2021, 2336 Bytes) of package /linux/misc/opensaf-5.21.09.tar.gz:


As a special service "Fossies" has tried to format the requested text file into HTML format (style: standard) with prefixed line numbers. Alternatively you can here view or download the uninterpreted source code file. See also the latest Fossies "Diffs" side-by-side code changes report for "NEWS": 5.21.06_vs_5.21.09.

    1 OpenSAF 5.21.09 (released 2021-09-14)
    2 -------------------------------------
    3 
    4 This is a major release containing new enhancements. Before installing or
    5 upgrading to OpenSAF 5.21.09, make sure your system meets the minimum version
    6 requirements of the following system components:
    7 
    8 - Linux kernel, version 2.6.39 or later. Recommended version is Linux 3.18 or
    9   later when using the TCP transport, and Linux 4.4.22 or later when using the
   10   TIPC transport. Linux versions older than the recommended ones contain bugs
   11   that are known to affect the proper function of OpenSAF. Use of Linux versions
   12   older than the recommended ones together with OpenSAF is strongly discouraged.
   13 - GNU C Library (Glibc), version 2.11 or later
   14 - GNU Compiler Collection (GCC), version 4.8.1 or later
   15 - Libxml2, version 2.7 or later
   16 - Python, version 2.7 or later (only needed when configuring with
   17   --enable-python)
   18 - Libopenssl, version 0.9.8 or later (optional)
   19 - Systemd, version 219 or later (optional)
   20 - Libsqlite3, version 3.6 or later (only needed when configuring with
   21   --enable-imm-pbe)
   22 - OpenHPI, version 2.17.0 or later (only needed when configuring with
   23   --enable-ais-plm)
   24 - Libvirt, version 0.9.7 or later (only needed when configuring with
   25   --enable-ais-plm)
   26 
   27 When upgrading from OpenSAF version 5.1 or older, be aware that SMF upgrade
   28 campaigns can behave differently compared to earlier OpenSAF releases in case of
   29 component failures. This is because Section 4.2.1.3 of SMF spec A.01.02 was
   30 implemented in OpenSAF 5.2.0. You can now disable this new feature in OpenSAF
   31 5.17.07 by setting the attribute osafAmfRestrictAutoRepairEnable to 0 in the AMF
   32 configuration object amfConfig=1,safApp=safAmfService.
   33 
   34 Important enhancements in this release
   35 --------------------------------------
   36 
   37 **IMM enhancements**
   38 
   39 - imm: Introduce a configurable attribute saImmSyncrTimeout [#3268]
   40 
   41 Links
   42 -----
   43 
   44 * The complete list of enhancements in the 5.21.09 release can be found in this
   45   report:
   46 
   47 https://sourceforge.net/p/opensaf/tickets/search/?q=status%3Afixed+AND+_milestone%3A5.21.09+AND+_type%3Aenhancement
   48 
   49 * The documentation for the OpenSAF 5.21.09 release can be downloaded here:
   50 
   51 http://sourceforge.net/projects/opensaf/files/docs/opensaf-documentation-5.21.09.tar.gz/download
   52 
   53 You can also check the README of the respective OpenSAF service.