"Fossies" - the Fresh Open Source Software Archive

Member "gambas-3.16.3/.gitlab-ci.yml" (7 Sep 2021, 17714 Bytes) of package /linux/misc/gambas-3.16.3.tar.bz2:


As a special service "Fossies" has tried to format the requested source page into HTML format using (guessed) Ansible YAML source code syntax highlighting (style: standard) with prefixed line numbers. Alternatively you can here view or download the uninterpreted source code file. See also the latest Fossies "Diffs" side-by-side code changes report for ".gitlab-ci.yml": 3.16.2_vs_3.16.3.

    1 build:archlinux:
    2   image: archlinux:base
    3   before_script:
    4     - >
    5        pacman -Syu --needed --noconfirm
    6        alure autoconf automake bzip2 zstd coreutils curl dbus gcc gdk-pixbuf2 git
    7        glew glib2 gmime gsl gst-plugins-base gstreamer gtk2 gtk3 gtkglext imlib2
    8        intltool libffi libgl libgnome-keyring libmariadbclient librsvg libsm
    9        libxcursor libxml2 libxslt libxtst mariadb make mesa ncurses pcre
   10     - >
   11        pacman -Syu --needed --noconfirm
   12        pkg-config poppler poppler-glib postgresql postgresql-libs qt5-svg
   13        qt5-webkit qt5-x11extras sdl2 sdl2_gfx sdl2_image sdl2_mixer sdl2_net
   14        sdl2_ttf sdl_mixer sdl_ttf smpeg sqlite unixodbc v4l-utils xdg-utils
   15        zlib gettext qt5-webengine webkit2gtk
   16   script:
   17     - ./reconf-all
   18     - GAMBAS_CONFIG_FAILURE=1 ./configure -C --disable-sqlite2 --disable-qt4
   19     - make -j$(nproc)
   20     - make install
   21 
   22 
   23 build:archlinux-clang:
   24   image: archlinux:base
   25   before_script:
   26     - >
   27        pacman -Syu --needed --noconfirm
   28        alure autoconf automake bzip2 zstd coreutils curl dbus clang gdk-pixbuf2 git
   29        glew glib2 gmime gsl gst-plugins-base gstreamer gtk2 gtk3 gtkglext imlib2
   30        intltool libffi libgl libgnome-keyring libmariadbclient librsvg libsm
   31        libxcursor libxml2 libxslt libxtst mariadb make mesa ncurses pcre
   32     - >
   33        pacman -Syu --needed --noconfirm
   34        pkg-config poppler poppler-glib postgresql postgresql-libs qt5-svg
   35        qt5-webkit qt5-x11extras sdl2 sdl2_gfx sdl2_image sdl2_mixer sdl2_net
   36        sdl2_ttf sdl_mixer sdl_ttf smpeg sqlite unixodbc v4l-utils xdg-utils
   37        zlib gettext qt5-webengine webkit2gtk
   38   script:
   39     - ./reconf-all
   40     - GAMBAS_CONFIG_FAILURE=1 ./configure CC=clang CXX=clang++ -C --disable-sqlite2 --disable-qt4
   41     - make -j$(nproc)
   42     - make install
   43 
   44 
   45 build:debian-oldstable:
   46   image: debian:oldstable
   47   before_script:
   48     - >
   49        apt-get update && apt-get install -y build-essential g++ automake 
   50        autoconf libbz2-dev libzstd-dev default-libmysqlclient-dev unixodbc-dev libpq-dev 
   51        postgresql-server-dev-11 libsqlite0-dev libsqlite3-dev libglib2.0-dev 
   52        libgtk2.0-dev libcurl4-gnutls-dev libgtkglext1-dev libpcre3-dev 
   53        libsdl-sound1.2-dev libsdl-mixer1.2-dev libsdl-image1.2-dev libxml2-dev 
   54        libxslt1-dev librsvg2-dev libpoppler-dev libpoppler-glib-dev 
   55        libpoppler-private-dev libpoppler-cpp-dev libasound2-dev libdirectfb-dev libxtst-dev 
   56        libffi-dev libqt4-dev libqtwebkit-dev libqt4-opengl-dev libglew-dev 
   57        libimlib2-dev libv4l-dev libsdl-ttf2.0-dev libgdk-pixbuf2.0-dev 
   58        linux-libc-dev libgstreamer1.0-dev libgstreamer-plugins-base1.0-dev 
   59        libcairo2-dev libgsl-dev libncurses5-dev libgmime-2.6-dev libalure-dev 
   60        libgmp-dev libgtk-3-dev libsdl2-dev libsdl2-mixer-dev libsdl2-ttf-dev 
   61        libsdl2-image-dev sane-utils libdumb1-dev libqt5opengl5-dev 
   62        libqt5svg5-dev libqt5webkit5-dev libqt5x11extras5-dev qtbase5-dev 
   63        qtwebengine5-dev libwebkit2gtk-4.0-dev git 
   64        libssl-dev
   65   script:
   66     - ./reconf-all
   67     - GAMBAS_CONFIG_FAILURE=1 ./configure -C --disable-keyring
   68     - make -j$(nproc)
   69     - make install
   70 
   71 build:debian-stable:
   72   image: debian:stable
   73   before_script:
   74     - >
   75        apt-get update && apt-get install -y build-essential g++ automake 
   76        autoconf libbz2-dev libzstd-dev default-libmysqlclient-dev unixodbc-dev libpq-dev 
   77        postgresql-server-dev-13 libsqlite3-dev libglib2.0-dev 
   78        libgtk2.0-dev libcurl4-gnutls-dev libgtkglext1-dev libpcre3-dev 
   79        libsdl-sound1.2-dev libsdl-mixer1.2-dev libsdl-image1.2-dev libxml2-dev 
   80        libxslt1-dev librsvg2-dev libpoppler-dev libpoppler-glib-dev 
   81        libpoppler-private-dev libpoppler-cpp-dev libasound2-dev libdirectfb-dev libxtst-dev 
   82        libffi-dev libglew-dev 
   83        libimlib2-dev libv4l-dev libsdl-ttf2.0-dev libgdk-pixbuf2.0-dev 
   84        linux-libc-dev libgstreamer1.0-dev libgstreamer-plugins-base1.0-dev 
   85        libcairo2-dev libgsl-dev libncurses5-dev libgmime-3.0-dev libalure-dev 
   86        libgmp-dev libgtk-3-dev libsdl2-dev libsdl2-mixer-dev libsdl2-ttf-dev 
   87        libsdl2-image-dev sane-utils libdumb1-dev libqt5opengl5-dev 
   88        libqt5svg5-dev libqt5webkit5-dev libqt5x11extras5-dev qtbase5-dev 
   89        qtwebengine5-dev libwebkit2gtk-4.0-dev git libssl-dev
   90   script:
   91     - ./reconf-all
   92     - GAMBAS_CONFIG_FAILURE=1 ./configure -C --disable-keyring --disable-sqlite2 --disable-qt4 --disable-qtwebkit
   93     - make -j$(nproc)
   94     - make install
   95 
   96 build:debian-testing:
   97   image: debian:testing
   98   before_script:
   99     - >
  100        apt-get update && apt-get install -y build-essential g++ automake 
  101        autoconf libbz2-dev libzstd-dev default-libmysqlclient-dev unixodbc-dev libpq-dev 
  102        postgresql-server-dev-13 libsqlite3-dev libglib2.0-dev 
  103        libgtk2.0-dev libcurl4-gnutls-dev libgtkglext1-dev libpcre3-dev 
  104        libsdl-sound1.2-dev libsdl-mixer1.2-dev libsdl-image1.2-dev libxml2-dev 
  105        libxslt1-dev librsvg2-dev libpoppler-dev libpoppler-glib-dev 
  106        libpoppler-private-dev libpoppler-cpp-dev libasound2-dev libdirectfb-dev libxtst-dev 
  107        libffi-dev libglew-dev 
  108        libimlib2-dev libv4l-dev libsdl-ttf2.0-dev libgdk-pixbuf2.0-dev 
  109        linux-libc-dev libgstreamer1.0-dev libgstreamer-plugins-base1.0-dev 
  110        libcairo2-dev libgsl-dev libncurses5-dev libgmime-3.0-dev libalure-dev 
  111        libgmp-dev libgtk-3-dev libsdl2-dev libsdl2-mixer-dev libsdl2-ttf-dev 
  112        libsdl2-image-dev sane-utils libdumb1-dev libqt5opengl5-dev 
  113        libqt5svg5-dev libqt5webkit5-dev libqt5x11extras5-dev qtbase5-dev 
  114        qtwebengine5-dev libwebkit2gtk-4.0-dev git libssl-dev
  115   script:
  116     - ./reconf-all
  117     - GAMBAS_CONFIG_FAILURE=1 ./configure -C --disable-keyring --disable-sqlite2 --disable-qt4 --disable-qtwebkit
  118     - make -j$(nproc)
  119     - make install
  120 
  121 
  122 build:debian-unstable:
  123   image: debian:unstable
  124   before_script:
  125     - >
  126        apt-get update && apt-get install -y build-essential g++ automake autoconf libbz2-dev libzstd-dev default-libmysqlclient-dev unixodbc-dev libpq-dev postgresql-server-dev-13 libsqlite0-dev libsqlite3-dev libglib2.0-dev libgtk2.0-dev libcurl4-gnutls-dev libgtkglext1-dev libpcre3-dev libsdl-sound1.2-dev libsdl-mixer1.2-dev libsdl-image1.2-dev libxml2-dev libxslt1-dev librsvg2-dev libpoppler-dev libpoppler-glib-dev libpoppler-private-dev libpoppler-cpp-dev libasound2-dev libdirectfb-dev libxtst-dev libffi-dev libglew-dev libimlib2-dev libv4l-dev libsdl-ttf2.0-dev libgdk-pixbuf2.0-dev linux-libc-dev libgstreamer1.0-dev libgstreamer-plugins-base1.0-dev libcairo2-dev libgsl-dev libncurses5-dev libgmime-3.0-dev libalure-dev libgmp-dev libgtk-3-dev libsdl2-dev libsdl2-mixer-dev libsdl2-ttf-dev libsdl2-image-dev sane-utils libdumb1-dev libqt5opengl5-dev libqt5svg5-dev libqt5webkit5-dev libqt5x11extras5-dev qtbase5-dev qtwebengine5-dev libwebkit2gtk-4.0-dev git libssl-dev
  127   script:
  128     - ./reconf-all
  129     - GAMBAS_CONFIG_FAILURE=1 ./configure -C --disable-keyring --disable-qt4
  130     - make -j$(nproc)
  131     - make install
  132 
  133 build:ubuntu-latest:
  134   image: ubuntu:latest
  135   before_script:
  136     - >
  137        apt-get update && DEBIAN_FRONTEND=noninteractive apt-get install -y build-essential g++ automake autoconf libtool libbz2-dev libzstd-dev libmysqlclient-dev unixodbc-dev libpq-dev postgresql-server-dev-12 libsqlite0-dev libsqlite3-dev libglib2.0-dev libgtk2.0-dev libcurl4-gnutls-dev libgtkglext1-dev libpcre3-dev libsdl-sound1.2-dev libsdl-mixer1.2-dev libsdl-image1.2-dev libxml2-dev libxslt1-dev librsvg2-dev libpoppler-dev libpoppler-private-dev libpoppler-glib-dev libpoppler-cpp-dev libasound2-dev libdirectfb-dev libxtst-dev libffi-dev libglew-dev libimlib2-dev libv4l-dev libsdl-ttf2.0-dev libgdk-pixbuf2.0-dev linux-libc-dev libgstreamer1.0-dev libgstreamer-plugins-base1.0-dev libcairo2-dev libgsl-dev libncurses5-dev libgmime-2.6-dev llvm-dev llvm libalure-dev libgmp-dev libgtk-3-dev libsdl2-dev libsdl2-mixer-dev libsdl2-ttf-dev libsdl2-image-dev sane-utils libdumb1-dev libssl-dev libqt5opengl5-dev libqt5svg5-dev libqt5webkit5-dev libqt5x11extras5-dev qtbase5-dev qtwebengine5-dev libwebkit2gtk-4.0-dev git
  138 
  139   script:
  140     - ./reconf-all
  141     - GAMBAS_CONFIG_FAILURE=1 ./configure -C --disable-keyring --disable-qt4
  142     - make -j$(nproc)
  143     - make install
  144 
  145 build:ubuntu-hirsute:
  146   image: ubuntu:hirsute
  147   before_script:
  148     - >
  149        apt-get update && DEBIAN_FRONTEND=noninteractive apt-get install -y build-essential g++ automake autoconf libtool libbz2-dev libzstd-dev libmysqlclient-dev unixodbc-dev libpq-dev postgresql-server-dev-13 libsqlite0-dev libsqlite3-dev libglib2.0-dev libgtk2.0-dev libcurl4-gnutls-dev libgtkglext1-dev libpcre3-dev libsdl-sound1.2-dev libsdl-mixer1.2-dev libsdl-image1.2-dev libxml2-dev libxslt1-dev librsvg2-dev libpoppler-dev libpoppler-private-dev libpoppler-glib-dev libpoppler-cpp-dev libasound2-dev libdirectfb-dev libxtst-dev libffi-dev libglew-dev libimlib2-dev libv4l-dev libsdl-ttf2.0-dev libgdk-pixbuf2.0-dev linux-libc-dev libgstreamer1.0-dev libgstreamer-plugins-base1.0-dev libcairo2-dev libgsl-dev libncurses5-dev libgmime-3.0-dev llvm-dev llvm libalure-dev libgmp-dev libgtk-3-dev libsdl2-dev libsdl2-mixer-dev libsdl2-ttf-dev libsdl2-image-dev sane-utils libdumb1-dev libssl-dev libqt5opengl5-dev libqt5svg5-dev libqt5webkit5-dev libqt5x11extras5-dev qtbase5-dev qtwebengine5-dev libwebkit2gtk-4.0-dev git
  150 
  151   script:
  152     - ./reconf-all
  153     - GAMBAS_CONFIG_FAILURE=1 ./configure -C --disable-keyring --disable-qt4
  154     - make -j$(nproc)
  155     - make install
  156 
  157 build:ubuntu-focal:
  158   image: ubuntu:focal
  159   before_script:
  160     - >
  161        apt-get update && DEBIAN_FRONTEND=noninteractive apt-get install -y build-essential g++ automake autoconf libtool libbz2-dev libzstd-dev libmysqlclient-dev unixodbc-dev libpq-dev postgresql-server-dev-12 libsqlite0-dev libsqlite3-dev libglib2.0-dev libgtk2.0-dev libcurl4-gnutls-dev libgtkglext1-dev libpcre3-dev libsdl-sound1.2-dev libsdl-mixer1.2-dev libsdl-image1.2-dev libxml2-dev libxslt1-dev librsvg2-dev libpoppler-dev libpoppler-private-dev libpoppler-glib-dev libpoppler-cpp-dev libasound2-dev libdirectfb-dev libxtst-dev libffi-dev libglew-dev libimlib2-dev libv4l-dev libsdl-ttf2.0-dev libgdk-pixbuf2.0-dev linux-libc-dev libgstreamer1.0-dev libgstreamer-plugins-base1.0-dev libcairo2-dev libgsl-dev libncurses5-dev libgmime-2.6-dev llvm-dev llvm libalure-dev libgmp-dev libgtk-3-dev libsdl2-dev libsdl2-mixer-dev libsdl2-ttf-dev libsdl2-image-dev sane-utils libdumb1-dev libssl-dev libqt5opengl5-dev libqt5svg5-dev libqt5webkit5-dev libqt5x11extras5-dev qtbase5-dev qtwebengine5-dev libwebkit2gtk-4.0-dev git
  162 
  163   script:
  164     - ./reconf-all
  165     - GAMBAS_CONFIG_FAILURE=1 ./configure -C --disable-keyring --disable-qt4
  166     - make -j$(nproc)
  167     - make install
  168 
  169 build:ubuntu-bionic:
  170   image: ubuntu:bionic
  171   before_script:
  172     - >
  173        apt-get update && DEBIAN_FRONTEND=noninteractive apt-get install -y build-essential g++ automake autoconf libtool libbz2-dev libzstd-dev libmysqlclient-dev unixodbc-dev libpq-dev postgresql-server-dev-10 libsqlite0-dev libsqlite3-dev libglib2.0-dev libgtk2.0-dev libcurl4-gnutls-dev libgtkglext1-dev libpcre3-dev libsdl-sound1.2-dev libsdl-mixer1.2-dev libsdl-image1.2-dev libxml2-dev libxslt1-dev librsvg2-dev libpoppler-dev libpoppler-private-dev libpoppler-glib-dev libpoppler-cpp-dev libasound2-dev libdirectfb-dev libxtst-dev libffi-dev libqt4-dev libqtwebkit-dev libqt4-opengl-dev libglew-dev libimlib2-dev libv4l-dev libsdl-ttf2.0-dev libgdk-pixbuf2.0-dev linux-libc-dev libgstreamer1.0-dev libgstreamer-plugins-base1.0-dev libcairo2-dev libgsl-dev libncurses5-dev libgmime-2.6-dev llvm-dev llvm libalure-dev libgmp-dev libgtk-3-dev libsdl2-dev libsdl2-mixer-dev libsdl2-ttf-dev libsdl2-image-dev sane-utils libdumb1-dev libssl-dev libqt5opengl5-dev libqt5svg5-dev libqt5webkit5-dev libqt5x11extras5-dev qtbase5-dev qtwebengine5-dev libwebkit2gtk-4.0-dev git
  174 
  175   script:
  176     - ./reconf-all
  177     - GAMBAS_CONFIG_FAILURE=1 ./configure -C --disable-keyring
  178     - make -j$(nproc)
  179     - make install
  180 
  181 build:ubuntu-xenial:
  182   image: ubuntu:xenial
  183   before_script:
  184     - >
  185        apt-get update && apt-get install -y build-essential g++ automake autoconf libtool libbz2-dev libmysqlclient-dev unixodbc-dev libpq-dev postgresql-server-dev-9.5 libsqlite0-dev libsqlite3-dev libglib2.0-dev libgtk2.0-dev libcurl4-gnutls-dev libgtkglext1-dev libpcre3-dev libsdl-sound1.2-dev libsdl-mixer1.2-dev libsdl-image1.2-dev libxml2-dev libxslt1-dev librsvg2-dev libpoppler-dev libpoppler-glib-dev libpoppler-private-dev libpoppler-cpp-dev libasound2-dev libdirectfb-dev libxtst-dev libffi-dev libqt4-dev libqtwebkit-dev libqt4-opengl-dev libglew-dev libimlib2-dev libv4l-dev libsdl-ttf2.0-dev libgnome-keyring-dev libgdk-pixbuf2.0-dev linux-libc-dev libgstreamer1.0-dev libgstreamer-plugins-base1.0-dev libcairo2-dev libgsl-dev libncurses5-dev libgmime-2.6-dev llvm-dev llvm libalure-dev libgmp-dev libgtk-3-dev libsdl2-dev libsdl2-mixer-dev libsdl2-ttf-dev libsdl2-image-dev sane-utils libdumb1-dev libssl-dev libqt5opengl5-dev libqt5svg5-dev libqt5webkit5-dev libqt5x11extras5-dev qtbase5-dev libwebkit2gtk-3.0-dev git
  186 
  187   script:
  188     - ./reconf-all
  189     - GAMBAS_CONFIG_FAILURE=1 ./configure -C --disable-gtk3webview --disable-qt5webview --disable-zstd
  190     - make -j$(nproc)
  191     - make install
  192 
  193 build:ubuntu-trusty:
  194   image: ubuntu:trusty
  195   before_script:
  196     - >
  197        apt-get update && apt-get install -y build-essential g++ automake autoconf libtool libbz2-dev libmysqlclient-dev unixodbc-dev libpq-dev postgresql-server-dev-9.3 libsqlite0-dev libsqlite3-dev libglib2.0-dev libgtk2.0-dev libcurl4-gnutls-dev libgtkglext1-dev libpcre3-dev libsdl-sound1.2-dev libsdl-mixer1.2-dev libsdl-image1.2-dev libxml2-dev libxslt1-dev librsvg2-dev libpoppler-dev libpoppler-glib-dev libpoppler-private-dev libpoppler-cpp-dev libasound2-dev libdirectfb-dev libxtst-dev libffi-dev libqt4-dev libqtwebkit-dev libqt4-opengl-dev libglew-dev libimlib2-dev libv4l-dev libsdl-ttf2.0-dev libgnome-keyring-dev libgdk-pixbuf2.0-dev linux-libc-dev libgstreamer1.0-dev libgstreamer-plugins-base1.0-dev libcairo2-dev libgsl0-dev libncurses5-dev libgmime-2.6-dev llvm-dev llvm libalure-dev libgmp-dev libgtk-3-dev libsdl2-dev libsdl2-mixer-dev libsdl2-ttf-dev libsdl2-image-dev sane-utils libdumb1-dev libssl-dev git libglu1-mesa-dev libglu1-mesa-dev libglew1.10 libglu1-mesa libgles2-mesa-dev libwebkit2gtk-3.0-dev
  198 
  199   script:
  200     - ./reconf-all
  201     - GAMBAS_CONFIG_FAILURE=1 ./configure -C --disable-qt5 --disable-gtk3webview --disable-gtk3opengl --disable-zstd
  202     - make -j$(nproc)
  203     - make install
  204 
  205 build:alpine:
  206   image: alpine
  207   before_script:
  208     - >
  209        apk add --no-progress -q
  210        autoconf automake libtool curl-dev dbus-dev g++ gdk-pixbuf-dev git gmp-dev
  211        glew-dev glib-dev gmime-dev gsl-dev gst-plugins-base-dev gstreamer-dev gtk+2.0-dev gtk+3.0-dev
  212        imlib2-dev gettext-dev libffi-dev mesa-dev libgnome-keyring-dev mariadb-dev librsvg-dev
  213        libsm-dev libxcursor-dev libxml2-dev libxslt-dev libxtst-dev make ncurses-dev pcre-dev pkgconf
  214        poppler-dev postgresql-dev qt5-qtsvg-dev qt5-qtwebkit-dev qt5-qtx11extras-dev qt5-qtwebengine-dev 
  215        sdl2-dev sdl2_image-dev sdl2_mixer-dev sdl2_ttf-dev sdl_mixer-dev sqlite-dev unixodbc-dev xdg-utils 
  216        zlib-dev webkit2gtk-dev
  217   script:
  218     - ./reconf-all
  219     - GAMBAS_CONFIG_FAILURE=1 ./configure -C --disable-openal --disable-qt4 --disable-sdl --disable-sqlite2 --disable-v4l --disable-gtkopengl --disable-zstd
  220     - make -j$(nproc)
  221     - make install
  222 
  223 build:fedora-latest:
  224   image: fedora:latest
  225   before_script:
  226     - >
  227        dnf install -y libtool libtool-ltdl-devel gcc make autoconf dumb-devel gmime-devel gmime30-devel libffi-devel mariadb-devel postgresql-devel unixODBC-devel sqlite2-devel libsqlite3x-devel libxslt-devel libv4l-devel glew-devel poppler-devel poppler-glib-devel poppler-cpp-devel qt-devel qt5-qtbase-devel qt5-qtbase-private-devel qt5-qtwebengine-devel qt5-qtx11extras-devel qt5-qtsvg-devel SDL_ttf-devel SDL_mixer-devel SDL-devel SDL2_ttf-devel SDL2_mixer-devel SDL2_image-devel SDL2-devel cairo-devel gtk2-devel gtk3-devel imlib2-devel librsvg2-devel qt-webkit-devel qt5-qtwebkit qt5-qtwebkit-devel openal-soft-devel libjpeg-turbo-devel gtkglext-devel gmp-devel libxml2-devel libXtst-devel gsl-devel pcre-devel dbus-devel libcurl-devel alure-devel gstreamermm-devel libgnome-keyring-devel bzip2-devel libzstd-devel postgresql-server-devel webkit2gtk3-devel ncurses-devel
  228   script:
  229     - ./reconf-all
  230     - GAMBAS_CONFIG_FAILURE=1 ./configure -C
  231     - make -j$(nproc)
  232     - make install
  233 
  234 build:opensuse-tumbleweed:
  235   image: opensuse/tumbleweed
  236   before_script:
  237     - >
  238        zypper update -y && zypper install -y libtool gcc glew-devel gmime-devel gtk2-devel gtk3-devel libQt5WebKit5-devel libqt5-qtx11extras-devel libQt5WebKit5 libQt5WebKitWidgets-devel libqt5-qtwebengine-devel libQt5Xml-devel libQt5Sql-devel libqt5-qtsvg-devel libQt5Gui-devel libQt5Core-devel libQt5Sql5-postgresql libQt5Sql5-unixODBC libQt5Sql5-mysql libQt5Sql5-sqlite webkit2gtk3-devel libICE-devel libSM-devel unixODBC-devel libzip-devel libzstd-devel libmariadb-devel gsl-devel libopenssl-devel alure-devel postgresql-devel postgresql-server-devel libcurl-devel libSDL_ttf-devel libSDL_mixer-devel libSDL-devel libSDL2_ttf-devel libSDL2_mixer-devel libSDL2_image-devel libSDL2-devel libxslt-devel libv4l-devel librsvg-devel gtkglext-devel libgnome-keyring-devel libjpeg62-devel libpoppler-devel libpoppler-glib-devel imlib2-devel gmp-devel gstreamermm-devel
  239   script:
  240     - ./reconf-all
  241     - GAMBAS_CONFIG_FAILURE=1 ./configure -C --disable-qt4 --disable-sqlite2
  242     - make -j$(nproc)
  243     - make install