"Fossies" - the Fresh Open Source Software Archive

Member "pdns-auth-4.2.0/builder-support/debian/dnsdist/ubuntu-trusty/dnsdist.postinst" (27 Aug 2019, 962 Bytes) of package /linux/misc/dns/pdns-auth-4.2.0.tar.gz:


As a special service "Fossies" has tried to format the requested source page into HTML format using (guessed) Bash source code syntax highlighting (style: standard) with prefixed line numbers. Alternatively you can here view or download the uninterpreted source code file.

    1 #! /bin/sh
    2 
    3 set -e
    4 
    5 # summary of how this script can be called:
    6 #        * <postinst> `configure' <most-recently-configured-version>
    7 #        * <old-postinst> `abort-upgrade' <new version>
    8 #        * <conflictor's-postinst> `abort-remove' `in-favour' <package>
    9 #          <new-version>
   10 #        * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
   11 #          <failed-install-package> <version> `removing'
   12 #          <conflicting-package> <version>
   13 # for details, see http://www.debian.org/doc/debian-policy/ or
   14 # the debian-policy package
   15 
   16 case "$1" in
   17   configure)
   18 
   19     adduser --force-badname --system --home /nonexistent --group \
   20         --no-create-home --quiet _dnsdist || true
   21   ;;
   22 
   23   abort-upgrade|abort-remove|abort-deconfigure)
   24   ;;
   25 
   26   *)
   27     echo "postinst called with unknown argument \`$1'" >&2
   28     exit 1
   29   ;;
   30 esac
   31 
   32 # dh_installdeb will replace this with shell code automatically
   33 # generated by other debhelper scripts.
   34 
   35 #DEBHELPER#
   36 
   37 exit 0