"Fossies" - the Fresh Open Source Software Archive

Member "apt-1.9.4/test/integration/test-ubuntu-bug-835625-multiarch-lockstep-installed-first" (19 Sep 2019, 1570 Bytes) of package /linux/misc/apt-1.9.4.tar.gz:


As a special service "Fossies" has tried to format the requested source page into HTML format using (guessed) Bash source code syntax highlighting (style: standard) with prefixed line numbers. Alternatively you can here view or download the uninterpreted source code file.

    1 #!/bin/sh
    2 set -e
    3 
    4 TESTDIR="$(readlink -f "$(dirname "$0")")"
    5 . "$TESTDIR/framework"
    6 setupenvironment
    7 configarchitecture 'amd64' 'i386'
    8 
    9 insertinstalledpackage 'libsame' 'i386' '1'
   10 insertinstalledpackage 'apt' 'i386' '1' 'Depends: libsame (= 1)'
   11 
   12 insertpackage 'unstable' 'libsame' 'i386,amd64' '2' 'Multi-Arch: same'
   13 insertpackage 'unstable' 'apt' 'i386' '2' 'Depends: libsame (= 2)'
   14 
   15 setupaptarchive
   16 
   17 testequalor2 'Reading package lists...
   18 Building dependency tree...
   19 The following additional packages will be installed:
   20   apt:i386 libsame:i386
   21 The following NEW packages will be installed:
   22   libsame
   23 The following packages will be upgraded:
   24   apt:i386 libsame:i386
   25 2 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
   26 Inst libsame:i386 [1] (2 unstable [i386]) [apt:i386 ]
   27 Inst libsame (2 unstable [amd64]) [apt:i386 ]
   28 Conf libsame:i386 (2 unstable [i386]) [apt:i386 ]
   29 Conf libsame (2 unstable [amd64]) [apt:i386 ]
   30 Inst apt:i386 [1] (2 unstable [i386])
   31 Conf apt:i386 (2 unstable [i386])' 'Reading package lists...
   32 Building dependency tree...
   33 The following additional packages will be installed:
   34   apt:i386 libsame:i386
   35 The following NEW packages will be installed:
   36   libsame
   37 The following packages will be upgraded:
   38   apt:i386 libsame:i386
   39 2 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
   40 Inst apt:i386 [1] (2 unstable [i386]) []
   41 Inst libsame:i386 [1] (2 unstable [i386])
   42 Inst libsame (2 unstable [amd64])
   43 Conf libsame:i386 (2 unstable [i386])
   44 Conf libsame (2 unstable [amd64])
   45 Conf apt:i386 (2 unstable [i386])' aptget install libsame:amd64 -s