"Fossies" - the Fresh Open Source Software Archive

Member "flutter-1.22.4/packages/flutter/pubspec.yaml" (13 Nov 2020, 2524 Bytes) of package /linux/misc/flutter-1.22.4.tar.gz:


As a special service "Fossies" has tried to format the requested source page into HTML format using (guessed) Ansible YAML source code syntax highlighting (style: standard) with prefixed line numbers. Alternatively you can here view or download the uninterpreted source code file.

    1 name: flutter
    2 author: Flutter Authors <flutter-dev@googlegroups.com>
    3 description: A framework for writing Flutter applications
    4 homepage: http://flutter.dev
    5 
    6 environment:
    7   # The pub client defaults to an <2.0.0 sdk constraint which we need to explicitly overwrite.
    8   sdk: ">=2.10.0-0.0.dev <3.0.0"
    9 
   10 dependencies:
   11   # To update these, use "flutter update-packages --force-upgrade".
   12   characters: 1.1.0-nullsafety.3
   13   collection: 1.15.0-nullsafety.3
   14   meta: 1.3.0-nullsafety.3
   15   typed_data: 1.3.0-nullsafety.3
   16   vector_math: 2.1.0-nullsafety.3
   17   sky_engine:
   18     sdk: flutter
   19 
   20 dev_dependencies:
   21   flutter_test:
   22     sdk: flutter
   23   flutter_goldens:
   24     sdk: flutter
   25   mockito: 4.1.1
   26   fake_async: 1.2.0-nullsafety.1
   27 
   28   async: 2.5.0-nullsafety.1 # THIS LINE IS AUTOGENERATED - TO UPDATE USE "flutter update-packages --force-upgrade"
   29   boolean_selector: 2.1.0-nullsafety.1 # THIS LINE IS AUTOGENERATED - TO UPDATE USE "flutter update-packages --force-upgrade"
   30   charcode: 1.2.0-nullsafety.1 # THIS LINE IS AUTOGENERATED - TO UPDATE USE "flutter update-packages --force-upgrade"
   31   clock: 1.1.0-nullsafety.1 # THIS LINE IS AUTOGENERATED - TO UPDATE USE "flutter update-packages --force-upgrade"
   32   file: 6.0.0-nullsafety.2 # THIS LINE IS AUTOGENERATED - TO UPDATE USE "flutter update-packages --force-upgrade"
   33   matcher: 0.12.10-nullsafety.1 # THIS LINE IS AUTOGENERATED - TO UPDATE USE "flutter update-packages --force-upgrade"
   34   path: 1.8.0-nullsafety.1 # THIS LINE IS AUTOGENERATED - TO UPDATE USE "flutter update-packages --force-upgrade"
   35   platform: 3.0.0-nullsafety.2 # THIS LINE IS AUTOGENERATED - TO UPDATE USE "flutter update-packages --force-upgrade"
   36   process: 4.0.0-nullsafety.2 # THIS LINE IS AUTOGENERATED - TO UPDATE USE "flutter update-packages --force-upgrade"
   37   source_span: 1.8.0-nullsafety.2 # THIS LINE IS AUTOGENERATED - TO UPDATE USE "flutter update-packages --force-upgrade"
   38   stack_trace: 1.10.0-nullsafety.1 # THIS LINE IS AUTOGENERATED - TO UPDATE USE "flutter update-packages --force-upgrade"
   39   stream_channel: 2.1.0-nullsafety.1 # THIS LINE IS AUTOGENERATED - TO UPDATE USE "flutter update-packages --force-upgrade"
   40   string_scanner: 1.1.0-nullsafety.1 # THIS LINE IS AUTOGENERATED - TO UPDATE USE "flutter update-packages --force-upgrade"
   41   term_glyph: 1.2.0-nullsafety.1 # THIS LINE IS AUTOGENERATED - TO UPDATE USE "flutter update-packages --force-upgrade"
   42   test_api: 0.2.19-nullsafety.2 # THIS LINE IS AUTOGENERATED - TO UPDATE USE "flutter update-packages --force-upgrade"
   43 
   44 # PUBSPEC CHECKSUM: 1239