"Fossies" - the Fresh Open Source Software Archive

Member "bonnie++-1.04/debian/rules" (5 Sep 2017, 1506 Bytes) of package /linux/privat/bonnie++_1.04.tgz:


As a special service "Fossies" has tried to format the requested source page into HTML format using (guessed) Make source code syntax highlighting (style: standard) with prefixed line numbers. Alternatively you can here view or download the uninterpreted source code file. See also the latest Fossies "Diffs" side-by-side code changes report for "rules": 1.03e_vs_1.04.

    1 #!/usr/bin/make -f
    2 # Sample debian/rules that uses debhelper.
    3 # GNU copyright 1997 to 1999 by Joey Hess.
    4 
    5 # Uncomment this to turn on verbose mode.
    6 #export DH_VERBOSE=1
    7 
    8 build: build-stamp
    9 build-stamp:
   10     dh_testdir
   11 
   12     
   13     # Add here commands to compile the package.
   14     ./configure --prefix=`pwd`/debian/bonnie++/usr --mandir=`pwd`/debian/bonnie++/usr/share/man
   15     $(MAKE)
   16 
   17     touch build-stamp
   18 
   19 clean:
   20     dh_testdir
   21     dh_testroot
   22     rm -f build-stamp
   23 
   24     # Add here commands to clean up after the build process.
   25     -$(MAKE) clean
   26     rm -f config.*
   27 
   28     dh_clean
   29 
   30 install: build
   31     dh_testdir
   32     dh_testroot
   33     dh_prep
   34     dh_installdirs
   35 
   36     # Add here commands to install the package into debian/bonnie++.
   37     $(MAKE) install-bin
   38     ln -s bonnie++ debian/bonnie++/usr/sbin/bonnie
   39 
   40     touch install-stamp
   41 
   42 # Build architecture-independent files here.
   43 binary-indep: build install
   44 # We have nothing to do by default.
   45 
   46 # Build architecture-dependent files here.
   47 binary-arch: build install
   48 #   dh_testversion
   49     dh_testdir
   50     dh_testroot
   51 #   dh_installdebconf   
   52     dh_installdocs
   53 #   dh_installexamples
   54 #   dh_installmenu
   55 #   dh_installemacsen
   56 #   dh_installpam
   57 #   dh_installinit
   58 #   dh_installcron
   59     dh_installman *.1 *.8
   60 #   dh_installinfo
   61 #   dh_undocumented
   62     dh_installchangelogs 
   63     dh_strip
   64     dh_compress
   65     dh_fixperms
   66     # You may want to make some executables suid here.
   67 #   dh_suidregister
   68 #   dh_makeshlibs
   69     dh_installdeb
   70 #   dh_perl
   71     dh_shlibdeps
   72     dh_gencontrol
   73     dh_md5sums
   74     dh_builddeb
   75 
   76 binary: binary-indep binary-arch
   77 .PHONY: build clean binary-indep binary-arch binary install