"Fossies" - the Fresh Open Source Software Archive

Member "Plone-5.2.5-UnifiedInstaller-1.0/helper_scripts/locales/en/LC_MESSAGES/messages.sh" (13 Sep 2021, 11940 Bytes) of package /linux/www/Plone-5.2.5-UnifiedInstaller-1.0.tgz:


As a special service "Fossies" has tried to format the requested source page into HTML format using (guessed) Bash source code syntax highlighting (style: standard) with prefixed line numbers and code folding option. Alternatively you can here view or download the uninterpreted source code file. See also the last Fossies "Diffs" side-by-side code changes report for "messages.sh": 5.2.2-UnifiedInstaller_vs_5.2.4-UnifiedInstaller-1.0.

    1 # Installer messages. Note that these are typically single-quoted and
    2 # sometimes contain variables for expansion via eval.
    3 # So, all characters meaningful to the shell will need
    4 # escaping if they're not meant to be interpreted.
    5 
    6 USAGE_MESSAGE=\
    7 '
    8 Usage: [sudo] `basename $0` [options] standalone|zeo
    9 
   10 Install methods available:
   11    standalone - install standalone zope instance
   12    zeo        - install zeo cluster
   13 
   14 Use sudo (or run as root) for server-mode install.
   15 
   16 Options (see top of install.sh for complete list):
   17 
   18 --with-python=/full/path/to/python-${WANT_PYTHON}
   19   Path to the Python-${WANT_PYTHON} that you wish to use with Plone.
   20   virtualenv will be used to isolate the install.
   21 
   22 --password=InstancePassword
   23   If not specified, a random password will be generated.
   24 
   25 --target=pathname
   26   Use to specify top-level path for installs. Plone instances
   27   and Python will be built inside this directory
   28   (default is $PLONE_HOME)
   29 
   30 --clients=client-count
   31   Use with the \"zeo\" install method to specify the number of Zope
   32   clients you wish to create. Default is 2.
   33 
   34 --instance=instance-name
   35   Use to specify the name of the operating instance to be created.
   36   This will be created inside the target directory.
   37   Default is \"zinstance\" for standalone, \"zeocluster\" for ZEO.
   38 
   39 --daemon-user=user-name
   40   In a server-mode install, sets the effective user for running the
   41   instance. Default is \"plone_daemon\". Ignored for non-server-mode installs.
   42 
   43 --owner=owner-name
   44   In a server-mode install, sets the overall owner of the installation.
   45   Default is \"buildout_user\". This is the user id that should be employed
   46   to run buildout or make src or product changes.
   47   Ignored for non-server-mode installs.
   48 
   49 --group=group-name
   50   In a server-mode install, sets the effective group for the daemon and
   51   buildout users. Default is \"plone_group\".
   52   Ignored for non-server-mode installs.
   53 
   54 --template=template-name
   55   Specifies the buildout.cfg template filename. The template file must
   56   be in the ${TEMPLATE_DIR} subdirectory. Defaults to buildout.cfg.
   57 
   58 --static-lxml
   59   Forces a static built of libxml2 and libxslt dependencies. Requires
   60   Internet access to download components.
   61 
   62 Read the top of install.sh for more install options.
   63 '
   64 
   65 BAD_USER_OPTION=\
   66 'Did you want "--daemon-user" instead of "--user"?'
   67 
   68 BAD_TEMPLATE=\
   69 'Unable to find $TEMPLATE or ${TEMPLATE}.cfg in $TEMPLATE_DIR'
   70 
   71 NO_METHOD_SELECTED=\
   72 'No method selected.
   73 Will use standalone method for convenience, but not run bin/buildout.'
   74 
   75 POLITE_GOODBYE=\
   76 '
   77 Goodbye for now'
   78 
   79 WELCOME='Welcome'
   80 
   81 DIALOG_WELCOME='
   82 Welcome to the Plone Unified Installer.
   83 
   84 This kit installs Plone from source in many Linux/BSD/OS X/Windows 10 environments.
   85 You may use the installer via command-line arguments, or by having us
   86 ask you questions about major options.
   87 
   88 For command-line options, just re-run the installer with "--help".
   89 
   90 Shall we continue?'
   91 
   92 INSTALL_TYPE_TITLE='Install Type'
   93 CHOOSE_CONFIG_MSG='Choose a basic configuration.'
   94 # note that # is the choice separator
   95 INSTALL_TYPE_CHOICES=\
   96 "Standalone (best for testing/development)#ZEO Cluster (best for production; requires load-balancer setup.)"
   97 
   98 CLIENT_CHOICES="1#2#3#4#5#6"
   99 CHOOSE_CLIENTS_TITLE="ZEO Clients"
  100 CHOOSE_CLIENTS_PROMPT=\
  101 'How many ZEO clients would you like to create\?
  102 This is easy to change later.
  103 Clients are memory/CPU-intensive.'
  104 
  105 INSTALL_DIR_TITLE="Install Directory"
  106 INSTALL_DIR_PROMPT='Installation target directory? (Leave empty for ${PLONE_HOME}): '
  107 
  108 PASSWORD_TITLE=Password
  109 PASSWORD_PROMPT="Pick an administrative password. (Leave empty for random): "
  110 
  111 Q_CONTINUE="Continue?"
  112 CONTINUE_PROMPT=\
  113 "
  114 Continue with the command line:
  115 "
  116 
  117 NO_GCC_MSG="
  118 Error: gcc is required for the install.
  119 See README.txt for dependencies."
  120 
  121 PREFLIGHT_FAILED_MSG="
  122 Unable to run preflight check. Basic build tools are missing.
  123 You may get more information about what went wrong by running
  124 sh ./preflight
  125 Aborting installation.
  126 "
  127 
  128 IGNORING_WITH_PYTHON="We already have a Python environment for this target; ignoring --with-python."
  129 
  130 CHOOSE_PYTHON_TITLE="Pick a Python"
  131 CHOOSE_PYTHON_EXPLANATION="
  132 Choose the Python executable you wish to use for building and running Plone.
  133 If you don't want one of these, cancel and use the --with-python command-line argument.
  134 "
  135 
  136 SUDO_REQUIRED_MSG="sudo utility is required to do a server-mode install."
  137 
  138 MISSING_PARTS_MSG='
  139 The install script directory must contain
  140 $PACKAGES_DIR and $HSCRIPTS_DIR subdirectories.
  141 '
  142 
  143 NEED_INSTALL_PYTHON_MSG='
  144 Please do one of the following:
  145 1) Install python${WANT_PYTHON} or python3.6+ as a system "dev" package\;
  146 2) Use --with-python=... option to point the installer to a useable python.\
  147 '
  148 
  149 NEED_INSTALL_LIBZ_MSG="
  150 
  151 Unable to find libz library and headers. These are required to build Python.
  152 Please use your system package or port manager to install libz dev.
  153 (Debian/Ubuntu zlib1g-dev)
  154 Exiting now.
  155 "
  156 
  157 NEED_INSTALL_LIBJPEG_MSG="
  158 
  159 Unable to find libjpeg library and headers. These are required to build Plone.
  160 Please use your system package or port manager to install libjpeg dev.
  161 (Debian/Ubuntu libjpeg-dev)
  162 Exiting now.
  163 "
  164 
  165 NEED_INSTALL_SSL_MSG="
  166 Unable to find libssl or openssl/ssl.h.
  167 libssl and its development headers are required for Plone.
  168 Please install your platform's openssl-dev package
  169 and try again.
  170 (If your system is using an SSL other than openssl or is
  171 putting the libraries/headers in an unconventional place,
  172 you may need to set CFLAGS/CPPFLAGS/LDFLAGS environment variables
  173 to specify the locations.)
  174 If you want to install Plone without SSL support, specify
  175 --without-ssl on the installer command line.
  176 "
  177 
  178 SORRY_OPENBSD='
  179 ***Aborting***
  180 Sorry, but the Unified Installer cannot build a Python ${WANT_PYTHON} for OpenBSD.
  181 There are too many platform-specific patches required.
  182 Please consider installing the Python ${WANT_PYTHON} port and re-run installer.
  183 '
  184 
  185 PYTHON_NOT_FOUND='Unable to find python${WANT_PYTHON} on system exec path.'
  186 
  187 WITH_PYTHON_IS_OK='$WITH_PYTHON looks OK. We will use it.'
  188 
  189 WITH_PYTHON_IS_BAD='
  190 $WITH_PYTHON does not meet the requirements for Zope/Plone.
  191 '
  192 
  193 WITH_PYTHON_NOT_EX='Error: $WITH_PYTHON is not an executable. It should be the filename of a Python binary.'
  194 
  195 TESTING_WITH_PYTHON='Testing $WITH_PYTHON for Zope/Plone requirements....'
  196 
  197 MISSING_GCC="Note: gcc is required for the install. Exiting now."
  198 
  199 MISSING_GPP="Note: g++ is required for the install. Exiting now."
  200 
  201 MISSING_MAKE="Note: make is required for the install. Exiting now."
  202 
  203 MISSING_TAR="Note: gnu tar is required for the install. Exiting now."
  204 
  205 MISSING_PATCH="Note: gnu patch program is required for the install. Exiting now."
  206 
  207 MISSING_GUNZIP="Note: gunzip is required for the install. Exiting now."
  208 
  209 MISSING_BUNZIP2="Note: bunzip2 is required for the install. Exiting now."
  210 
  211 MISSING_MINIMUM_XSLT='
  212 Plone installation requires the development versions of libxml2 and libxslt.
  213 libxml2 must be version $NEED_XML2 or greater\; libxslt must be $NEED_XSLT or greater.
  214 Ideally, you should install these as dev package libraries before running install.sh.
  215 If -- and only if -- these packages are not available for your platform, you may
  216 try adding --static-lxml=yes to your install.sh command line to force a
  217 local, static build of these libraries. This will require Internet access for the
  218 installer to download the extra source.
  219 Installation aborted.'
  220 
  221 MISSING_XSLT_DEV="Unable to find libxslt development libraries."
  222 
  223 MISSING_XML2_DEV="Unable to find libxml2 development libraries."
  224 
  225 BAD_XML2_VER='We need development version $NEED_XML2 of libxml2. Not found.'
  226 
  227 BAD_XSLT_VER='We need development version $NEED_XSLT of libxslt. Not found.'
  228 
  229 ROOT_INSTALL_CHOSEN='
  230 Root install method chosen. Will install for use by users:
  231   ZEO & Client Daemons:      $DAEMON_USER
  232   Code Resources & buildout: $BUILDOUT_USER'
  233 
  234 ROOTLESS_INSTALL_CHOSEN='Rootless install method chosen. Will install for use by system user $USER'
  235 
  236 CANNOT_WRITE_LOG='Unable to write to ${INSTALL_LOG}\; detailed log will go to stdout.'
  237 
  238 LOGGING_MSG='
  239 Detailed installation log being written to $INSTALL_LOG'
  240 
  241 SEE_LOG_EXIT_MSG='
  242 Installation has failed.
  243 See the detailed installation log at $INSTALL_LOG
  244 to determine the cause.'
  245 
  246 INSTALLING_NOW='Installing Plone ${FOR_PLONE} at $PLONE_HOME
  247 '
  248 
  249 CANNOT_CREATE_HOME='
  250 Unable to create $PLONE_HOME
  251 Please check rights and pathnames.
  252 
  253 Installation has failed.
  254 '
  255 
  256 INSTANCE_HOME_EXISTS='Instance target $INSTANCE_HOME already exists; aborting install.'
  257 
  258 CREATING_VIRTUALENV="Creating Python virtual environment."
  259 
  260 VIRTUALENV_CREATION_FAILED='
  261 Failed to create virtual environment for $WITH_PYTHON'
  262 
  263 VIRTUALENV_BAD='
  264 Python created with virtualenv no longer passes baseline tests.
  265 '
  266 
  267 DOWNLOADING_PYTHON='Downloading Python source from $PYTHON_URL'
  268 DOWNLOADING_PYTHON3='Downloading Python source from $PYTHON3_URL'
  269 
  270 PYTHON_BUILD_OK="Python build looks OK."
  271 
  272 PYTHON_BUILD_BAD='
  273 ***Aborting***
  274 The built Python does not meet the requirements for Zope/Plone.
  275 Check messages and the install.log to find out what went wrong.
  276 
  277 See the "Built Python does not meet requirements" section of
  278 README.txt for more information about this error.'
  279 
  280 INSTALLING_BUILDOUT='Installing zc.buildout in virtual environment.'
  281 
  282 INSTALLING_BUILDOUT_FAILED='Unable to install zc.buildout in virtual environment.'
  283 
  284 INSTALLING_SETUPTOOLS='Installing setuptools in virtual environment.'
  285 
  286 INSTALLING_SETUPTOOLS_FAILED='Unable to install setuptools in virtual environment.'
  287 
  288 INSTALLING_REQUIREMENTS='Installing Python requirements in virtual environment.'
  289 
  290 INSTALLING_REQUIREMENTS_FAILED='Unable to install Python requirements in virtual environment.'
  291 
  292 FOUND_BUILDOUT_CACHE='Found existing buildout cache at $BUILDOUT_CACHE\; skipping step.'
  293 
  294 UNPACKING_BUILDOUT_CACHE='Unpacking buildout cache to $BUILDOUT_CACHE'
  295 
  296 BUILDOUT_CACHE_UNPACK_FAILED="Buildout cache unpack failed. Unable to continue."
  297 
  298 BUILDOUT_FAILED="Buildout failed. Unable to continue"
  299 
  300 BUILDOUT_SUCCESS="Buildout completed"
  301 
  302 INSTALL_COMPLETE='
  303 ######################  Installation Complete  ######################
  304 
  305 Plone successfully installed at $PLONE_HOME
  306 See $RMFILE
  307 for startup instructions.
  308 '
  309 
  310 BUILDOUT_SKIPPED_OK='
  311 Buildout was skipped at your request, but the installation is
  312 otherwise complete and may be found at $PLONE_HOME
  313 '
  314 
  315 NEED_HELP_MSG='
  316 
  317 
  318 - If you need help, ask in our forum https://community.plone.org
  319 - Live chat channels also exists at http://plone.org/support/chat
  320 
  321 - Submit feedback and report errors at https://github.com/plone/Products.CMFPlone/issues
  322 (For install problems, https://github.com/plone/Installers-UnifiedInstaller/issues)
  323 '
  324 
  325 REPORT_ERRORS_MSG='
  326 There were errors during the install.  Please read readme.txt and try again.
  327 To report errors with the installer, visit https://github.com/plone/Installers-UnifiedInstaller/issues
  328 '
  329 
  330 # build_python.sh
  331 
  332 INSTALLING_PYTHON='Installing ${PYTHON_DIR}. This takes a while...'
  333 INSTALLING_PYTHON3='Installing ${PYTHON3_DIR}. This takes a while...'
  334 
  335 UNABLE_TO_CONFIGURE_PY="Unable to configure Python build."
  336 
  337 PY_BUILD_FAILED="Python build has failed."
  338 
  339 INSTALL_PY_FAILED='Install of ${PYTHON_DIR} has failed.'
  340 INSTALL_PY3_FAILED='Install of ${PYTHON3_DIR} has failed.'
  341 
  342 # user_group_utilities.sh
  343 
  344 USING_USERADD="Using useradd and groupadd to create users and groups."
  345 
  346 GROUP_EXISTS='"$TARGET_GROUP" already exists; no need to create it.'
  347 
  348 GROUP_FAILED='Creation of "$TARGET_GROUP" failed. Unable to continue.'
  349 
  350 USER_EXISTS='User "$TARGET_USER" already exists. No need to create it.'
  351 
  352 ADD_USER_TO_GROUP='Adding user $TARGET_USER to group $TARGET_GROUP.'
  353 
  354 USING_PW="Using pw to create users and groups"
  355 
  356 UNKNOWN_USER_ENV='We do not know how to add users and groups in this environment.
  357 This is no problem if the required users and group already exist.
  358 '
  359 
  360 UG_CREATE_FAILED='Expected to find uid for $TARGET_USER and gid for $TARGET_GROUP but did not.
  361 Please use your system tools to create/edit required users and group, then try again.'