"Fossies" - the Fresh Open Source Software Archive

Member "Plone-5.2.5-UnifiedInstaller-1.0/docs/dependencies.rst" (13 Sep 2021, 1741 Bytes) of package /linux/www/Plone-5.2.5-UnifiedInstaller-1.0.tgz:


As a special service "Fossies" has tried to format the requested source page into HTML format (assuming markdown format). Alternatively you can here view or download the uninterpreted source code file. A member file download can also be achieved by clicking within a package contents listing on the according byte size field. See also the latest Fossies "Diffs" side-by-side code changes report for "dependencies.rst": 5.2.4-UnifiedInstaller-1.0_vs_5.2.5-UnifiedInstaller-1.0.

Dependencies

Most of these are included with system "build" kits.

Libraries Required

Install libraries prior to running installer. Development versions of some packages are required for headers. Debian/Ubuntu package names are included below. RPM equivalents follow in a separate subsection.

Linux

Please ensure to have these packages installed.

Debian/Ubuntu:

RPM:

SuSE Linux

sudo zypper install gcc-c++ patch openssl-devel libjpeg-devel libxslt-devel readline-devel make which python3-devel bzip2

Other Linux distributions may have slightly different names.

LibXML2/LibXSLT versions

Many older systems have inadequate libxslt/libxml libraries. There is no point in installing old libraries. Plone requires libxml2 >= 2.7.8 and libxslt 1.1.26. In this case, use the --static-lxml option to get the installer to build and statically link these libraries.

OS X (El Capitan)

The XCode command-line tools provides everything except libjpeg. Install that via MacPorts or Homebrew.

Optional

Mainly used to support indexing of office-automation documents.