"Fossies" - the Fresh Open Source Software Archive  

Source code changes of the file "tests/framework/console/ControllerTest.php" between
yii2-2.0.36.tar.gz and yii2-2.0.37.tar.gz

About: Yii 2 is a high-performance component-based PHP framework for developing large-scale Web applications (source).

ControllerTest.php  (yii2-2.0.36):ControllerTest.php  (yii2-2.0.37)
skipping to change at line 80 skipping to change at line 80
$params = ['_aliases' => ['ta' => 'from params,notdefault']]; $params = ['_aliases' => ['ta' => 'from params,notdefault']];
list($fromParam, $other) = $controller->runAction('aksi6', $params); list($fromParam, $other) = $controller->runAction('aksi6', $params);
$this->assertEquals('from params', $fromParam); $this->assertEquals('from params', $fromParam);
$this->assertEquals('notdefault', $other); $this->assertEquals('notdefault', $other);
$params = ['test-array' => 'from params,notdefault']; $params = ['test-array' => 'from params,notdefault'];
list($fromParam, $other) = $controller->runAction('aksi6', $params); list($fromParam, $other) = $controller->runAction('aksi6', $params);
$this->assertEquals('from params', $fromParam); $this->assertEquals('from params', $fromParam);
$this->assertEquals('notdefault', $other); $this->assertEquals('notdefault', $other);
$params = ['from params', 'notdefault'];
list($fromParam, $other) = $controller->run('trimargs', $params);
$this->assertEquals('from params', $fromParam);
$this->assertEquals('notdefault', $other);
$params = ['avaliable']; $params = ['avaliable'];
$message = Yii::t('yii', 'Missing required arguments: {params}', ['param s' => implode(', ', ['missing'])]); $message = Yii::t('yii', 'Missing required arguments: {params}', ['param s' => implode(', ', ['missing'])]);
$this->expectException('yii\console\Exception'); $this->expectException('yii\console\Exception');
$this->expectExceptionMessage($message); $this->expectExceptionMessage($message);
$result = $controller->runAction('aksi3', $params); $result = $controller->runAction('aksi3', $params);
} }
public function testNullableInjectedActionParams() public function testNullableInjectedActionParams()
{ {
if (PHP_VERSION_ID < 70100) { if (PHP_VERSION_ID < 70100) {
$this->markTestSkipped('Can not be tested on PHP < 7.1'); $this->markTestSkipped('Can not be tested on PHP < 7.1');
return; return;
} }
// Use the PHP71 controller for this test // Use the PHP71 controller for this test
 End of changes. 2 change blocks. 
0 lines changed or deleted 6 lines changed or added

Home  |  About  |  Features  |  All  |  Newest  |  Dox  |  Diffs  |  RSS Feeds  |  Screenshots  |  Comments  |  Imprint  |  Privacy  |  HTTP(S)