"Fossies" - the Fresh Open Source Software Archive  

Source code changes of the file "UPGRADE" between
yii-1.1.18.018a89.tar.gz and yii-1.1.19.5790cb.tar.gz

About: Yii is a high-performance component-based PHP framework for developing large-scale Web applications.

UPGRADE  (yii-1.1.18.018a89):UPGRADE  (yii-1.1.19.5790cb)
Upgrading Instructions for Yii Framework v1.1.18 Upgrading Instructions for Yii Framework v1.1.19
================================================ ================================================
!!!IMPORTANT!!! !!!IMPORTANT!!!
The following upgrading instructions are cumulative. That is, The following upgrading instructions are cumulative. That is,
if you want to upgrade from version A to version C and there is if you want to upgrade from version A to version C and there is
version B between A and C, you need to following the instructions version B between A and C, you need to following the instructions
for both A and B. for both A and B.
General upgrade instructions General upgrade instructions
---------------------------- ----------------------------
- Make a backup. - Make a backup.
- Clean up your 'assets' folder. - Clean up your 'assets' folder.
- Replace 'framework' dir with the new one or point GIT to a fresh - Replace 'framework' dir with the new one or point GIT to a fresh
release and update. release and update.
- Check if everything is OK, if not — revert from backup and post - Check if everything is OK, if not — revert from backup and post
issues to Yii issue tracker. issues to Yii issue tracker.
Upgrading from v1.1.18
----------------------
If you are outputting validation errors directly without using `CHtml` or `CActi
veForm`, make sure
to encode them properly depending on context you are outputting them into.
Upgrading from v1.1.17 Upgrading from v1.1.17
---------------------- ----------------------
No significant changes were made. No significant changes were made.
Upgrading from v1.1.16 Upgrading from v1.1.16
---------------------- ----------------------
- If you're using CApcCache with APCu, set `useApcu` to `true` in the component config. - If you're using CApcCache with APCu, set `useApcu` to `true` in the component config.
- Undocumented usage of regular expressions outside parameters in URL rules was considered a bug (#3348). Regular - Undocumented usage of regular expressions outside parameters in URL rules was considered a bug (#3348). Regular
 End of changes. 2 change blocks. 
1 lines changed or deleted 8 lines changed or added

Home  |  About  |  Features  |  All  |  Newest  |  Dox  |  Diffs  |  RSS Feeds  |  Screenshots  |  Comments  |  Imprint  |  Privacy  |  HTTP(S)