"Fossies" - the Fresh Open Source Software Archive  

Source code changes of the file "configure.ac" between
xorg-server-1.20.7.tar.bz2 and xorg-server-1.20.8.tar.bz2

About: The X.Org X Server component of the X Window System architecture.

configure.ac  (xorg-server-1.20.7.tar.bz2):configure.ac  (xorg-server-1.20.8.tar.bz2)
skipping to change at line 29 skipping to change at line 29
dnl FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER dnl FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
dnl DEALINGS IN THE SOFTWARE. dnl DEALINGS IN THE SOFTWARE.
dnl dnl
dnl Authors: Keith Packard <keithp@keithp.com> dnl Authors: Keith Packard <keithp@keithp.com>
dnl Daniel Stone <daniel@fooishbar.org> dnl Daniel Stone <daniel@fooishbar.org>
dnl an unwitting cast of miscellaneous others dnl an unwitting cast of miscellaneous others
dnl dnl
dnl Process this file with autoconf to create configure. dnl Process this file with autoconf to create configure.
AC_PREREQ(2.60) AC_PREREQ(2.60)
AC_INIT([xorg-server], 1.20.7, [https://gitlab.freedesktop.org/xorg/xserver/issu AC_INIT([xorg-server], 1.20.8, [https://gitlab.freedesktop.org/xorg/xserver/issu
es], xorg-server) es], xorg-server)
RELEASE_DATE="2020-01-13" RELEASE_DATE="2020-03-29"
RELEASE_NAME="Stuffed French Toast" RELEASE_NAME="Chicken Parmigiana"
AC_CONFIG_SRCDIR([Makefile.am]) AC_CONFIG_SRCDIR([Makefile.am])
AC_CONFIG_MACRO_DIR([m4]) AC_CONFIG_MACRO_DIR([m4])
AM_INIT_AUTOMAKE([foreign dist-bzip2]) AM_INIT_AUTOMAKE([foreign dist-bzip2])
AC_USE_SYSTEM_EXTENSIONS AC_USE_SYSTEM_EXTENSIONS
# Require xorg-macros minimum of 1.14 for XORG_COMPILER_BRAND in XORG_DEFAULT_OP TIONS # Require xorg-macros minimum of 1.14 for XORG_COMPILER_BRAND in XORG_DEFAULT_OP TIONS
m4_ifndef([XORG_MACROS_VERSION], m4_ifndef([XORG_MACROS_VERSION],
[m4_fatal([must install xorg-macros 1.14 or later before running autoc onf/autogen])]) [m4_fatal([must install xorg-macros 1.14 or later before running autoc onf/autogen])])
XORG_MACROS_VERSION(1.14) XORG_MACROS_VERSION(1.14)
XORG_DEFAULT_OPTIONS XORG_DEFAULT_OPTIONS
skipping to change at line 2051 skipping to change at line 2051
AM_CONDITIONAL([GLAMOR], [test "x$GLAMOR" = xyes]) AM_CONDITIONAL([GLAMOR], [test "x$GLAMOR" = xyes])
if test "x$GLAMOR" = xyes; then if test "x$GLAMOR" = xyes; then
AC_DEFINE(GLAMOR, 1, [Build glamor]) AC_DEFINE(GLAMOR, 1, [Build glamor])
PKG_CHECK_MODULES([GLAMOR], [epoxy]) PKG_CHECK_MODULES([GLAMOR], [epoxy])
PKG_CHECK_EXISTS(epoxy >= 1.4.4, PKG_CHECK_EXISTS(epoxy >= 1.4.4,
[AC_DEFINE(GLAMOR_HAS_EGL_QUERY_DMABUF, 1, [Have GLAMOR_ HAS_EGL_QUERY_DMABUF])], [AC_DEFINE(GLAMOR_HAS_EGL_QUERY_DMABUF, 1, [Have GLAMOR_ HAS_EGL_QUERY_DMABUF])],
[]) [])
PKG_CHECK_EXISTS(epoxy >= 1.5.4,
[AC_DEFINE(GLAMOR_HAS_EGL_QUERY_DRIVER, 1, [Have GLAMOR_
HAS_EGL_QUERY_DRIVER])],
[])
PKG_CHECK_MODULES(GBM, "$LIBGBM", [GBM=yes], [GBM=no]) PKG_CHECK_MODULES(GBM, "$LIBGBM", [GBM=yes], [GBM=no])
if test "x$GBM" = xyes; then if test "x$GBM" = xyes; then
AC_DEFINE(GLAMOR_HAS_GBM, 1, AC_DEFINE(GLAMOR_HAS_GBM, 1,
[Build glamor with GBM-based EGL support]) [Build glamor with GBM-based EGL support])
AC_CHECK_DECL(GBM_BO_USE_LINEAR, AC_CHECK_DECL(GBM_BO_USE_LINEAR,
[AC_DEFINE(GLAMOR_HAS_GBM_LINEAR, 1, [Have GBM_BO_USE_LIN EAR])], [], [AC_DEFINE(GLAMOR_HAS_GBM_LINEAR, 1, [Have GBM_BO_USE_LIN EAR])], [],
[#include <stdlib.h> [#include <stdlib.h>
#include <gbm.h>]) #include <gbm.h>])
dnl 17.1.0 is required for gbm_bo_create_with_modifiers dnl 17.1.0 is required for gbm_bo_create_with_modifiers
PKG_CHECK_EXISTS(gbm >= 17.1.0, PKG_CHECK_EXISTS(gbm >= 17.1.0,
 End of changes. 2 change blocks. 
4 lines changed or deleted 9 lines changed or added

Home  |  About  |  Features  |  All  |  Newest  |  Dox  |  Diffs  |  RSS Feeds  |  Screenshots  |  Comments  |  Imprint  |  Privacy  |  HTTP(S)