"Fossies" - the Fresh Open Source Software Archive  

Source code changes of the file "configure.ac" between
wayland-1.17.0.tar.xz and wayland-1.18.0.tar.xz

About: Wayland is a computer display server protocol for a compositor to talk to its clients and a library for Linux implementing that protocol.

configure.ac  (wayland-1.17.0.tar.xz):configure.ac  (wayland-1.18.0.tar.xz)
AC_PREREQ([2.64]) AC_PREREQ([2.64])
m4_define([wayland_major_version], [1]) m4_define([wayland_major_version], [1])
m4_define([wayland_minor_version], [17]) m4_define([wayland_minor_version], [18])
m4_define([wayland_micro_version], [0]) m4_define([wayland_micro_version], [0])
m4_define([wayland_version], m4_define([wayland_version],
[wayland_major_version.wayland_minor_version.wayland_micro_version]) [wayland_major_version.wayland_minor_version.wayland_micro_version])
AC_INIT([wayland], AC_INIT([wayland],
[wayland_version], [wayland_version],
[https://gitlab.freedesktop.org/wayland/wayland/issues/], [https://gitlab.freedesktop.org/wayland/wayland/issues/],
[wayland], [wayland],
[https://wayland.freedesktop.org/]) [https://wayland.freedesktop.org/])
AC_SUBST([WAYLAND_VERSION_MAJOR], [wayland_major_version]) AC_SUBST([WAYLAND_VERSION_MAJOR], [wayland_major_version])
skipping to change at line 66 skipping to change at line 66
AS_IF([test x"$enable_fatal_warnings" != "xno"], [ AS_IF([test x"$enable_fatal_warnings" != "xno"], [
WERROR_CFLAGS="-Werror" WERROR_CFLAGS="-Werror"
]) ])
if test "x$GCC" = "xyes"; then if test "x$GCC" = "xyes"; then
GCC_CFLAGS="$WERROR_CFLAGS -Wall -Wextra -Wno-unused-parameter -g -Wstric t-prototypes -Wmissing-prototypes -fvisibility=hidden" GCC_CFLAGS="$WERROR_CFLAGS -Wall -Wextra -Wno-unused-parameter -g -Wstric t-prototypes -Wmissing-prototypes -fvisibility=hidden"
fi fi
AC_SUBST(GCC_CFLAGS) AC_SUBST(GCC_CFLAGS)
AC_CHECK_HEADERS([sys/prctl.h]) AC_CHECK_HEADERS([sys/prctl.h])
AC_CHECK_FUNCS([accept4 mkostemp posix_fallocate prctl]) AC_CHECK_FUNCS([accept4 mkostemp posix_fallocate prctl memfd_create strndup])
# *BSD don't have libdl, but they have its functions in libc
WESTON_SEARCH_LIBS([DL], [dl], [dlsym])
# OpenBSD doesn't have librt, but it has its functions in libc
WESTON_SEARCH_LIBS([RT], [rt], [clock_gettime])
AC_ARG_ENABLE([libraries], AC_ARG_ENABLE([libraries],
[AC_HELP_STRING([--disable-libraries], [AC_HELP_STRING([--disable-libraries],
[Disable compilation of wayland libraries])], [Disable compilation of wayland libraries])],
[], [],
[enable_libraries=yes]) [enable_libraries=yes])
AC_ARG_WITH([host-scanner], AC_ARG_WITH([host-scanner],
[AC_HELP_STRING([--with-host-scanner], [AC_HELP_STRING([--with-host-scanner],
[Use installed wayland-scanner from host PATH duri ng build])], [Use installed wayland-scanner from host PATH duri ng build])],
skipping to change at line 126 skipping to change at line 132
AM_CONDITIONAL([DTD_VALIDATION], [test "x$enable_dtd_validation" = "xyes"]) AM_CONDITIONAL([DTD_VALIDATION], [test "x$enable_dtd_validation" = "xyes"])
if test "x$enable_dtd_validation" = "xyes"; then if test "x$enable_dtd_validation" = "xyes"; then
PKG_CHECK_MODULES(LIBXML, [libxml-2.0]) PKG_CHECK_MODULES(LIBXML, [libxml-2.0])
AC_DEFINE(HAVE_LIBXML, 1, [libxml-2.0 is available]) AC_DEFINE(HAVE_LIBXML, 1, [libxml-2.0 is available])
AC_CONFIG_LINKS([src/wayland.dtd.embed:protocol/wayland.dtd]) AC_CONFIG_LINKS([src/wayland.dtd.embed:protocol/wayland.dtd])
fi fi
AC_PATH_PROG(XSLTPROC, xsltproc) AC_PATH_PROG(XSLTPROC, xsltproc)
AM_CONDITIONAL([HAVE_XSLTPROC], [test "x$XSLTPROC" != "x"]) AM_CONDITIONAL([HAVE_XSLTPROC], [test "x$XSLTPROC" != "x"])
AC_MSG_CHECKING([for docbook manpages stylesheet])
MANPAGES_STYLESHEET=http://docbook.sourceforge.net/release/xsl/current/manpages/
docbook.xsl
AC_PATH_PROGS_FEATURE_CHECK([XSLTPROC_TMP], [xsltproc],
AS_IF([`"$ac_path_XSLTPROC_TMP" --nonet "$MANPAGES_ST
YLESHEET" > /dev/null 2>&1`],
[HAVE_MANPAGES_STYLESHEET=yes]))
if test "x$HAVE_MANPAGES_STYLESHEET" = "xyes"; then
AM_CONDITIONAL([HAVE_MANPAGES_STYLESHEET], true)
AC_SUBST(MANPAGES_STYLESHEET)
AC_MSG_RESULT([yes])
else
AM_CONDITIONAL([HAVE_MANPAGES_STYLESHEET], false)
AC_MSG_RESULT([no])
fi
AM_CONDITIONAL(BUILD_DOCS, [test x$enable_documentation = xyes]) AM_CONDITIONAL(BUILD_DOCS, [test x$enable_documentation = xyes])
if test "x$enable_documentation" = "xyes"; then if test "x$enable_documentation" = "xyes"; then
AC_PATH_PROG(DOXYGEN, doxygen) AC_PATH_PROG(DOXYGEN, doxygen)
if test "x$DOXYGEN" = "x"; then if test "x$DOXYGEN" = "x"; then
AC_MSG_ERROR([Documentation build requested but doxygen not found . Install doxygen or disable the documentation using --disable-documentation]) AC_MSG_ERROR([Documentation build requested but doxygen not found . Install doxygen or disable the documentation using --disable-documentation])
fi fi
AC_MSG_CHECKING([for compatible doxygen version]) AC_MSG_CHECKING([for compatible doxygen version])
doxygen_version=`$DOXYGEN --version` doxygen_version=`$DOXYGEN --version`
skipping to change at line 174 skipping to change at line 166
AC_MSG_ERROR([Documentation build requested but graphviz's dot no t found. Install graphviz or disable the documentation using --disable-documenta tion]) AC_MSG_ERROR([Documentation build requested but graphviz's dot no t found. Install graphviz or disable the documentation using --disable-documenta tion])
fi fi
AC_MSG_CHECKING([for compatible dot version]) AC_MSG_CHECKING([for compatible dot version])
dot_version=`$DOT -V 2>&1|$GREP -o ['[0-9]*\.[0-9]*\.[0-9]*']` dot_version=`$DOT -V 2>&1|$GREP -o ['[0-9]*\.[0-9]*\.[0-9]*']`
AS_VERSION_COMPARE([$dot_version], [2.26.0], AS_VERSION_COMPARE([$dot_version], [2.26.0],
[AC_MSG_RESULT([no]) [AC_MSG_RESULT([no])
AC_MSG_ERROR([Graphviz dot $dot_version too old. Grap hviz 2.26+ required for documentation build. Install required graphviz version o r disable the documentation using --disable-documentation])], AC_MSG_ERROR([Graphviz dot $dot_version too old. Grap hviz 2.26+ required for documentation build. Install required graphviz version o r disable the documentation using --disable-documentation])],
[AC_MSG_RESULT([yes])], [AC_MSG_RESULT([yes])],
[AC_MSG_RESULT([yes])]) [AC_MSG_RESULT([yes])])
AC_MSG_CHECKING([for docbook stylesheets])
DOCS_STYLESHEET=http://docbook.sourceforge.net/release/xsl/current/manpag
es/docbook.xsl
AC_PATH_PROGS_FEATURE_CHECK([XSLTPROC_TMP], [xsltproc],
AS_IF([`"$ac_path_XSLTPROC_TMP" --nonet "$DOC
S_STYLESHEET" > /dev/null 2>&1`],
[HAVE_DOCS_STYLESHEET=yes]))
if test "x$HAVE_DOCS_STYLESHEET" != "xyes"; then
AC_MSG_RESULT([no])
AC_MSG_ERROR([Documentation build requested but docbook-xsl style
sheets are not found. Install the docbook-xsl package or disable the documentati
on using --disable-documentation])
fi
AC_MSG_RESULT([yes])
AC_SUBST(DOCS_STYLESHEET)
AC_CONFIG_FILES([ AC_CONFIG_FILES([
doc/doxygen/wayland.doxygen doc/doxygen/wayland.doxygen
]) ])
fi fi
AM_CONDITIONAL([HAVE_XMLTO], [test "x$XMLTO" != "x"]) AM_CONDITIONAL([HAVE_XMLTO], [test "x$XMLTO" != "x"])
AC_CONFIG_FILES([Makefile AC_CONFIG_FILES([Makefile
cursor/wayland-cursor.pc cursor/wayland-cursor.pc
cursor/wayland-cursor-uninstalled.pc cursor/wayland-cursor-uninstalled.pc
 End of changes. 4 change blocks. 
19 lines changed or deleted 26 lines changed or added

Home  |  About  |  Features  |  All  |  Newest  |  Dox  |  Diffs  |  RSS Feeds  |  Screenshots  |  Comments  |  Imprint  |  Privacy  |  HTTP(S)