"Fossies" - the Fresh Open Source Software Archive  

Source code changes of the file "setup.py" between
versions-1.5.4.tar.gz and versions-1.5.5.tar.gz

About: versions checks releases and versions of your favorite programs (on the main repositories) through RSS or Atom feeds.

setup.py  (versions-1.5.4):setup.py  (versions-1.5.5)
skipping to change at line 42 skipping to change at line 42
# specification here: # specification here:
# https://packaging.python.org/specifications/core-metadata/#name # https://packaging.python.org/specifications/core-metadata/#name
name='program_versions', # Required name='program_versions', # Required
# Versions should comply with PEP 440: # Versions should comply with PEP 440:
# https://www.python.org/dev/peps/pep-0440/ # https://www.python.org/dev/peps/pep-0440/
# #
# For a discussion on single-sourcing the version across setup.py and the # For a discussion on single-sourcing the version across setup.py and the
# project code, see # project code, see
# https://packaging.python.org/en/latest/single_source_version.html # https://packaging.python.org/en/latest/single_source_version.html
version='1.5.4', # Required version='1.5.5', # Required
# This is a one-line description or tagline of what your project does. This # This is a one-line description or tagline of what your project does. This
# corresponds to the "Summary" metadata field: # corresponds to the "Summary" metadata field:
# https://packaging.python.org/specifications/core-metadata/#summary # https://packaging.python.org/specifications/core-metadata/#summary
description='Know version changes of your favourites projects in your termin al.', # Required description='Know version changes of your favourites projects in your termin al.', # Required
# This is an optional longer description of your project that represents # This is an optional longer description of your project that represents
# the body of text which users will see when they visit PyPI. # the body of text which users will see when they visit PyPI.
# #
# Often, this is the same as your README, so you can just read it in from # Often, this is the same as your README, so you can just read it in from
skipping to change at line 120 skipping to change at line 120
# Note that this is a string of words separated by whitespace, not a list. # Note that this is a string of words separated by whitespace, not a list.
keywords='version-checker version follower rss atom command-line', # Option al keywords='version-checker version follower rss atom command-line', # Option al
# You can just specify package directories manually here if your project is # You can just specify package directories manually here if your project is
# simple. Or you can use find_packages(). # simple. Or you can use find_packages().
# #
# Alternatively, if you just want to distribute a single Python file, use # Alternatively, if you just want to distribute a single Python file, use
# the `py_modules` argument instead as follows, which will expect a file # the `py_modules` argument instead as follows, which will expect a file
# called `my_module.py` to exist: # called `my_module.py` to exist:
# #
#py_modules=['versions', 'configuration', 'common', 'bylist', 'byproject', ' caches'], # py_modules=['versions', 'configuration', 'common', 'bylist', 'byproject', 'caches'],
packages=setuptools.find_packages(exclude=['tests']), # Required packages=setuptools.find_packages(exclude=['tests']), # Required
# This field lists other packages that your project depends on to run. # This field lists other packages that your project depends on to run.
# Any package you put here will be installed by pip when your project is # Any package you put here will be installed by pip when your project is
# installed, so they must be valid existing projects. # installed, so they must be valid existing projects.
# #
# For an analysis of "install_requires" vs pip's requirements files see: # For an analysis of "install_requires" vs pip's requirements files see:
# https://packaging.python.org/en/latest/requirements.html # https://packaging.python.org/en/latest/requirements.html
install_requires=['feedparser>=5.1.3', 'PyYAML>=3.11'], # Optional install_requires=['feedparser>=5.1.3', 'PyYAML>=3.11'], # Optional
# List additional groups of dependencies here (e.g. development # List additional groups of dependencies here (e.g. development
 End of changes. 3 change blocks. 
3 lines changed or deleted 3 lines changed or added

Home  |  About  |  Features  |  All  |  Newest  |  Dox  |  Diffs  |  RSS Feeds  |  Screenshots  |  Comments  |  Imprint  |  Privacy  |  HTTP(S)