"Fossies" - the Fresh Open Source Software Archive  

Source code changes of the file "src/external/samba.m4" between
sssd-2.4.1.tar.gz and sssd-2.4.2.tar.gz

About: SSSD is a system daemon to manage identity, authentication and authorization for centrally-managed systems. It provides several interfaces, including NSS and PAM modules or a D-Bus interface.

samba.m4  (sssd-2.4.1):samba.m4  (sssd-2.4.2)
skipping to change at line 33 skipping to change at line 33
]])) ]]))
PKG_CHECK_MODULES(SMBCLIENT, smbclient, , PKG_CHECK_MODULES(SMBCLIENT, smbclient, ,
AC_MSG_ERROR([[Please install libsmbclient development libraries. AC_MSG_ERROR([[Please install libsmbclient development libraries.
libsmbclient libraries are necessary for building ad and ipa provider. libsmbclient libraries are necessary for building ad and ipa provider.
If you do not want to build these providers it is possible to build SSSD If you do not want to build these providers it is possible to build SSSD
without them. In this case, you will need to execute configure script without them. In this case, you will need to execute configure script
with argument --without-samba with argument --without-samba
]])) ]]))
PKG_CHECK_MODULES(SAMBA_UTIL, samba-util, ,
AC_MSG_ERROR([[Please install libsamba-util development libraries.
libsamba-util libraries are necessary for building ad and ipa provider.
If you do not want to build these providers it is possible to build SSSD
without them. In this case, you will need to execute configure script
with argument --without-samba
]]))
if test x"$HAVE_LIBINI_CONFIG_V1_1" != x1; then if test x"$HAVE_LIBINI_CONFIG_V1_1" != x1; then
AC_MSG_ERROR([[Please install libini_config development libraries AC_MSG_ERROR([[Please install libini_config development libraries
v1.1.0, or newer. libini_config libraries are necessary for building ipa v1.1.0, or newer. libini_config libraries are necessary for building ipa
provider, as well as for building gpo-based access control in ad provider. If provider, as well as for building gpo-based access control in ad provider. If
you do not want to build these providers it is possible to build SSSD without you do not want to build these providers it is possible to build SSSD without
them. In this case, you will need to execute configure script with argument them. In this case, you will need to execute configure script with argument
--without-samba --without-samba
]]) ]])
fi fi
 End of changes. 1 change blocks. 
0 lines changed or deleted 8 lines changed or added

Home  |  About  |  Features  |  All  |  Newest  |  Dox  |  Diffs  |  RSS Feeds  |  Screenshots  |  Comments  |  Imprint  |  Privacy  |  HTTP(S)