"Fossies" - the Fresh Open Source Software Archive  

Source code changes of the file "configure.ac" between
sqwebmail-5.9.3.tar.bz2 and sqwebmail-6.0.0.tar.bz2

About: SqWebMail is a CGI Webmail client for Maildir mailboxes (module of the Courier mail server).

configure.ac  (sqwebmail-5.9.3.tar.bz2):configure.ac  (sqwebmail-6.0.0.tar.bz2)
dnl dnl
dnl Copyright 1998 - 2013 Double Precision, Inc. See COPYING for dnl Copyright 1998 - 2013 Double Precision, Inc. See COPYING for
dnl distribution information. dnl distribution information.
AC_PREREQ(2.59) AC_PREREQ(2.59)
AC_INIT(sqwebmail, 5.9.3, [courier-sqwebmail@lists.sourceforge.net]) AC_INIT(sqwebmail, 6.0.0, [courier-sqwebmail@lists.sourceforge.net])
AC_CONFIG_SRCDIR(dbobj.config.in) AC_CONFIG_SRCDIR(dbobj.config.in)
AC_CONFIG_HEADERS(config.h) AC_CONFIG_HEADERS(config.h)
AM_INIT_AUTOMAKE AM_INIT_AUTOMAKE
>confdefs.h # Kill PACKAGE_ macros >confdefs.h # Kill PACKAGE_ macros
LPATH="$PATH:/usr/local/bin" LPATH="$PATH:/usr/local/bin"
AC_PROG_MAKE_SET AC_PROG_MAKE_SET
AC_PROG_LN_S AC_PROG_LN_S
AC_PROG_SYSCONFTOOL AC_PROG_SYSCONFTOOL
AC_PROG_CC AC_PROG_CC
AC_LIBTOOL_DLOPEN AC_LIBTOOL_DLOPEN
AM_PROG_LIBTOOL AM_PROG_LIBTOOL
AC_PATH_PROGS(SETENV, env) AC_PATH_PROGS(SETENV, env)
dnl Checks for programs. dnl Checks for programs.
AC_ARG_WITH(notice,[AS_HELP_STRING([--with-notice=unicode],
[The --with-notice=unicode option is required, and indicates that you
are aware of the instructions in INSTALL for upgrading to this
version])], [notice="$withval"], [])
case "$notice" in
unicode)
;;
*)
AC_MSG_ERROR([
************************************************************************
Please rerun configure and add the
--with-notice=unicode
option.
This indicates that you've read the instructions in INSTALL about
updating from earlier versions; specifically the need to convert any
existing maildirs to a Unicode naming scheme, and the need to update
any other Courier packages together with updating this one.
If you are building RPMs directly using the spec file from the source
tarball, add a
--define 'notice_option --with-notice=unicode'
option to the rpmbuild command:
$ rpmbuild -ta --define 'notice_option --with-notice=unicode'
This message is only meant to make sure you are aware of the contents
of INSTALL about updating from earlier versions, and the need for
manual steps to update any existing maildirs.
If you are installing for the first time, you can simply rerun configure
with this option.
************************************************************************])
;;
esac
AC_PATH_PROGS(COURIERAUTHCONFIG, courierauthconfig) AC_PATH_PROGS(COURIERAUTHCONFIG, courierauthconfig)
if test "$COURIERAUTHCONFIG" = "" if test "$COURIERAUTHCONFIG" = ""
then then
hash='#' hash='#'
AC_MSG_WARN(=== Courier authentication library not found.) AC_MSG_WARN(=== Courier authentication library not found.)
AC_MSG_WARN(=== You need to download and install) AC_MSG_WARN(=== You need to download and install)
AC_MSG_WARN([=== http://www.courier-mta.org/download.php${hash}authlib fi rst.]) AC_MSG_WARN([=== http://www.courier-mta.org/download.php${hash}authlib fi rst.])
AC_MSG_WARN(=== If courier-authlib is installed in a non-default) AC_MSG_WARN(=== If courier-authlib is installed in a non-default)
AC_MSG_WARN([=== directory, set the COURIERAUTHCONFIG environment]) AC_MSG_WARN([=== directory, set the COURIERAUTHCONFIG environment])
 End of changes. 2 change blocks. 
1 lines changed or deleted 41 lines changed or added

Home  |  About  |  Features  |  All  |  Newest  |  Dox  |  Diffs  |  RSS Feeds  |  Screenshots  |  Comments  |  Imprint  |  Privacy  |  HTTP(S)