"Fossies" - the Fresh Open Source Software Archive  

Source code changes of the file "tools/github/before_install.sh" between
scikit-image-0.18.1.tar.gz and scikit-image-0.18.3.tar.gz

About: scikit-image is a collection of algorithms for image processing in Python.

before_install.sh  (scikit-image-0.18.1):before_install.sh  (scikit-image-0.18.3)
skipping to change at line 36 skipping to change at line 36
} }
if [[ $MINIMUM_REQUIREMENTS == 1 ]]; then if [[ $MINIMUM_REQUIREMENTS == 1 ]]; then
for filename in requirements/*.txt; do for filename in requirements/*.txt; do
sed -i 's/>=/==/g' $filename sed -i 's/>=/==/g' $filename
done done
fi fi
python -m pip install --upgrade pip wheel setuptools python -m pip install --upgrade pip wheel setuptools
# install specific wheels from wheelhouse
for requirement in matplotlib scipy pillow; do
WHEELS="$WHEELS $(grep $requirement requirements/default.txt)"
done
# cython is not in the default.txt requirements
WHEELS="$WHEELS $(grep -i cython requirements/build.txt)"
python -m pip install $PIP_FLAGS $WHEELS
# Install build time requirements # Install build time requirements
python -m pip install $PIP_FLAGS -r requirements/build.txt python -m pip install $PIP_FLAGS -r requirements/build.txt
# Default requirements are necessary to build because of lazy importing # Default requirements are necessary to build because of lazy importing
# They can be moved after the build step if #3158 is accepted # They can be moved after the build step if #3158 is accepted
python -m pip install $PIP_FLAGS -r requirements/default.txt python -m pip install $PIP_FLAGS -r requirements/default.txt
# Show what's installed # Show what's installed
python -m pip list python -m pip list
section () { section () {
 End of changes. 1 change blocks. 
8 lines changed or deleted 0 lines changed or added

Home  |  About  |  Features  |  All  |  Newest  |  Dox  |  Diffs  |  RSS Feeds  |  Screenshots  |  Comments  |  Imprint  |  Privacy  |  HTTP(S)