"Fossies" - the Fresh Open Source Software Archive  

Source code changes of the file "config.pri" between
scidavis-1.26.tar.gz and scidavis-2.1.4.tar.gz

About: SciDAVis is a free application for Scientific Data Analysis and Visualization (a fork off of QtiPlot).

config.pri  (scidavis-1.26):config.pri  (scidavis-2.1.4)
skipping to change at line 224 skipping to change at line 224
### support for Origin OPJ import using liborigin2 ### support for Origin OPJ import using liborigin2
mxe|osx_dist|aegis { mxe|osx_dist|aegis {
CONFIG+=liborigin CONFIG+=liborigin
} }
liborigin { liborigin {
DEFINES += ORIGIN_IMPORT DEFINES += ORIGIN_IMPORT
} }
### python support ### python support
osx_dist|aegis { aegis {
CONFIG+=python CONFIG+=python
} }
################################################################################ ################################################################################
### Dependencies # ### Dependencies #
################################################################################ ################################################################################
# code for maintained branch of liborigin. # code for maintained branch of liborigin.
contains(PRESET, default_installation) { contains(PRESET, default_installation) {
skipping to change at line 280 skipping to change at line 280
# this was an attempt to add a post build step. Doesn't seem to work, # this was an attempt to add a post build step. Doesn't seem to work,
# so just run this step manually # so just run this step manually
QMAKE_EXTRA_TARGETS += mac-dist QMAKE_EXTRA_TARGETS += mac-dist
mac-dist.commands = sh mkMacDist.sh mac-dist.commands = sh mkMacDist.sh
} }
contains(PRESET, linux_package) { contains(PRESET, linux_package) {
### dynamically link against Qwt(3D) installed system-wide ### dynamically link against Qwt(3D) installed system-wide
### WARNING: make sure they are compiled against >= Qt4.2
### Mixing Qt 4.2 and Qt >= 4.3 compiled stuff may also
### cause problems.
equals(QT_MAJOR_VERSION, 5) {
exists(/usr/include/qt5/qwt5-qt5) {INCLUDEPATH+=/usr/include/qt5/qw t5-qt5} exists(/usr/include/qt5/qwt5-qt5) {INCLUDEPATH+=/usr/include/qt5/qw t5-qt5}
exists(/usr/include/qt5/qwtplot3d-qt5) {INCLUDEPATH+=/usr/include/qt5/qw tplot3d-qt5} exists(/usr/include/qt5/qwtplot3d-qt5) {INCLUDEPATH+=/usr/include/qt5/qw tplot3d-qt5}
exists(/usr/include/qwt5-qt5) {INCLUDEPATH+=/usr/include/qwt5-qt5}
exists(/usr/include/qwtplot3d) {INCLUDEPATH+=/usr/include/qwtplot3d}
system (ls /usr/lib*/libqwt5-qt5.so) { system (ls /usr/lib*/libqwt5-qt5.so) {LIBS+=-lqwt5-qt5}
LIBS+=-lqwt5-qt5 system (ls /usr/lib*/*/libqwt5-qt5.so) {LIBS+=-lqwt5-qt5}
} system (ls /usr/lib*/libqwt-qt5.so) {LIBS+=-lqwt-qt5}
system (ls /usr/lib*/libqwtplot3d-qt5.so) { system (ls /usr/lib*/libqwtplot3d-qt5.so) {LIBS+=-lqwtplot3d-qt5}
LIBS+=-lqwtplot3d-qt5 system (ls /usr/lib*/*/libqwtplot3d-qt5.so) {LIBS+=-lqwtplot3d-qt5}
}
} else {
exists(/usr/include/qwt5) {INCLUDEPATH+=/usr/include/qwt5}
exists (/usr/include/qwt-qt4) {INCLUDEPATH+=/usr/include/qwt-qt4}
exists(/usr/include/qwt5-qt4) {INCLUDEPATH+=/usr/include/qwt5-qt4}
exists(/usr/include/qwtplot3d-qt4) {INCLUDEPATH+=/usr/include/qwtplot3d-
qt4} #debianish
else {INCLUDEPATH += /usr/include/qwtplot3d} #standard
system (ls /usr/lib*/libqwt5.so) {
LIBS+=-lqwt5
} else {
system (ls /usr/lib*/libqwt5-qt4.so) {
LIBS+=-lqwt5-qt4
} else {
system (ls /usr/lib*/libqwt-qt4.so) {
LIBS+=-lqwt-qt4
} else {LIBS+=-lqwt}
}
}
system (ls /usr/lib*/libqwtplot3d-qt4.so) {
LIBS+=-lqwtplot3d-qt4
} else {
LIBS+=-lqwtplot3d
}
}
INCLUDEPATH = "$(HOME)/usr/include" $$INCLUDEPATH
QMAKE_LIBDIR = "$(HOME)/usr/lib" $$QMAKE_LIBDIR
LIBS += -lz -lGLU LIBS += -lz -lGLU
INCLUDEPATH += /usr/include/muParser INCLUDEPATH += /usr/include/muParser
LIBS += -lgsl -lgslcblas LIBS += -lgsl -lgslcblas
LIBS += -lmuparser LIBS += -lmuparser
# enable user installed packages
INCLUDEPATH = "$(HOME)/usr/include" $$INCLUDEPATH
QMAKE_LIBDIR = "$(HOME)/usr/lib" $$QMAKE_LIBDIR
} }
contains(PRESET, self_contained) { contains(PRESET, self_contained) {
### mostly static linking, for self-contained binaries ### mostly static linking, for self-contained binaries
INCLUDEPATH += ../3rdparty/qwt/src INCLUDEPATH += ../3rdparty/qwt/src
LIBS += ../3rdparty/qwt/lib/libqwt.a LIBS += ../3rdparty/qwt/lib/libqwt.a
INCLUDEPATH += ../3rdparty/qwtplot3d/include INCLUDEPATH += ../3rdparty/qwtplot3d/include
LIBS += ../3rdparty/qwtplot3d/lib/libqwtplot3d.a LIBS += ../3rdparty/qwtplot3d/lib/libqwtplot3d.a
skipping to change at line 400 skipping to change at line 373
} }
############################################################################# #############################################################################
### Names of the lupdate and lrelease programs # ### Names of the lupdate and lrelease programs #
### # ### #
### These are needed if you want to compile and install the translations # ### These are needed if you want to compile and install the translations #
### automatically. Possibly needs to be adapted if you have an unusual Qt # ### automatically. Possibly needs to be adapted if you have an unusual Qt #
### installation. # ### installation. #
############################################################################# #############################################################################
exists(/usr/bin/lupdate-qt4) { exists(/usr/bin/lupdate-qt5) {
# Debian, Ubuntu, Fedora # Debian, Ubuntu, Fedora
LUPDATE_BIN = lupdate-qt4 LUPDATE_BIN = lupdate-qt5
LRELEASE_BIN = lrelease-qt4 LRELEASE_BIN = lrelease-qt5
} else { } else {
# anything else # anything else
LUPDATE_BIN = lupdate LUPDATE_BIN = lupdate
LRELEASE_BIN = lrelease LRELEASE_BIN = lrelease
} }
 End of changes. 8 change blocks. 
43 lines changed or deleted 15 lines changed or added

Home  |  About  |  Features  |  All  |  Newest  |  Dox  |  Diffs  |  RSS Feeds  |  Screenshots  |  Comments  |  Imprint  |  Privacy  |  HTTP(S)