"Fossies" - the Fresh Open Source Software Archive  

Source code changes of the file "Gemfile" between
redmine-4.1.0.tar.gz and redmine-4.1.1.tar.gz

About: Redmine is a flexible project management and bug-tracking web application (using the Ruby on Rails framework). It supports also project wikis and forums, documents management, and multiple version control systems.

Gemfile  (redmine-4.1.0):Gemfile  (redmine-4.1.1)
source 'https://rubygems.org' source 'https://rubygems.org'
ruby '>= 2.3.0', '< 2.7.0' if Bundler::VERSION >= '1.12.0'
gem "bundler", ">= 1.5.0" gem "bundler", ">= 1.5.0"
gem "rails", "5.2.4.1" gem 'rails', '5.2.4.2'
gem 'sprockets', '~> 3.7.2' if RUBY_VERSION < '2.5'
gem "rouge", "~> 3.12.0" gem "rouge", "~> 3.12.0"
gem "request_store", "~> 1.4.1" gem "request_store", "~> 1.4.1"
gem "mini_mime", "~> 1.0.1" gem "mini_mime", "~> 1.0.1"
gem "actionpack-xml_parser" gem "actionpack-xml_parser"
gem "roadie-rails", (RUBY_VERSION < "2.5" ? "~> 1.3.0" : "~> 2.1.0") gem "roadie-rails", (RUBY_VERSION < "2.5" ? "~> 1.3.0" : "~> 2.1.0")
gem "mimemagic" gem "mimemagic"
gem "mail", "~> 2.7.1" gem "mail", "~> 2.7.1"
gem "csv", "~> 3.1.1" gem "csv", "~> 3.1.1"
gem "nokogiri", "~> 1.10.0" gem "nokogiri", "~> 1.10.0"
gem "i18n", "~> 1.6.0" gem "i18n", "~> 1.6.0"
skipping to change at line 60 skipping to change at line 62
if adapters.any? if adapters.any?
adapters.each do |adapter| adapters.each do |adapter|
case adapter case adapter
when 'mysql2' when 'mysql2'
gem "mysql2", "~> 0.5.0", :platforms => [:mri, :mingw, :x64_mingw] gem "mysql2", "~> 0.5.0", :platforms => [:mri, :mingw, :x64_mingw]
when /postgresql/ when /postgresql/
gem "pg", "~> 1.1.4", :platforms => [:mri, :mingw, :x64_mingw] gem "pg", "~> 1.1.4", :platforms => [:mri, :mingw, :x64_mingw]
when /sqlite3/ when /sqlite3/
gem "sqlite3", "~> 1.4.0", :platforms => [:mri, :mingw, :x64_mingw] gem "sqlite3", "~> 1.4.0", :platforms => [:mri, :mingw, :x64_mingw]
when /sqlserver/ when /sqlserver/
gem "tiny_tds", "~> 1.0.5", :platforms => [:mri, :mingw, :x64_mingw] gem "tiny_tds", "~> 2.1.2", :platforms => [:mri, :mingw, :x64_mingw]
gem "activerecord-sqlserver-adapter", :platforms => [:mri, :mingw, :x64_ gem "activerecord-sqlserver-adapter", "~> 5.2.1", :platforms => [:mri, :
mingw] mingw, :x64_mingw]
else else
warn("Unknown database adapter `#{adapter}` found in config/database.yml , use Gemfile.local to load your own database gems") warn("Unknown database adapter `#{adapter}` found in config/database.yml , use Gemfile.local to load your own database gems")
end end
end end
else else
warn("No adapter found in config/database.yml, please configure it first") warn("No adapter found in config/database.yml, please configure it first")
end end
else else
warn("Please configure your config/database.yml first") warn("Please configure your config/database.yml first")
end end
 End of changes. 3 change blocks. 
4 lines changed or deleted 6 lines changed or added

Home  |  About  |  Features  |  All  |  Newest  |  Dox  |  Diffs  |  RSS Feeds  |  Screenshots  |  Comments  |  Imprint  |  Privacy  |  HTTP(S)