"Fossies" - the Fresh Open Source Software Archive  

Source code changes of the file "Gemfile" between
rails-6.1.3.2.tar.gz and rails-6.1.4.tar.gz

About: Ruby on Rails is a web application development framework (written in Ruby).

Gemfile  (rails-6.1.3.2):Gemfile  (rails-6.1.4)
skipping to change at line 39 skipping to change at line 39
gem "json", ">= 2.0.0" gem "json", ">= 2.0.0"
group :rubocop do group :rubocop do
gem "rubocop", ">= 0.90", require: false gem "rubocop", ">= 0.90", require: false
gem "rubocop-packaging", require: false gem "rubocop-packaging", require: false
gem "rubocop-performance", require: false gem "rubocop-performance", require: false
gem "rubocop-rails", require: false gem "rubocop-rails", require: false
end end
group :doc do group :doc do
gem "sdoc", ">= 2.0.3" gem "sdoc", ">= 2.1.0"
gem "redcarpet", "~> 3.2.3", platforms: :ruby gem "redcarpet", "~> 3.2.3", platforms: :ruby
gem "w3c_validators", "~> 1.3.6" gem "w3c_validators", "~> 1.3.6"
gem "kindlerb", "~> 1.2.0" gem "kindlerb", "~> 1.2.0"
gem "rouge" gem "rouge"
end end
# Active Support # Active Support
gem "dalli" gem "dalli"
gem "listen", "~> 3.3", require: false gem "listen", "~> 3.3", require: false
gem "libxml-ruby", platforms: :ruby gem "libxml-ruby", platforms: :ruby
skipping to change at line 102 skipping to change at line 102
gem "azure-storage-blob", require: false gem "azure-storage-blob", require: false
gem "image_processing", "~> 1.2" gem "image_processing", "~> 1.2"
end end
# Action Mailbox # Action Mailbox
gem "aws-sdk-sns", require: false gem "aws-sdk-sns", require: false
gem "webmock" gem "webmock"
group :ujs do group :ujs do
gem "qunit-selenium"
gem "webdrivers" gem "webdrivers"
end end
# Add your own local bundler stuff. # Add your own local bundler stuff.
local_gemfile = File.expand_path(".Gemfile", __dir__) local_gemfile = File.expand_path(".Gemfile", __dir__)
instance_eval File.read local_gemfile if File.exist? local_gemfile instance_eval File.read local_gemfile if File.exist? local_gemfile
group :test do group :test do
gem "minitest-bisect" gem "minitest-bisect"
gem "minitest-retry" gem "minitest-retry"
skipping to change at line 170 skipping to change at line 169
# Gems that are necessary for Active Record tests with Oracle. # Gems that are necessary for Active Record tests with Oracle.
if ENV["ORACLE_ENHANCED"] if ENV["ORACLE_ENHANCED"]
platforms :ruby do platforms :ruby do
gem "ruby-oci8", "~> 2.2" gem "ruby-oci8", "~> 2.2"
end end
gem "activerecord-oracle_enhanced-adapter", github: "rsim/oracle-enhanced", br anch: "master" gem "activerecord-oracle_enhanced-adapter", github: "rsim/oracle-enhanced", br anch: "master"
end end
gem "tzinfo-data", platforms: [:mingw, :mswin, :x64_mingw, :jruby] gem "tzinfo-data", platforms: [:mingw, :mswin, :x64_mingw, :jruby]
gem "wdm", ">= 0.1.0", platforms: [:mingw, :mswin, :x64_mingw, :mswin64] gem "wdm", ">= 0.1.0", platforms: [:mingw, :mswin, :x64_mingw, :mswin64]
if RUBY_VERSION >= "3.1"
# net-smtp, net-imap and net-pop were removed from default gems in Ruby 3.1, b
ut is used by the `mail` gem.
# So we need to add them as dependencies until `mail` is fixed: https://github
.com/mikel/mail/pull/1439
gem "net-smtp", require: false
gem "net-imap", require: false
gem "net-pop", require: false
# matrix was removed from default gems in Ruby 3.1, but is used by the `capyba
ra` gem.
# So we need to add it as a dependency until `capybara` is fixed: https://gith
ub.com/teamcapybara/capybara/pull/2468
gem "matrix", require: false
end
 End of changes. 3 change blocks. 
2 lines changed or deleted 1 lines changed or added

Home  |  About  |  Features  |  All  |  Newest  |  Dox  |  Diffs  |  RSS Feeds  |  Screenshots  |  Comments  |  Imprint  |  Privacy  |  HTTP(S)