"Fossies" - the Fresh Open Source Software Archive  

Source code changes of the file "pylint/__pkginfo__.py" between
pylint-2.14.1.tar.gz and pylint-2.14.2.tar.gz

About: pylint analyzes Python source code looking for bugs and signs of poor quality.

__pkginfo__.py  (pylint-2.14.1):__pkginfo__.py  (pylint-2.14.2)
skipping to change at line 12 skipping to change at line 12
# For details: https://github.com/PyCQA/pylint/blob/main/LICENSE # For details: https://github.com/PyCQA/pylint/blob/main/LICENSE
# Copyright (c) https://github.com/PyCQA/pylint/blob/main/CONTRIBUTORS.txt # Copyright (c) https://github.com/PyCQA/pylint/blob/main/CONTRIBUTORS.txt
"""This module exists for compatibility reasons. """This module exists for compatibility reasons.
It's updated via tbump, do not modify. It's updated via tbump, do not modify.
""" """
from __future__ import annotations from __future__ import annotations
__version__ = "2.14.1" __version__ = "2.14.2"
def get_numversion_from_version(v: str) -> tuple[int, int, int]: def get_numversion_from_version(v: str) -> tuple[int, int, int]:
"""Kept for compatibility reason. """Kept for compatibility reason.
See https://github.com/PyCQA/pylint/issues/4399 See https://github.com/PyCQA/pylint/issues/4399
https://github.com/PyCQA/pylint/issues/4420, https://github.com/PyCQA/pylint/issues/4420,
""" """
version = v.replace("pylint-", "") version = v.replace("pylint-", "")
result_version = [] result_version = []
for number in version.split(".")[0:3]: for number in version.split(".")[0:3]:
 End of changes. 1 change blocks. 
1 lines changed or deleted 1 lines changed or added

Home  |  About  |  Features  |  All  |  Newest  |  Dox  |  Diffs  |  RSS Feeds  |  Screenshots  |  Comments  |  Imprint  |  Privacy  |  HTTP(S)