"Fossies" - the Fresh Open Source Software Archive  

Source code changes of the file ".github/workflows/build-and-test.yml" between
prophet-1.1.tar.gz and prophet-1.1.1.tar.gz

About: Prophet is a tool for producing high quality forecasts for time series data that has multiple seasonality with linear or non-linear growth.

build-and-test.yml  (prophet-1.1):build-and-test.yml  (prophet-1.1.1)
skipping to change at line 60 skipping to change at line 60
- {os: ubuntu-20.04, r: 'release', rspm: "https://packagemanager.rstud io.com/cran/__linux__/focal/latest"} - {os: ubuntu-20.04, r: 'release', rspm: "https://packagemanager.rstud io.com/cran/__linux__/focal/latest"}
fail-fast: false fail-fast: false
env: env:
R_REMOTES_NO_ERRORS_FROM_WARNINGS: true R_REMOTES_NO_ERRORS_FROM_WARNINGS: true
RSPM: ${{ matrix.config.rspm }} RSPM: ${{ matrix.config.rspm }}
steps: steps:
- uses: actions/checkout@v2 - uses: actions/checkout@v2
- name: Set up R - name: Set up R
uses: r-lib/actions/setup-r@v1 uses: r-lib/actions/setup-r@v2
with: with:
r-version: ${{ matrix.config.r }} r-version: ${{ matrix.config.r }}
- name: Install remotes - name: Install remotes
run: | run: |
install.packages('remotes') install.packages('remotes')
shell: Rscript {0} shell: Rscript {0}
- name: Query dependencies - name: Query dependencies
run: | run: |
saveRDS(remotes::dev_package_deps(pkgdir = "R/", dependencies = TRUE), " .github/depends.Rds", version = 2) saveRDS(remotes::dev_package_deps(pkgdir = "R/", dependencies = TRUE), " .github/depends.Rds", version = 2)
writeLines(sprintf("R-%i.%i", getRversion()$major, getRversion()$minor), ".github/R-version") writeLines(sprintf("R-%i.%i", getRversion()$major, getRversion()$minor), ".github/R-version")
 End of changes. 1 change blocks. 
1 lines changed or deleted 1 lines changed or added

Home  |  About  |  Features  |  All  |  Newest  |  Dox  |  Diffs  |  RSS Feeds  |  Screenshots  |  Comments  |  Imprint  |  Privacy  |  HTTP(S)