"Fossies" - the Fresh Open Source Software Archive  

Source code changes of the file "pyproject.toml" between
poetry-1.1.15.tar.gz and poetry-1.2.0.tar.gz

About: Poetry is a tool for dependency management and packaging in Python.

pyproject.toml  (poetry-1.1.15):pyproject.toml  (poetry-1.2.0)
[tool.poetry] [tool.poetry]
name = "poetry" name = "poetry"
version = "1.1.15" version = "1.2.0"
description = "Python dependency management and packaging made easy." description = "Python dependency management and packaging made easy."
authors = [ authors = [
"Sébastien Eustace <sebastien@eustace.io>" "Sébastien Eustace <sebastien@eustace.io>",
]
maintainers = [
"Arun Babu Neelicattu <arun.neelicattu@gmail.com>",
"Bjorn Neergaard <bjorn@neersighted.com>",
"Branch Vincent <branchevincent@gmail.com>",
"Bryce Drennan <github@accounts.brycedrennan.com>",
"Daniel Eades <danieleades@hotmail.com>",
"Randy Döring <radoering.poetry@gmail.com>",
"Steph Samson <hello@stephsamson.com>",
"finswimmer <finswimmer77@gmail.com>",
] ]
license = "MIT" license = "MIT"
readme = "README.md" readme = "README.md"
packages = [
{ include = "poetry", from = "src" }
]
include = [
{ path = "tests", format = "sdist" }
]
homepage = "https://python-poetry.org/" homepage = "https://python-poetry.org/"
repository = "https://github.com/python-poetry/poetry" repository = "https://github.com/python-poetry/poetry"
documentation = "https://python-poetry.org/docs" documentation = "https://python-poetry.org/docs"
keywords = ["packaging", "dependency", "poetry"] keywords = ["packaging", "dependency", "poetry"]
classifiers = [ classifiers = [
"Topic :: Software Development :: Build Tools", "Topic :: Software Development :: Build Tools",
"Topic :: Software Development :: Libraries :: Python Modules" "Topic :: Software Development :: Libraries :: Python Modules"
] ]
[tool.poetry.build]
generate-setup-file = false
# Requirements # Requirements
[tool.poetry.dependencies] [tool.poetry.dependencies]
python = "~2.7 || ^3.5" python = "^3.7"
poetry-core = "~1.0.7" poetry-core = "1.1.0"
cleo = "^0.8.1" poetry-plugin-export = "^1.0.6"
clikit = "^0.6.2" cachecontrol = { version = "^0.12.9", extras = ["filecache"] }
crashtest = { version = "^0.3.0", python = "^3.6" }
requests = "^2.18"
cachy = "^0.3.0" cachy = "^0.3.0"
requests-toolbelt = "^0.9.1" cleo = "^1.0.0a5"
cachecontrol = [ crashtest = "^0.3.0"
{ version = "^0.12.4", extras = ["filecache"], python = "<3.6" },
{ version = "^0.12.9", extras = ["filecache"], python = "^3.6" }
]
pkginfo = "^1.4"
html5lib = "^1.0" html5lib = "^1.0"
shellingham = "^1.1" importlib-metadata = { version = "^4.4", python = "<3.10" }
tomlkit = ">=0.7.0,<1.0.0" jsonschema = "^4.10.0"
# keyring uses calver, so version is unclamped
keyring = ">=21.2.0"
# packaging uses calver, so version is unclamped
packaging = ">=20.4"
pexpect = "^4.7.0" pexpect = "^4.7.0"
packaging = "^20.4" pkginfo = "^1.5"
virtualenv = { version = "^20.0.26" } platformdirs = "^2.5.2"
requests = "^2.18"
# The typing module is not in the stdlib in Python 2.7 requests-toolbelt = "^0.9.1"
typing = { version = "^3.6", python = "~2.7" } shellingham = "^1.5"
# exclude 0.11.2 and 0.11.3 due to https://github.com/sdispater/tomlkit/issues/2
# Use pathlib2 for Python 2.7 25
pathlib2 = { version = "^2.3", python = "~2.7" } tomlkit = ">=0.11.1,<1.0.0,!=0.11.2,!=0.11.3"
# Use futures on Python 2.7 # exclude 20.4.5 - 20.4.6 due to https://github.com/pypa/pip/issues/9953
futures = { version = "^3.3.0", python = "~2.7" } virtualenv = "(>=20.4.3,<20.4.5 || >=20.4.7)"
# Use glob2 for Python 2.7 and 3.4 xattr = { version = "^0.9.7", markers = "sys_platform == 'darwin'" }
glob2 = { version = "^0.6", python = "~2.7" } urllib3 = "^1.26.0"
# functools32 is needed for Python 2.7 dulwich = "^0.20.44"
functools32 = { version = "^3.2.3", python = "~2.7" }
keyring = [
{ version = "^18.0.1", python = "~2.7" },
{ version = "^20.0.1", python = "~3.5" },
{ version = ">=21.2.0", python = "^3.6" }
]
# Use subprocess32 for Python 2.7
subprocess32 = { version = "^3.5", python = "~2.7" }
importlib-metadata = {version = "^1.6.0", python = "<3.8"}
[tool.poetry.dev-dependencies] [tool.poetry.dev-dependencies]
pytest = [ tox = "^3.18"
{version = "^4.1", python = "<3.5"}, pytest = "^7.1"
{version = "^5.4.3", python = "~3.5"}, pytest-cov = "^3.0"
{version = "^6.2.5", python = ">=3.6"} pytest-mock = "^3.5"
] pytest-randomly = "^3.10"
pytest-cov = "^2.5" pytest-sugar = "^0.9"
pytest-mock = "^1.9" pytest-xdist = { version = "^2.5", extras = ["psutil"] }
pre-commit = { version = "^2.6", python = "^3.6.1" } pre-commit = "^2.6"
tox = "^3.0" deepdiff = "^5.0"
pytest-sugar = "^0.9.2" httpretty = "^1.0"
httpretty = "^0.9.6" typing-extensions = { version = "^4.0.0", python = "<3.8" }
# We need to restrict the version of urllib3 to avoid zipp = { version = "^3.4", python = "<3.8" }
# httpretty breaking. This is fixed in httpretty >= 1.0.3 flatdict = "^4.0.1"
# but it's not compatible with Python 2.7 and 3.5. mypy = ">=0.971"
urllib3 = "~1.25.10" types-html5lib = ">=1.1.9"
types-jsonschema = ">=4.9.0"
types-requests = ">=2.28.8"
[tool.poetry.scripts] [tool.poetry.scripts]
poetry = "poetry.console:main" poetry = "poetry.console.application:main"
[build-system] [build-system]
requires = ["poetry-core>=1.0.0"] requires = ["poetry-core>=1.0.0"]
build-backend = "poetry.core.masonry.api" build-backend = "poetry.core.masonry.api"
[tool.isort] [tool.isort]
py_version = 37
profile = "black" profile = "black"
force_single_line = true force_single_line = true
atomic = true combine_as_imports = true
include_trailing_comma = true
lines_after_imports = 2
lines_between_types = 1 lines_between_types = 1
use_parentheses = true lines_after_imports = 2
src_paths = ["poetry", "tests"] src_paths = ["src", "tests"]
skip_glob = ["*/setup.py"] extend_skip = ["setup.py"]
filter_files = true known_third_party = ["poetry.core"]
known_first_party = "poetry"
[tool.black] [tool.black]
line-length = 88 target-version = ['py37']
include = '\.pyi?$' preview = true
exclude = ''' force-exclude = '''
/( .*/setup\.py$
\.eggs
| \.git
| \.hg
| \.mypy_cache
| \.tox
| \.venv
| _build
| buck-out
| build
| dist
| tests/.*/setup.py
)/
''' '''
[tool.mypy]
files = "src"
mypy_path = "src"
namespace_packages = true
explicit_package_bases = true
show_error_codes = true
strict = true
enable_error_code = [
"ignore-without-code",
"redundant-expr",
"truthy-bool",
]
# use of importlib-metadata backport at python3.7 makes it impossible to
# satisfy mypy without some ignores: but we get a different set of ignores at
# different python versions.
#
# <https://github.com/python/mypy/issues/8823>, meanwhile suppress that
# warning.
[[tool.mypy.overrides]]
module = [
'poetry.console.commands.self.show.plugins',
'poetry.installation.executor',
'poetry.mixology.version_solver',
'poetry.plugins.plugin_manager',
'poetry.repositories.installed_repository',
'poetry.utils.env',
]
warn_unused_ignores = false
[[tool.mypy.overrides]]
module = [
'cachecontrol.*',
'cachy.*',
'cleo.*',
'crashtest.*',
'pexpect.*',
'pkginfo.*',
'requests_toolbelt.*',
'shellingham.*',
'virtualenv.*',
'xattr.*',
]
ignore_missing_imports = true
[tool.coverage.report]
exclude_lines = [
"pragma: no cover",
"if TYPE_CHECKING:"
]
 End of changes. 16 change blocks. 
78 lines changed or deleted 75 lines changed or added

Home  |  About  |  Features  |  All  |  Newest  |  Dox  |  Diffs  |  RSS Feeds  |  Screenshots  |  Comments  |  Imprint  |  Privacy  |  HTTP(S)