"Fossies" - the Fresh Open Source Software Archive  

Source code changes of the file "tox.ini" between
keystone-16.0.0.tar.gz and keystone-16.0.1.tar.gz

About: OpenStack Keystone (Core Service: Identity) provides an authentication and authorization service for other OpenStack services. Provides a catalog of endpoints for all OpenStack services.
The "Train" series (latest release).

tox.ini  (keystone-16.0.0):tox.ini  (keystone-16.0.1)
[tox] [tox]
minversion = 2.5.0 minversion = 2.5.0
skipsdist = True skipsdist = True
envlist = py27,py37,pep8,api-ref,docs,genconfig,genpolicy,releasenotes,protectio n envlist = py27,py37,pep8,api-ref,docs,genconfig,genpolicy,releasenotes,protectio n
[testenv] [testenv]
usedevelop = True usedevelop = True
install_command = pip install {opts} {packages} install_command = pip install {opts} {packages}
setenv = VIRTUAL_ENV={envdir} setenv = VIRTUAL_ENV={envdir}
deps = -c{env:UPPER_CONSTRAINTS_FILE:https://releases.openstack.org/constraints/ upper/master} deps = -c{env:UPPER_CONSTRAINTS_FILE:https://releases.openstack.org/constraints/ upper/train}
-r{toxinidir}/test-requirements.txt -r{toxinidir}/test-requirements.txt
-r{toxinidir}/requirements.txt -r{toxinidir}/requirements.txt
.[ldap,memcache,mongodb] .[ldap,memcache,mongodb]
commands = commands =
find keystone -type f -name "*.pyc" -delete find keystone -type f -name "*.pyc" -delete
stestr run {posargs} stestr run {posargs}
whitelist_externals = whitelist_externals =
bash bash
find find
passenv = http_proxy HTTP_PROXY https_proxy HTTPS_PROXY no_proxy NO_PROXY PBR_VE RSION passenv = http_proxy HTTP_PROXY https_proxy HTTPS_PROXY no_proxy NO_PROXY PBR_VE RSION
skipping to change at line 53 skipping to change at line 53
basepython = python3 basepython = python3
envdir = {toxworkdir}/pep8 envdir = {toxworkdir}/pep8
commands = commands =
{toxinidir}/tools/fast8.sh {toxinidir}/tools/fast8.sh
passenv = FAST8_NUM_COMMITS passenv = FAST8_NUM_COMMITS
[testenv:bandit] [testenv:bandit]
basepython = python3 basepython = python3
# NOTE(browne): This is required for the integration test job of the bandit # NOTE(browne): This is required for the integration test job of the bandit
# project. Please do not remove. # project. Please do not remove.
deps = -c{env:UPPER_CONSTRAINTS_FILE:https://releases.openstack.org/constraints/ upper/master} deps = -c{env:UPPER_CONSTRAINTS_FILE:https://releases.openstack.org/constraints/ upper/train}
-r{toxinidir}/requirements.txt -r{toxinidir}/requirements.txt
.[bandit] .[bandit]
commands = bandit -r keystone -x 'keystone/tests/*' commands = bandit -r keystone -x 'keystone/tests/*'
[testenv:cover] [testenv:cover]
basepython = python3 basepython = python3
# Also do not run test_coverage_ext tests while gathering coverage as those # Also do not run test_coverage_ext tests while gathering coverage as those
# tests conflict with coverage. # tests conflict with coverage.
setenv = setenv =
{[testenv]setenv} {[testenv]setenv}
skipping to change at line 138 skipping to change at line 138
# E402: module level import not at top of file # E402: module level import not at top of file
# W503: line break before binary operator # W503: line break before binary operator
ignore = D100,D101,D102,D103,D104,D203,E402,W503 ignore = D100,D101,D102,D103,D104,D203,E402,W503
exclude=.venv,.git,.tox,build,dist,*lib/python*,*egg,tools,vendor,.update-venv,* .ini,*.po,*.pot exclude=.venv,.git,.tox,build,dist,*lib/python*,*egg,tools,vendor,.update-venv,* .ini,*.po,*.pot
max-complexity=24 max-complexity=24
[testenv:docs] [testenv:docs]
basepython = python3 basepython = python3
deps = deps =
-c{env:UPPER_CONSTRAINTS_FILE:https://releases.openstack.org/constraints/upper /train}
-r{toxinidir}/doc/requirements.txt -r{toxinidir}/doc/requirements.txt
.[ldap,memcache,mongodb] .[ldap,memcache,mongodb]
commands= commands=
bash -c "rm -rf doc/build" bash -c "rm -rf doc/build"
bash -c "rm -rf doc/source/api" bash -c "rm -rf doc/source/api"
sphinx-build -W -b html -d doc/build/doctrees doc/source doc/build/html sphinx-build -W -b html -d doc/build/doctrees doc/source doc/build/html
# FIXME(gyee): we need to pre-create the doc/build/pdf/_static directory as a # FIXME(gyee): we need to pre-create the doc/build/pdf/_static directory as a
# workaround because sphinx_feature_classification.support_matrix extension # workaround because sphinx_feature_classification.support_matrix extension
# is operating under the assumption that the _static directory already exist # is operating under the assumption that the _static directory already exist
 End of changes. 3 change blocks. 
2 lines changed or deleted 3 lines changed or added

Home  |  About  |  Features  |  All  |  Newest  |  Dox  |  Diffs  |  RSS Feeds  |  Screenshots  |  Comments  |  Imprint  |  Privacy  |  HTTP(S)