"Fossies" - the Fresh Open Source Software Archive  

Source code changes of the file "INSTALL.md" between
htmldoc-1.9.11-source.tar.gz and htmldoc-1.9.12-source.tar.gz

About: HTMLDOC converts HTML and Markdown source files into indexed HTML, EPUB, PostScript, or PDF files (but doesn’t support CSS).

INSTALL.md  (htmldoc-1.9.11-source):INSTALL.md  (htmldoc-1.9.12-source)
How to Install HTMLDOC from Source How to Install HTMLDOC from Source
================================== ==================================
To compile HTMLDOC you'll need C and C++ compilers (gcc is fine, most vendor To compile HTMLDOC you'll need C and C++ compilers (clang and gcc are fine)
compilers work, too). The JPEG, PNG, and ZLIB libraries are provided with along with the following libraries:
HTMLDOC.
For the GUI support you'll need FLTK 1.1.x or 1.3.x. FLTK is a LGPL'd cross- - FLTK 1.1.x or higher for GUI support
platform GUI toolkit and can be downloaded from: - GNU TLS for HTTPS support (except on macOS and Windows)
- libjpeg (7 or higher) or libjpeg-turbo for JPEG support
http://www.fltk.org/ - libpng 1.6 or higher for PNG support
- zlib 1.1 or higher
For HTTPS support you'll need GNU TLS on Linux and UNIX.
Windows Windows
------- -------
A Visual Studio solution is included in the "vcnet" directory. You must add the A Visual Studio solution is included in the "vcnet" directory. You must add the
FLTK include and library directories separately for the solution to build. FLTK include and library directories separately for the solution to build.
We highly recommend building and installing the HTMLDOC MSI target, as it takes We highly recommend building and installing the HTMLDOC MSI target, as it takes
care of registering the installation location with Windows. If you want to care of registering the installation location with Windows. If you want to
install the software by hand, create a directory for the software and copy the install the software by hand, create a directory for the software and copy the
skipping to change at line 68 skipping to change at line 66
----------------------- -----------------------
You should install the following packages: You should install the following packages:
sudo apt-get install build-essential autoconf libfltk1.3-dev \ sudo apt-get install build-essential autoconf libfltk1.3-dev \
libgnutls28-dev libjpeg-dev libpng-dev pkg-config zlib1g-dev libgnutls28-dev libjpeg-dev libpng-dev pkg-config zlib1g-dev
CentOS, Fedora, and RHEL Notes CentOS, Fedora, and RHEL Notes
------------------------------ ------------------------------
The version of GCC bundled with older releases of these operating systems cannot Install the following packages to get full functionality:
handle the version of libpng that is bundled with HTMLDOC. Install the
following packages to avoid this and get full functionality:
sudo yum install autoconf fltk-devel gnutls-devel libjpeg-devel \ sudo yum install autoconf fltk-devel gnutls-devel libjpeg-devel \
libpng-devel pkgconfig zlib-devel libpng-devel pkgconfig zlib-devel
 End of changes. 3 change blocks. 
12 lines changed or deleted 8 lines changed or added

Home  |  About  |  Features  |  All  |  Newest  |  Dox  |  Diffs  |  RSS Feeds  |  Screenshots  |  Comments  |  Imprint  |  Privacy  |  HTTP(S)