"Fossies" - the Fresh Open Source Software Archive  

Source code changes of the file "pyproject.toml" between
gvm-tools-21.6.0.tar.gz and gvm-tools-21.6.1.tar.gz

About: GVM-Tools is a collection of tools that help with remote controlling a Greenbone Security Manager (GSM) appliance and its underlying Greenbone Vulnerability Manager (GVM). Series 21.x.

pyproject.toml  (gvm-tools-21.6.0):pyproject.toml  (gvm-tools-21.6.1)
[build-system] [build-system]
requires = ["poetry>=0.12"] requires = ["poetry>=0.12"]
build-backend = "poetry.masonry.api" build-backend = "poetry.masonry.api"
[tool.poetry] [tool.poetry]
name = "gvm-tools" name = "gvm-tools"
version = "21.6.0" version = "21.6.1"
authors = ["Greenbone Networks GmbH <info@greenbone.net>"] authors = ["Greenbone Networks GmbH <info@greenbone.net>"]
description = "Tools to control a GSM/GVM over GMP or OSP" description = "Tools to control a GSM/GVM over GMP or OSP"
license = "GPL-3.0-or-later" license = "GPL-3.0-or-later"
readme = "README.md" readme = "README.md"
homepage = "https://github.com/greenbone/gvm-tools/" homepage = "https://github.com/greenbone/gvm-tools/"
repository = "https://github.com/greenbone/gvm-tools/" repository = "https://github.com/greenbone/gvm-tools/"
documentation = "https://gvm-tools.readthedocs.io/" documentation = "https://gvm-tools.readthedocs.io/"
classifiers=[ classifiers=[
# Full list: https://pypi.org/pypi?%3Aaction=list_classifiers # Full list: https://pypi.org/pypi?%3Aaction=list_classifiers
'Development Status :: 5 - Production/Stable', 'Development Status :: 5 - Production/Stable',
skipping to change at line 45 skipping to change at line 45
gvm-pyshell = "gvmtools.pyshell:main" gvm-pyshell = "gvmtools.pyshell:main"
gvm-cli = "gvmtools.cli:main" gvm-cli = "gvmtools.cli:main"
gvm-script = "gvmtools.script:main" gvm-script = "gvmtools.script:main"
[tool.poetry.dependencies] [tool.poetry.dependencies]
python = "^3.7.0" python = "^3.7.0"
python-gvm = ">=21.5,<22.0" python-gvm = ">=21.5,<22.0"
[tool.poetry.dev-dependencies] [tool.poetry.dev-dependencies]
autohooks = "^21.3.0" autohooks = "^21.3.0"
autohooks-plugin-pylint = "^1.2.0" autohooks-plugin-pylint = "^21.6.0"
sphinx = "^4.0.2" sphinx = "^4.0.2"
pylint = "^2.8.3" pylint = "^2.8.3"
coverage = "^5.5" coverage = "^5.5"
autohooks-plugin-black = {version = "^1.2.0", python = "^3.6"} autohooks-plugin-black = {version = "^1.2.0", python = "^3.6"}
black = {version = "21.5b2", python = "^3.6"} black = {version = "21.6b0", python = "^3.6"}
rope = "^0.19.0" rope = "^0.19.0"
pontos = "^21.6.3" pontos = "^21.6.3"
[tool.black] [tool.black]
line-length = 80 line-length = 80
target-version = ['py35', 'py36', 'py37', 'py38'] target-version = ['py35', 'py36', 'py37', 'py38']
skip-string-normalization = true skip-string-normalization = true
exclude = ''' exclude = '''
/( /(
\.git \.git
 End of changes. 3 change blocks. 
3 lines changed or deleted 3 lines changed or added

Home  |  About  |  Features  |  All  |  Newest  |  Dox  |  Diffs  |  RSS Feeds  |  Screenshots  |  Comments  |  Imprint  |  Privacy  |  HTTP(S)