"Fossies" - the Fresh Open Source Software Archive  

Source code changes of the file "SECURITY.md" between
glib-2.69.2.tar.xz and glib-2.69.3.tar.xz

About: GLib is a low-level core C library used by GTK+ and GNOME. Development version.

SECURITY.md  (glib-2.69.2.tar.xz):SECURITY.md  (glib-2.69.3.tar.xz)
skipping to change at line 20 skipping to change at line 20
Upstream GLib only supports the most recent stable release series, and the Upstream GLib only supports the most recent stable release series, and the
current development release series. Any older stable release series are no current development release series. Any older stable release series are no
longer supported, although they may still receive backported security updates longer supported, although they may still receive backported security updates
in long-term support distributions. Such support is up to the distributions, in long-term support distributions. Such support is up to the distributions,
though. though.
Under GLib’s versioning scheme, stable release series have an *even* minor Under GLib’s versioning scheme, stable release series have an *even* minor
component (for example, 2.66.0, 2.66.1, 2.68.3), and development release series component (for example, 2.66.0, 2.66.1, 2.68.3), and development release series
have an *odd* minor component (2.67.1, 2.69.0). have an *odd* minor component (2.67.1, 2.69.0).
## Signed Releases
The git tags for all releases ≥2.58.0 are signed by a maintainer using
[git-evtag](https://github.com/cgwalters/git-evtag). The maintainer will use
their personal GPG key; there is currently not necessarily a formal chain of
trust for these keys. Please [create an issue](https://gitlab.gnome.org/GNOME/gl
ib/-/issues/new)
if you would like to work on improving this.
Unsigned releases ≥2.58.0 should not be trusted. Releases prior to 2.58.0 were
not signed.
## Reporting a Vulnerability ## Reporting a Vulnerability
If you think you've identified a security issue in GLib, GObject or GIO, please If you think you've identified a security issue in GLib, GObject or GIO, please
**do not** report the issue publicly via a mailing list, IRC, a public issue on **do not** report the issue publicly via a mailing list, IRC, a public issue on
the GitLab issue tracker, a merge request, or any other public venue. the GitLab issue tracker, a merge request, or any other public venue.
Instead, report a Instead, report a
[*confidential* issue in the GitLab issue tracker](https://gitlab.gnome.org/GNOM E/glib/-/issues/new?issue[confidential]=1), [*confidential* issue in the GitLab issue tracker](https://gitlab.gnome.org/GNOM E/glib/-/issues/new?issue[confidential]=1),
with the “This issue is confidential” box checked. Please include as many with the “This issue is confidential” box checked. Please include as many
details as possible, including a minimal reproducible example of the issue, and details as possible, including a minimal reproducible example of the issue, and
 End of changes. 1 change blocks. 
0 lines changed or deleted 12 lines changed or added

Home  |  About  |  Features  |  All  |  Newest  |  Dox  |  Diffs  |  RSS Feeds  |  Screenshots  |  Comments  |  Imprint  |  Privacy  |  HTTP(S)