"Fossies" - the Fresh Open Source Software Archive  

Source code changes of the file "ChangeLog" between
fail2ban-1.0.1.tar.gz and fail2ban-1.0.2.tar.gz

About: fail2ban scans log files and bans (via firewall rules) IP-addresses that makes too many access failures. It updates firewall rules to reject the IP address.

ChangeLog  (fail2ban-1.0.1):ChangeLog  (fail2ban-1.0.2)
<!-- vim: syntax=Markdown --> <!-- vim: syntax=Markdown -->
__ _ _ ___ _ __ _ _ ___ _
/ _|__ _(_) |_ ) |__ __ _ _ _ / _|__ _(_) |_ ) |__ __ _ _ _
| _/ _` | | |/ /| '_ \/ _` | ' \ | _/ _` | | |/ /| '_ \/ _` | ' \
|_| \__,_|_|_/___|_.__/\__,_|_||_| |_| \__,_|_|_/___|_.__/\__,_|_||_|
Fail2Ban: Changelog Fail2Ban: Changelog
=================== ===================
ver. 1.0.2 (2022/11/09) - finally-war-game-test-tape-not-a-nuclear-alarm
-----------
### Fixes
* backend `systemd`: code review and several fixes:
- wait only if it is necessary, e. g. in operational mode and if no more entri
es retrieved (end of journal);
- ensure we give enough time after possible rotation, vacuuming or adding/remo
ving journal files,
and move cursor back and forth to avoid entering dead space
* `filter.d/named-refused.conf`:
- support BIND named log categories, gh-3388
- allow `info:` as possible error prefix too ("query (cache) denied" may occur
as info)
* `filter.d/dovecot.conf`:
- fixes regression introduced in gh-3210: resolve extremely long search by rep
eated apply of non-greedy RE-part
with following branches (it may be extremely slow up to infinite search depe
nding on message), gh-3370
- fixes regression and matches new format in aggressive mode too (amend to gh-
3210)
### New Features and Enhancements
ver. 1.0.1 (2022/09/27) - energy-equals-mass-times-the-speed-of-light-squared ver. 1.0.1 (2022/09/27) - energy-equals-mass-times-the-speed-of-light-squared
----------- -----------
### Compatibility ### Compatibility
* the minimum supported python version is now 2.7, if you have previous python v ersion * the minimum supported python version is now 2.7, if you have previous python v ersion
you can use the 0.11 version of fail2ban or upgrade python (or even build it f rom source). you can use the 0.11 version of fail2ban or upgrade python (or even build it f rom source).
* potential incompatibility by parsing of options of `backend`, `filter` and `ac tion` parameters (if they * potential incompatibility by parsing of options of `backend`, `filter` and `ac tion` parameters (if they
are partially incorrect), because fail2ban could throw an error now (doesn't s ilently bypass it anymore). are partially incorrect), because fail2ban could throw an error now (doesn't s ilently bypass it anymore).
* due to fix for CVE-2021-32749 (GHSA-m985-3f3v-cwmm) the mailing action using m ailutils may require extra configuration, * due to fix for CVE-2021-32749 (GHSA-m985-3f3v-cwmm) the mailing action using m ailutils may require extra configuration,
if it is not compatible or doesn't support `-E 'set escape'` (e. g. with `mail cmd` parameter), see gh-3059 if it is not compatible or doesn't support `-E 'set escape'` (e. g. with `mail cmd` parameter), see gh-3059
 End of changes. 1 change blocks. 
0 lines changed or deleted 24 lines changed or added

Home  |  About  |  Features  |  All  |  Newest  |  Dox  |  Diffs  |  RSS Feeds  |  Screenshots  |  Comments  |  Imprint  |  Privacy  |  HTTP(S)