"Fossies" - the Fresh Open Source Software Archive  

Source code changes of the file "lib/version.rb" between
discourse-2.7.3.tar.gz and discourse-2.7.4.tar.gz

About: Discourse is a "next-generation" forum platform for community discussions.

version.rb  (discourse-2.7.3):version.rb  (discourse-2.7.4)
skipping to change at line 12 skipping to change at line 12
module Discourse module Discourse
VERSION_REGEXP ||= /\A\d+\.\d+\.\d+(\.beta\d+)?\z/ VERSION_REGEXP ||= /\A\d+\.\d+\.\d+(\.beta\d+)?\z/
VERSION_COMPATIBILITY_FILENAME ||= ".discourse-compatibility" VERSION_COMPATIBILITY_FILENAME ||= ".discourse-compatibility"
# work around reloader # work around reloader
unless defined? ::Discourse::VERSION unless defined? ::Discourse::VERSION
module VERSION #:nodoc: module VERSION #:nodoc:
MAJOR = 2 MAJOR = 2
MINOR = 7 MINOR = 7
TINY = 3 TINY = 4
PRE = nil PRE = nil
STRING = [MAJOR, MINOR, TINY, PRE].compact.join('.') STRING = [MAJOR, MINOR, TINY, PRE].compact.join('.')
end end
end end
class InvalidVersionListError < StandardError; end class InvalidVersionListError < StandardError; end
def self.has_needed_version?(current, needed) def self.has_needed_version?(current, needed)
Gem::Version.new(current) >= Gem::Version.new(needed) Gem::Version.new(current) >= Gem::Version.new(needed)
 End of changes. 1 change blocks. 
1 lines changed or deleted 1 lines changed or added

Home  |  About  |  Features  |  All  |  Newest  |  Dox  |  Diffs  |  RSS Feeds  |  Screenshots  |  Comments  |  Imprint  |  Privacy  |  HTTP(S)