"Fossies" - the Fresh Open Source Software Archive  

Source code changes of the file "configure.ac" between
cryptsetup-2.4.2.tar.xz and cryptsetup-2.4.3.tar.xz

About: cryptsetup is a utility used to conveniently setup disk encryption based on the dm-crypt kernel module. These include plain dm-crypt volumes, LUKS volumes, loop-AES and TrueCrypt compatible format.

configure.ac  (cryptsetup-2.4.2.tar.xz):configure.ac  (cryptsetup-2.4.3.tar.xz)
AC_PREREQ([2.67]) AC_PREREQ([2.67])
AC_INIT([cryptsetup],[2.4.2]) AC_INIT([cryptsetup],[2.4.3])
dnl library version from <major>.<minor>.<release>[-<suffix>] dnl library version from <major>.<minor>.<release>[-<suffix>]
LIBCRYPTSETUP_VERSION=$(echo $PACKAGE_VERSION | cut -f1 -d-) LIBCRYPTSETUP_VERSION=$(echo $PACKAGE_VERSION | cut -f1 -d-)
LIBCRYPTSETUP_VERSION_INFO=19:0:7 LIBCRYPTSETUP_VERSION_INFO=19:0:7
AM_SILENT_RULES([yes]) AM_SILENT_RULES([yes])
AC_CONFIG_SRCDIR(src/cryptsetup.c) AC_CONFIG_SRCDIR(src/cryptsetup.c)
AC_CONFIG_MACRO_DIR([m4]) AC_CONFIG_MACRO_DIR([m4])
AC_CONFIG_HEADERS([config.h:config.h.in]) AC_CONFIG_HEADERS([config.h:config.h.in])
skipping to change at line 143 skipping to change at line 143
AC_ARG_ENABLE([ssh-token], AC_ARG_ENABLE([ssh-token],
AS_HELP_STRING([--disable-ssh-token], [disable LUKS2 ssh-token]), AS_HELP_STRING([--disable-ssh-token], [disable LUKS2 ssh-token]),
[], [enable_ssh_token=yes]) [], [enable_ssh_token=yes])
AM_CONDITIONAL(SSHPLUGIN_TOKEN, test "x$enable_ssh_token" = "xyes") AM_CONDITIONAL(SSHPLUGIN_TOKEN, test "x$enable_ssh_token" = "xyes")
if test "x$enable_ssh_token" = "xyes" -a "x$enable_external_tokens" = "xno"; the n if test "x$enable_ssh_token" = "xyes" -a "x$enable_external_tokens" = "xno"; the n
AC_MSG_ERROR([Requested LUKS2 ssh-token build, but external tokens are di sabled.]) AC_MSG_ERROR([Requested LUKS2 ssh-token build, but external tokens are di sabled.])
fi fi
dnl LUKS2 online reencryption
AC_ARG_ENABLE([luks2-reencryption],
AS_HELP_STRING([--disable-luks2-reencryption], [disable LUKS2 online reen
cryption extension]),
[], [enable_luks2_reencryption=yes])
if test "x$enable_luks2_reencryption" = "xyes"; then
AC_DEFINE(USE_LUKS2_REENCRYPTION, 1, [Use LUKS2 online reencryption exten
sion])
fi
dnl ========================================================================== dnl ==========================================================================
AM_GNU_GETTEXT([external],[need-ngettext]) AM_GNU_GETTEXT([external],[need-ngettext])
AM_GNU_GETTEXT_VERSION([0.18.3]) AM_GNU_GETTEXT_VERSION([0.18.3])
dnl ========================================================================== dnl ==========================================================================
saved_LIBS=$LIBS saved_LIBS=$LIBS
AC_CHECK_LIB(popt, poptConfigFileToString,, AC_CHECK_LIB(popt, poptConfigFileToString,,
[AC_MSG_ERROR([You need popt 1.7 or newer to compile.])]) [AC_MSG_ERROR([You need popt 1.7 or newer to compile.])])
 End of changes. 2 change blocks. 
1 lines changed or deleted 11 lines changed or added

Home  |  About  |  Features  |  All  |  Newest  |  Dox  |  Diffs  |  RSS Feeds  |  Screenshots  |  Comments  |  Imprint  |  Privacy  |  HTTP(S)