"Fossies" - the Fresh Open Source Software Archive  

Source code changes of the file "doc/06-config.md" between
composer-2.1.2.tar.gz and composer-2.1.3.tar.gz

About: Composer helps you declare, manage, and install dependencies of PHP projects.

06-config.md  (composer-2.1.2):06-config.md  (composer-2.1.3)
skipping to change at line 256 skipping to change at line 256
size the cache will be able to use. Older (less used) files will be removed size the cache will be able to use. Older (less used) files will be removed
first until the cache fits. first until the cache fits.
## cache-read-only ## cache-read-only
Defaults to `false`. Whether to use the Composer cache in read-only mode. Defaults to `false`. Whether to use the Composer cache in read-only mode.
## bin-compat ## bin-compat
Defaults to `auto`. Determines the compatibility of the binaries to be installed . Defaults to `auto`. Determines the compatibility of the binaries to be installed .
If it is `auto` then Composer only installs .bat proxy files when on Windows. If If it is `auto` then Composer only installs .bat proxy files when on Windows or WSL. If
set to `full` then both .bat files for Windows and scripts for Unix-based set to `full` then both .bat files for Windows and scripts for Unix-based
operating systems will be installed for each binary. This is mainly useful if yo u operating systems will be installed for each binary. This is mainly useful if yo u
run Composer inside a linux VM but still want the .bat proxies available for use run Composer inside a linux VM but still want the `.bat` proxies available for u
in the Windows host OS. se
in the Windows host OS. If set to `symlink` Composer will always symlink even on
Windows/WSL.
## prepend-autoloader ## prepend-autoloader
Defaults to `true`. If `false`, the Composer autoloader will not be prepended to Defaults to `true`. If `false`, the Composer autoloader will not be prepended to
existing autoloaders. This is sometimes required to fix interoperability issues existing autoloaders. This is sometimes required to fix interoperability issues
with other autoloaders. with other autoloaders.
## autoloader-suffix ## autoloader-suffix
Defaults to `null`. String to be used as a suffix for the generated Composer Defaults to `null`. String to be used as a suffix for the generated Composer
 End of changes. 2 change blocks. 
3 lines changed or deleted 5 lines changed or added

Home  |  About  |  Features  |  All  |  Newest  |  Dox  |  Diffs  |  RSS Feeds  |  Screenshots  |  Comments  |  Imprint  |  Privacy  |  HTTP(S)