"Fossies" - the Fresh Open Source Software Archive  

Source code changes of the file "appveyor.yml" between
cheetah3-3.2.4.tar.gz and cheetah3-3.2.5.tar.gz

About: Cheetah3 is a template engine and code generation tool for e.g. for Web development or Java, SQL, LaTeX, form email ... (written in Python).

appveyor.yml  (cheetah3-3.2.4):appveyor.yml  (cheetah3-3.2.5)
skipping to change at line 28 skipping to change at line 28
matrix: matrix:
- TOXENV: "py27" - TOXENV: "py27"
PYTHON_VERSION: "2.7" PYTHON_VERSION: "2.7"
PYTHON_ARCH: "32" PYTHON_ARCH: "32"
PYTHON_HOME: "C:\\Python27" PYTHON_HOME: "C:\\Python27"
- TOXENV: "py27" - TOXENV: "py27"
PYTHON_VERSION: "2.7" PYTHON_VERSION: "2.7"
PYTHON_ARCH: "64" PYTHON_ARCH: "64"
PYTHON_HOME: "C:\\Python27-x64" PYTHON_HOME: "C:\\Python27-x64"
- TOXENV: "py34" - TOXENV: "py34-w32"
PYTHON_VERSION: "3.4" PYTHON_VERSION: "3.4"
PYTHON_ARCH: "32" PYTHON_ARCH: "32"
PYTHON_HOME: "C:\\Python34" PYTHON_HOME: "C:\\Python34"
- TOXENV: "py34" - TOXENV: "py34-w32"
PYTHON_VERSION: "3.4" PYTHON_VERSION: "3.4"
PYTHON_ARCH: "64" PYTHON_ARCH: "64"
PYTHON_HOME: "C:\\Python34-x64" PYTHON_HOME: "C:\\Python34-x64"
- TOXENV: "py35" - TOXENV: "py35"
PYTHON_VERSION: "3.5" PYTHON_VERSION: "3.5"
PYTHON_ARCH: "32" PYTHON_ARCH: "32"
PYTHON_HOME: "C:\\Python35" PYTHON_HOME: "C:\\Python35"
- TOXENV: "py35" - TOXENV: "py35"
PYTHON_VERSION: "3.5" PYTHON_VERSION: "3.5"
PYTHON_ARCH: "64" PYTHON_ARCH: "64"
skipping to change at line 60 skipping to change at line 60
PYTHON_ARCH: "64" PYTHON_ARCH: "64"
PYTHON_HOME: "C:\\Python36-x64" PYTHON_HOME: "C:\\Python36-x64"
- TOXENV: "py37" - TOXENV: "py37"
PYTHON_VERSION: "3.7" PYTHON_VERSION: "3.7"
PYTHON_ARCH: "32" PYTHON_ARCH: "32"
PYTHON_HOME: "C:\\Python37" PYTHON_HOME: "C:\\Python37"
- TOXENV: "py37" - TOXENV: "py37"
PYTHON_VERSION: "3.7" PYTHON_VERSION: "3.7"
PYTHON_ARCH: "64" PYTHON_ARCH: "64"
PYTHON_HOME: "C:\\Python37-x64" PYTHON_HOME: "C:\\Python37-x64"
- TOXENV: "py38"
PYTHON_VERSION: "3.8"
PYTHON_ARCH: "32"
PYTHON_HOME: "C:\\Python38"
- TOXENV: "py38"
PYTHON_VERSION: "3.8"
PYTHON_ARCH: "64"
PYTHON_HOME: "C:\\Python38-x64"
- TOXENV: "pypy" - TOXENV: "pypy"
PYTHON_VERSION: "2.7" PYTHON_VERSION: "2.7"
PYTHON_ARCH: "32" PYTHON_ARCH: "32"
PYTHON_HOME: "C:\\tools\\pypy\\pypy" PYTHON_HOME: "C:\\tools\\pypy\\pypy"
install: install:
# Ensure we use the right python version # Ensure we use the right python version
- "SET PATH=%PYTHON_HOME%;%PYTHON_HOME%\\Scripts;%PATH%" - "SET PATH=%PYTHON_HOME%;%PYTHON_HOME%\\Scripts;%PATH%"
- "SET TOXPYTHON=%PYTHON_HOME%\\python.exe" - "SET TOXPYTHON=%PYTHON_HOME%\\python.exe"
- if "%TOXENV%" == "pypy" devscripts\\CI\\appveyor_install_pypy.cmd - if "%TOXENV%" == "pypy" devscripts\\CI\\appveyor_install_pypy.cmd
- "python --version" - "python --version"
- "python -c \"import struct; print(struct.calcsize('P') * 8)\"" - "python -c \"import struct; print(struct.calcsize('P') * 8)\""
- if "%TOXENV%" == "pypy" SET TOXPYTHON=pypy.exe - if "%TOXENV%" == "pypy" SET TOXPYTHON=pypy.exe
- if "%TOXENV%" == "pypy" pypy --version - if "%TOXENV%" == "pypy" pypy --version
- "python -m pip install --upgrade \"pip < 19.1\" setuptools" - "python -m pip install --upgrade \"pip<19.2\" \"setuptools<44\""
- "pip install --upgrade \"tox < 3.1\" ppu" - "pip install --upgrade \"tox<3.1\" ppu"
- "pip --version" - "pip --version"
# No build step - _namemapper extension will be built under tox # No build step - _namemapper extension will be built under tox
build: false build: false
test_script: test_script:
- "%CMD_IN_ENV% tox" - "%CMD_IN_ENV% tox"
after_test: after_test:
- remove-old-files.py -o 180 %LOCALAPPDATA%\\pip\\Cache - remove-old-files.py -o 180 %LOCALAPPDATA%\\pip\\Cache
deploy_script: deploy_script:
# If tests are successful and we've tested a tag, deploy binary wheel # If tests are successful and we've tested a tag, deploy binary wheel
# TWINE_USERNAME / TWINE_PASSWORD / TWINE_REPOSITORY_URL # TWINE_USERNAME / TWINE_PASSWORD / TWINE_REPOSITORY_URL
# must be set in AppVeyor settings. # must be set in AppVeyor settings.
- if "%APPVEYOR_REPO_TAG%" == "true" ( - if "%APPVEYOR_REPO_TAG%" == "true" (
pip install --upgrade twine "wheel==0.31.1" && if "%PYTHON_VERSION%" == "3.4" (
pip install --upgrade "readme-renderer<25.0" "twine<2.0" "wheel==0.31.1"
) else (
pip install --upgrade twine "wheel==0.34.1"
) &&
%CMD_IN_ENV% python setup.py bdist_wheel && %CMD_IN_ENV% python setup.py bdist_wheel &&
twine upload --skip-existing dist\\*.whl twine upload --skip-existing dist\\*.whl
) )
 End of changes. 5 change blocks. 
5 lines changed or deleted 17 lines changed or added

Home  |  About  |  Features  |  All  |  Newest  |  Dox  |  Diffs  |  RSS Feeds  |  Screenshots  |  Comments  |  Imprint  |  Privacy  |  HTTP(S)