"Fossies" - the Fresh Open Source Software Archive  

Source code changes of the file "package/linux-headers/Config.in.host" between
buildroot-2019.05.1.tar.bz2 and buildroot-2019.08-rc1.tar.bz2

About: Buildroot is a set of Makefiles and patches that makes it easy to generate a complete embedded Linux system. Release candidate.

Config.in.host  (buildroot-2019.05.1.tar.bz2):Config.in.host  (buildroot-2019.08-rc1.tar.bz2)
comment "Kernel Header Options" comment "Kernel Header Options"
config BR2_PACKAGE_HOST_LINUX_HEADERS config BR2_PACKAGE_HOST_LINUX_HEADERS
bool bool
choice choice
prompt "Kernel Headers" prompt "Kernel Headers"
default BR2_KERNEL_HEADERS_AS_KERNEL if BR2_LINUX_KERNEL default BR2_KERNEL_HEADERS_AS_KERNEL if BR2_LINUX_KERNEL
default BR2_KERNEL_HEADERS_5_1 default BR2_KERNEL_HEADERS_5_2
help help
Select the kernel version to get headers from. Select the kernel version to get headers from.
The kernel headers must be at least as old as the oldest The kernel headers must be at least as old as the oldest
kernel you intend to run on your target. kernel you intend to run on your target.
If you use Buildroot to build a kernel, then you can use If you use Buildroot to build a kernel, then you can use
the sources from that kernel as source for the headers. the sources from that kernel as source for the headers.
If you choose a custom version of the kernel headers, or If you choose a custom version of the kernel headers, or
skipping to change at line 32 skipping to change at line 32
can show or hide packages that have strong requirements on the can show or hide packages that have strong requirements on the
kernel headers. kernel headers.
config BR2_KERNEL_HEADERS_AS_KERNEL config BR2_KERNEL_HEADERS_AS_KERNEL
bool "Same as kernel being built" bool "Same as kernel being built"
depends on BR2_LINUX_KERNEL depends on BR2_LINUX_KERNEL
config BR2_KERNEL_HEADERS_4_4 config BR2_KERNEL_HEADERS_4_4
bool "Linux 4.4.x kernel headers" bool "Linux 4.4.x kernel headers"
depends on !BR2_riscv depends on !BR2_riscv
depends on !BR2_csky
select BR2_TOOLCHAIN_HEADERS_AT_LEAST_4_4 select BR2_TOOLCHAIN_HEADERS_AT_LEAST_4_4
config BR2_KERNEL_HEADERS_4_9 config BR2_KERNEL_HEADERS_4_9
bool "Linux 4.9.x kernel headers" bool "Linux 4.9.x kernel headers"
depends on !BR2_riscv depends on !BR2_riscv
depends on !BR2_csky
select BR2_TOOLCHAIN_HEADERS_AT_LEAST_4_9 select BR2_TOOLCHAIN_HEADERS_AT_LEAST_4_9
config BR2_KERNEL_HEADERS_4_14 config BR2_KERNEL_HEADERS_4_14
bool "Linux 4.14.x kernel headers" bool "Linux 4.14.x kernel headers"
depends on !BR2_riscv depends on !BR2_riscv
depends on !BR2_csky
select BR2_TOOLCHAIN_HEADERS_AT_LEAST_4_14 select BR2_TOOLCHAIN_HEADERS_AT_LEAST_4_14
config BR2_KERNEL_HEADERS_4_19 config BR2_KERNEL_HEADERS_4_19
bool "Linux 4.19.x kernel headers" bool "Linux 4.19.x kernel headers"
depends on !BR2_csky
select BR2_TOOLCHAIN_HEADERS_AT_LEAST_4_19 select BR2_TOOLCHAIN_HEADERS_AT_LEAST_4_19
config BR2_KERNEL_HEADERS_5_0
bool "Linux 5.0.x kernel headers"
select BR2_TOOLCHAIN_HEADERS_AT_LEAST_5_0
config BR2_KERNEL_HEADERS_5_1 config BR2_KERNEL_HEADERS_5_1
bool "Linux 5.1.x kernel headers" bool "Linux 5.1.x kernel headers"
select BR2_TOOLCHAIN_HEADERS_AT_LEAST_5_1 select BR2_TOOLCHAIN_HEADERS_AT_LEAST_5_1
config BR2_KERNEL_HEADERS_5_2
bool "Linux 5.2.x kernel headers"
select BR2_TOOLCHAIN_HEADERS_AT_LEAST_5_2
config BR2_KERNEL_HEADERS_VERSION config BR2_KERNEL_HEADERS_VERSION
bool "Manually specified Linux version" bool "Manually specified Linux version"
help help
This option allows you to use a specific official version from This option allows you to use a specific official version from
kernel.org, like 2.6.x, 2.6.x.y, 3.x.y, ... kernel.org, like 2.6.x, 2.6.x.y, 3.x.y, ...
Note: you cannot use this option to select a _longterm_ 2.6 Note: you cannot use this option to select a _longterm_ 2.6
kernel, because these kernels are not located at the standard kernel, because these kernels are not located at the standard
URL at kernel.org. Instead, select "Custom tarball" and URL at kernel.org. Instead, select "Custom tarball" and
specify the right URL directly. specify the right URL directly.
skipping to change at line 121 skipping to change at line 125
bool "Custom kernel headers series" bool "Custom kernel headers series"
depends on BR2_KERNEL_HEADERS_VERSION || BR2_KERNEL_HEADERS_AS_KERNEL || \ depends on BR2_KERNEL_HEADERS_VERSION || BR2_KERNEL_HEADERS_AS_KERNEL || \
BR2_KERNEL_HEADERS_CUSTOM_TARBALL || BR2_KERNEL_HEADERS_CUSTOM _GIT BR2_KERNEL_HEADERS_CUSTOM_TARBALL || BR2_KERNEL_HEADERS_CUSTOM _GIT
help help
Specify the kernel headers series you manually selected, Specify the kernel headers series you manually selected,
above. above.
This is used to hide/show some packages that have strict This is used to hide/show some packages that have strict
requirements on the version of kernel headers. requirements on the version of kernel headers.
config BR2_PACKAGE_HOST_LINUX_HEADERS_CUSTOM_5_2
bool "5.2.x"
select BR2_TOOLCHAIN_HEADERS_AT_LEAST_5_2
config BR2_PACKAGE_HOST_LINUX_HEADERS_CUSTOM_5_1 config BR2_PACKAGE_HOST_LINUX_HEADERS_CUSTOM_5_1
bool "5.1.x" bool "5.1.x"
select BR2_TOOLCHAIN_HEADERS_AT_LEAST_5_1 select BR2_TOOLCHAIN_HEADERS_AT_LEAST_5_1
config BR2_PACKAGE_HOST_LINUX_HEADERS_CUSTOM_5_0 config BR2_PACKAGE_HOST_LINUX_HEADERS_CUSTOM_5_0
bool "5.0.x" bool "5.0.x"
select BR2_TOOLCHAIN_HEADERS_AT_LEAST_5_0 select BR2_TOOLCHAIN_HEADERS_AT_LEAST_5_0
config BR2_PACKAGE_HOST_LINUX_HEADERS_CUSTOM_4_20 config BR2_PACKAGE_HOST_LINUX_HEADERS_CUSTOM_4_20
bool "4.20.x" bool "4.20.x"
skipping to change at line 300 skipping to change at line 308
bool "3.0.x" bool "3.0.x"
select BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_0 select BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_0
config BR2_PACKAGE_HOST_LINUX_HEADERS_CUSTOM_REALLY_OLD config BR2_PACKAGE_HOST_LINUX_HEADERS_CUSTOM_REALLY_OLD
bool "2.6.x" bool "2.6.x"
endchoice endchoice
config BR2_DEFAULT_KERNEL_HEADERS config BR2_DEFAULT_KERNEL_HEADERS
string string
default "4.4.184" if BR2_KERNEL_HEADERS_4_4 default "4.4.186" if BR2_KERNEL_HEADERS_4_4
default "4.9.184" if BR2_KERNEL_HEADERS_4_9 default "4.9.186" if BR2_KERNEL_HEADERS_4_9
default "4.14.132" if BR2_KERNEL_HEADERS_4_14 default "4.14.135" if BR2_KERNEL_HEADERS_4_14
default "4.19.57" if BR2_KERNEL_HEADERS_4_19 default "4.19.63" if BR2_KERNEL_HEADERS_4_19
default "5.0.21" if BR2_KERNEL_HEADERS_5_0 default "5.1.21" if BR2_KERNEL_HEADERS_5_1
default "5.1.16" if BR2_KERNEL_HEADERS_5_1 default "5.2.5" if BR2_KERNEL_HEADERS_5_2
default BR2_DEFAULT_KERNEL_VERSION if BR2_KERNEL_HEADERS_VERSION default BR2_DEFAULT_KERNEL_VERSION if BR2_KERNEL_HEADERS_VERSION
default "custom" if BR2_KERNEL_HEADERS_CUSTOM_TARBALL default "custom" if BR2_KERNEL_HEADERS_CUSTOM_TARBALL
default BR2_KERNEL_HEADERS_CUSTOM_REPO_VERSION \ default BR2_KERNEL_HEADERS_CUSTOM_REPO_VERSION \
if BR2_KERNEL_HEADERS_CUSTOM_GIT if BR2_KERNEL_HEADERS_CUSTOM_GIT
 End of changes. 9 change blocks. 
11 lines changed or deleted 19 lines changed or added

Home  |  About  |  Features  |  All  |  Newest  |  Dox  |  Diffs  |  RSS Feeds  |  Screenshots  |  Comments  |  Imprint  |  Privacy  |  HTTP(S)