"Fossies" - the Fresh Open Source Software Archive  

Source code changes of the file "package.json" between
angular-11.0.1.tar.gz and angular-11.0.2.tar.gz

About: Angular is a development platform for building mobile and desktop web applications using Typescript/JavaScript.

package.json  (angular-11.0.1):package.json  (angular-11.0.2)
{ {
"name": "angular-srcs", "name": "angular-srcs",
"version": "11.0.1", "version": "11.0.2",
"private": true, "private": true,
"description": "Angular - a web framework for modern web apps", "description": "Angular - a web framework for modern web apps",
"homepage": "https://github.com/angular/angular", "homepage": "https://github.com/angular/angular",
"bugs": "https://github.com/angular/angular/issues", "bugs": "https://github.com/angular/angular/issues",
"license": "MIT", "license": "MIT",
"//engines-comment": "Keep this in sync with /aio/package.json and /aio/tools/ examples/shared/package.json", "//engines-comment": "Keep this in sync with /aio/package.json and /aio/tools/ examples/shared/package.json",
"engines": { "engines": {
"node": ">=10.9.0 <13.0.0", "node": ">=10.9.0 <13.0.0",
"yarn": ">=1.22.4 <2" "yarn": ">=1.22.4 <2"
}, },
skipping to change at line 25 skipping to change at line 25
"type": "git", "type": "git",
"url": "https://github.com/angular/angular.git" "url": "https://github.com/angular/angular.git"
}, },
"scripts": { "scripts": {
"/": "", "/": "",
"// 1": "Many developer of our checks/scripts/tools have moved to our ng-dev tool", "// 1": "Many developer of our checks/scripts/tools have moved to our ng-dev tool",
"// 2": "Find the usage you are looking for with:", "// 2": "Find the usage you are looking for with:",
"// 3": "yarn ng-dev --help", "// 3": "yarn ng-dev --help",
"/ ": "", "/ ": "",
"preinstall": "node tools/yarn/check-yarn.js", "preinstall": "node tools/yarn/check-yarn.js",
"postinstall": "node scripts/webdriver-manager-update.js && node --preserve- symlinks --preserve-symlinks-main ./tools/postinstall-patches.js", "postinstall": "husky install && node scripts/webdriver-manager-update.js && node --preserve-symlinks --preserve-symlinks-main ./tools/postinstall-patches.j s",
"check-env": "gulp check-env", "check-env": "gulp check-env",
"test-ivy-aot": "bazelisk test --config=ivy --build_tag_filters=-no-ivy-aot, -fixme-ivy-aot --test_tag_filters=-no-ivy-aot,-fixme-ivy-aot", "test-ivy-aot": "bazelisk test --config=ivy --build_tag_filters=-no-ivy-aot, -fixme-ivy-aot --test_tag_filters=-no-ivy-aot,-fixme-ivy-aot",
"test-non-ivy": "bazelisk test --build_tag_filters=-ivy-only --test_tag_filt ers=-ivy-only", "test-non-ivy": "bazelisk test --build_tag_filters=-ivy-only --test_tag_filt ers=-ivy-only",
"test-fixme-ivy-aot": "bazelisk test --config=ivy --build_tag_filters=-no-iv y-aot --test_tag_filters=-no-ivy-aot", "test-fixme-ivy-aot": "bazelisk test --config=ivy --build_tag_filters=-no-iv y-aot --test_tag_filters=-no-ivy-aot",
"list-fixme-ivy-targets": "bazelisk query --output=label 'attr(\"tags\", \"\ \[.*fixme-ivy.*\\]\", //...) except kind(\"sh_binary\", //...) except kind(\"dev mode_js_sources\", //...)' | sort", "list-fixme-ivy-targets": "bazelisk query --output=label 'attr(\"tags\", \"\ \[.*fixme-ivy.*\\]\", //...) except kind(\"sh_binary\", //...) except kind(\"dev mode_js_sources\", //...)' | sort",
"lint": "yarn -s tslint && yarn -s ng-dev format changed --check", "lint": "yarn -s tslint && yarn -s ng-dev format changed --check",
"tslint": "tsc -p tools/tsconfig.json && tslint -c tslint.json \"+(dev-infra |packages|modules|scripts|tools)/**/*.+(js|ts)\"", "tslint": "tsc -p tools/tsconfig.json && tslint -c tslint.json \"+(dev-infra |packages|modules|scripts|tools)/**/*.+(js|ts)\"",
"public-api:check": "node goldens/public-api/manage.js test", "public-api:check": "node goldens/public-api/manage.js test",
"public-api:update": "node goldens/public-api/manage.js accept", "public-api:update": "node goldens/public-api/manage.js accept",
"symbol-extractor:check": "node tools/symbol-extractor/run_all_symbols_extra ctor_tests.js test", "symbol-extractor:check": "node tools/symbol-extractor/run_all_symbols_extra ctor_tests.js test",
skipping to change at line 156 skipping to change at line 156
"source-map-support": "0.5.9", "source-map-support": "0.5.9",
"sourcemap-codec": "^1.4.8", "sourcemap-codec": "^1.4.8",
"systemjs": "0.18.10", "systemjs": "0.18.10",
"terser": "^4.4.0", "terser": "^4.4.0",
"tsickle": "0.38.1", "tsickle": "0.38.1",
"tslib": "^2.0.0", "tslib": "^2.0.0",
"tslint": "6.1.3", "tslint": "6.1.3",
"typescript": "~4.0.2", "typescript": "~4.0.2",
"xhr2": "0.2.0", "xhr2": "0.2.0",
"yaml": "^1.10.0", "yaml": "^1.10.0",
"yargs": "^15.4.1" "yargs": "^16.1.1"
}, },
"// 2": "devDependencies are not used under Bazel. Many can be removed after t est.sh is deleted.", "// 2": "devDependencies are not used under Bazel. Many can be removed after t est.sh is deleted.",
"devDependencies": { "devDependencies": {
"@angular/cli": "11.0.0-rc.1", "@angular/cli": "11.0.0-rc.1",
"@bazel/bazelisk": "^1.4.0", "@bazel/bazelisk": "^1.4.0",
"@bazel/buildifier": "^0.29.0", "@bazel/buildifier": "^0.29.0",
"@bazel/ibazel": "^0.12.3", "@bazel/ibazel": "^0.12.3",
"@octokit/graphql": "^4.3.1", "@octokit/graphql": "^4.3.1",
"@types/cli-progress": "^3.4.2", "@types/cli-progress": "^3.4.2",
"@types/minimist": "^1.2.0", "@types/minimist": "^1.2.0",
skipping to change at line 182 skipping to change at line 182
"cldr-data-downloader": "0.3.2", "cldr-data-downloader": "0.3.2",
"cldrjs": "0.5.0", "cldrjs": "0.5.0",
"cli-progress": "^3.7.0", "cli-progress": "^3.7.0",
"conventional-changelog": "^2.0.3", "conventional-changelog": "^2.0.3",
"entities": "1.1.1", "entities": "1.1.1",
"firebase-tools": "^7.11.0", "firebase-tools": "^7.11.0",
"firefox-profile": "1.0.3", "firefox-profile": "1.0.3",
"glob": "7.1.2", "glob": "7.1.2",
"gulp": "3.9.1", "gulp": "3.9.1",
"gulp-conventional-changelog": "^2.0.3", "gulp-conventional-changelog": "^2.0.3",
"husky": "^4.2.5", "husky": "5.0.1",
"inquirer": "^7.3.3", "inquirer": "^7.3.3",
"inquirer-autocomplete-prompt": "^1.0.2", "inquirer-autocomplete-prompt": "^1.0.2",
"jpm": "1.3.1", "jpm": "1.3.1",
"karma-browserstack-launcher": "^1.3.0", "karma-browserstack-launcher": "^1.3.0",
"karma-sauce-launcher": "^2.0.2", "karma-sauce-launcher": "^2.0.2",
"madge": "^3.6.0", "madge": "^3.6.0",
"multimatch": "^4.0.0", "multimatch": "^4.0.0",
"mutation-observer": "^1.0.3", "mutation-observer": "^1.0.3",
"nock": "^13.0.3", "nock": "^13.0.3",
"ora": "^5.0.0", "ora": "^5.0.0",
skipping to change at line 212 skipping to change at line 212
"universal-analytics": "0.4.15", "universal-analytics": "0.4.15",
"vlq": "0.2.2", "vlq": "0.2.2",
"vrsource-tslint-rules": "5.1.1" "vrsource-tslint-rules": "5.1.1"
}, },
"// 4": "Overwrite graceful-fs to a version that does not rely on the 'natives ' package. This fixes gulp for >= 10.13, more information: #28213", "// 4": "Overwrite graceful-fs to a version that does not rely on the 'natives ' package. This fixes gulp for >= 10.13, more information: #28213",
"// 5": "Ensure a single version of webdriver-manager so it is hoisted as the integration tests depend on it being found at ../../node_modules/webdriver-manag er", "// 5": "Ensure a single version of webdriver-manager so it is hoisted as the integration tests depend on it being found at ../../node_modules/webdriver-manag er",
"resolutions": { "resolutions": {
"**/graceful-fs": "4.2.2", "**/graceful-fs": "4.2.2",
"**/webdriver-manager": "12.1.7" "**/webdriver-manager": "12.1.7"
}, },
"cldr-data-coverage": "full", "cldr-data-coverage": "full"
"husky": {
"hooks": {
"pre-commit": "yarn -s ng-dev format staged",
"commit-msg": "yarn -s ng-dev commit-message pre-commit-validate --file-en
v-variable HUSKY_GIT_PARAMS",
"prepare-commit-msg": "yarn -s ng-dev commit-message restore-commit-messag
e-draft --file-env-variable HUSKY_GIT_PARAMS"
}
}
} }
 End of changes. 5 change blocks. 
14 lines changed or deleted 5 lines changed or added

Home  |  About  |  Features  |  All  |  Newest  |  Dox  |  Diffs  |  RSS Feeds  |  Screenshots  |  Comments  |  Imprint  |  Privacy  |  HTTP(S)