"Fossies" - the Fresh Open Source Software Archive  

Source code changes of the file "t/35thrclone.t" between
DBI-1.642.tar.gz and DBI-1.643.tar.gz

About: DBI - The Perl Database Interface (requires one or more "driver" modules DBD::* to talk to databases).

35thrclone.t  (DBI-1.642):35thrclone.t  (DBI-1.643)
skipping to change at line 14 skipping to change at line 14
# --- Test DBI support for threads created after the DBI was loaded # --- Test DBI support for threads created after the DBI was loaded
BEGIN { eval "use threads;" } # Must be first BEGIN { eval "use threads;" } # Must be first
my $use_threads_err = $@; my $use_threads_err = $@;
use strict; use strict;
use Config qw(%Config); use Config qw(%Config);
use Test::More; use Test::More;
BEGIN { BEGIN {
if (!$Config{useithreads} || $] < 5.008001) { if (!$Config{useithreads}) {
plan skip_all => "this $^O perl $] not supported for DBI iThreads"; plan skip_all => "this $^O perl $] not supported for DBI iThreads";
} }
die $use_threads_err if $use_threads_err; # need threads die $use_threads_err if $use_threads_err; # need threads
} }
my $threads = 4; my $threads = 4;
plan tests => 4 + 4 * $threads; plan tests => 4 + 4 * $threads;
{ {
package threads_sub; package threads_sub;
 End of changes. 1 change blocks. 
1 lines changed or deleted 1 lines changed or added

Home  |  About  |  Features  |  All  |  Newest  |  Dox  |  Diffs  |  RSS Feeds  |  Screenshots  |  Comments  |  Imprint  |  Privacy  |  HTTP(S)